Please update Cairo-Dock Plug-Ins to 3.0.0 version (stable version)

Bug #983289 reported by Matthieu Baerts on 2012-04-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock-plug-ins (Ubuntu)
Wishlist
Unassigned

Bug Description

Hello,

The Cairo-Dock team proposes a new "bugs fixed" version of their Cairo-Dock packages.

This is the Upstream (short) ChangeLog:
   - Updated translations
   - Moved 'battery' theme from cairo-dock-core to cairo-dock-plug-ins
   - Included here a sound gauge theme for alsaMixer applet from our server in
      order to use the Default-Panel theme without an Internet connexion.
   - Shortcuts: properly initialize the disk structure, to avoid polling non
      writable disks
   - Clipper: fixed a warning when stopping the applet
   - Clock: fixed a small regression: text should be vertically centered
   - dnd2share: Fixed videobin backend and forced curl to follow redirection
   - Clock: numeric: Fixed a typo about the maximum ratio in vertical mode
   - Panel view: fixed the frame drawing (no bottom rounded corners)
   - Messaging-Menu:
    + Some items was not displayed with the latest version of indicator-messages
    + Fixed a few details about the lozenge and the drawing
    + Fixed a tiny memory leak
   - MusicPlayer: Fixed a typo about the detection of the MPRIS2 services for
      handlers with a valid mpris2 string
   - Shortcuts: used a default icon if vfs_backend_get_file_info returns none
      icon name (g_file_info_get_icon seems not able to find an icon for folders
      or drives on KDE)
   - GMenu: checked if alacarte or kmenuedit is available before adding the menu
      entry to launch it (alacarte seems no longer installed by default on new
      distributions with Gnome)
   - PowerManager: if we want to hide the icon, hide it even on desktop when we
      have no information)
   - ShowDesktop: if we can't show the widget layer or present the desktops
      (expo), we now display a warning and use the default action instead of
      doing nothing
   - Switcher: menu: limit windows' title to 50 chars to avoid too larger menus
   - Clipper: Menu entries are now translated
   - Mail: disable the RSS feed for Gmail, as it is not working any more with the
      current GMail authentification system; use IMAP instead
   - Status-Notifier: Removed an unused function
   - stdout: removed a lot of g_print functions (or replaced by cd_debug)
   - Clock: fixed the text drawing: avoid any stretching of the text

This bzr branch has been linked to this bug report: lp:~cairo-dock-team/ubuntu/precise/cairo-dock-plug-ins/3.0.0.1
This branch should be ready to be pushed on lp:ubuntu/cairo-dock-plug-ins (except the UNRELEASED version in debian/changelog)

@ubuntu-release team: This is a "bugs fixed" version of the previous RC and the diff is huge mainly because of the update of po files and also because we have renamed default theme, included 'Default-Panel' theme from our servers for those without an Internet connexion and moved gauges themes to 'cairo-dock-plug-ins'
Changes are detailed here and the reason to upload this version on Precise is simply to fix all these bugs and UI details :)
It only impacts Cairo-Dock packages so it's not a problem for other Ubuntu packages ;)
Also, I've compiled these packages on my pc with pbuilder and this version is also available on this public ppa: ppa:cairo-dock-team/ppa
https://launchpad.net/~cairo-dock-team/+archive/ppa/+packages

Thank you for your help! ;)

PS: 'cairo-dock' package has to be uploaded before this package! (if possible, 30min before) ( LP: #983288 )

Related branches

Scott Kitterman (kitterman) wrote :

Ack. Approved.

Changed in cairo-dock-plug-ins (Ubuntu):
importance: Undecided → Wishlist
milestone: none → ubuntu-12.04
status: New → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package cairo-dock-plug-ins - 3.0.0.1-0ubuntu1

---------------
cairo-dock-plug-ins (3.0.0.1-0ubuntu1) precise; urgency=low

  * New upstream release. (LP: #983289)
  * Upstream ChangeLog:
   - Updated translations
   - Moved 'battery' theme from cairo-dock-core to cairo-dock-plug-ins
   - Included here a sound gauge theme for alsaMixer applet from our server in
      order to use the Default-Panel theme without an Internet connexion.
   - Shortcuts: properly initialize the disk structure, to avoid polling non
      writable disks
   - Clipper: fixed a warning when stopping the applet
   - Clock: fixed a small regression: text should be vertically centered
   - dnd2share: Fixed videobin backend and forced curl to follow redirection
   - Clock: numeric: Fixed a typo about the maximum ratio in vertical mode
   - Panel view: fixed the frame drawing (no bottom rounded corners)
   - Messaging-Menu:
    + Some items was not displayed with the latest version of indicator-messages
    + Fixed a few details about the lozenge and the drawing
    + Fixed a tiny memory leak
   - MusicPlayer: Fixed a typo about the detection of the MPRIS2 services for
      handlers with a valid mpris2 string
   - Shortcuts: used a default icon if vfs_backend_get_file_info returns none
      icon name (g_file_info_get_icon seems not able to find an icon for folders
      or drives on KDE)
   - GMenu: checked if alacarte or kmenuedit is available before adding the menu
      entry to launch it (alacarte seems no longer installed by default on new
      distributions with Gnome)
   - PowerManager: if we want to hide the icon, hide it even on desktop when we
      have no information)
   - ShowDesktop: if we can't show the widget layer or present the desktops
      (expo), we now display a warning and use the default action instead of
      doing nothing
   - Switcher: menu: limit windows' title to 50 chars to avoid too larger menus
   - Clipper: Menu entries are now translated
   - Mail: disable the RSS feed for Gmail, as it is not working any more with the
      current GMail authentification system; use IMAP instead
   - Status-Notifier: Removed an unused function
   - stdout: removed a lot of g_print functions (or replaced by cd_debug)
   - Clock: fixed the text drawing: avoid any stretching of the text
  * This 3.0 series (and previous series) also fixes these bugs:
   - "Cairo-dock plugin musicPlayer loads ridiculous covers" (LP: #538569)
   - "Songbird support outdated in musicPlayer" (LP: #538361)
   - "Trash applet detects drag-and-dropped items twice" (LP: #530975)
   - "Lock screen does not work in GNOME 3" (LP: #943533)
   - "Sound volume don't work on the cairo-dock of my computer after a killall
       pulseaudio" (LP: #913101)
   - "Logout Applet needs guest session menu" (LP: #757193)
   - "Trash not emptied with folders from other partitions" (LP: #686564)
   - "Incorrect down/up speeds in Netspeed" (LP: #672452)
   - "the desklet 'meteo' gone freeze, and if i try to change localization crashes
       all cairo, that became black" (LP: #671261)
   - "Clipper action failed on other WM than kde gnome xfce" (LP: #664089)
   - "Crashed ...

Read more...

Changed in cairo-dock-plug-ins (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers