Please update Cairo-Dock Plug-Ins to 2.4.0~1 version (bugs fixed version)

Bug #859984 reported by Matthieu Baerts on 2011-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock-plug-ins (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

The Cairo-Dock team proposes a new version of its Cairo-Dock packages.

This is the Upstream (short) ChangeLog:
 * Upstream (short) ChangeLog (2.4.0~0beta2 -> 2.4.0~1):
   - Powermanager: correctly release the reference on the device object
   - logout: now works if there is no session-manager
   - Status-Notifier: fixed a small bug
      (wrong callback in cairo_dock_stop_watching_dbus_name_owner)
   - Folders: fixed the positionning of the new icon
      and the dialog when dropping a folder inside the dock
      and fixed the icon-rendering
   - Dustbin: use the default theme if no icon is found
   - Impulse: the default context seems to be ok and not an error
   - Status-Notifier: On Ubuntu Oneiric (with indicator-0.4)
      the ApplicationAdded signal has changed and has a new parameter
   - Disable MeMenu on Oneiric (no longer available with indicator-0.4)
   - CMakeLists.txt: Improved output messages
   - Slide view: fixed a small offset in vertical view
   - musicPlayer:
    + split MPRIS 1.0 and 2.0 to help debugging and finding the right
       name of the bug.
    + 'rhythmbox-client' tool is no longer available: used MPRIS
    + Disable Amazon service (it no longer work)
    + Cover: fixed corrupted icons: some players (e.g. the latest version
       of RB) copy covers on their cache forlder but it takes a few time.
    + Fixed the update the icon and its name if the player is stopped.
    + Prevent a crash if the name given by MPRIS is NULL
   - Powermanager: try to prevent to have a few dialogues at the same time
   - PowerManager and AlsaMixer: hidden gnome2 or 3 apps if not available
   - Messaging-Menu: Updated for Natty and Oneiric
      (dbus-menu gives us GVariant instead of GValue objects)
   - Alsamixer: fixed a small bug on reload
   - Dbus: Bash interface: Fixed a typo with emblem positions
   - Sys-monitor: fixed a bug which prevented from getting
      the CPU temperature in some cases
   - Compiz (0.9): type filter: replaced type=utility by type=Utility
   - Updated the version of all applets that have gauges
     in order to use the right directory
   - Wifi: Fixed the status if we are not connected
   - Dbus: removed a conflict with the Help applet
   - Messaging-Menu: updated applet-menu.c => Memory leaks on pixbufs
   - Dbus: Fixed a crash when changing dock theme if a 'third-party' applet
      is running
   - Netspeed: in /proc/net/dev, there are 8 values to drop after the card id
      except if there is whitespaces just after this ':' character
      and fixed order and value for ON_ICON display
   - dock-rendering/toto: removed a useless file
   - Clipper: fixed the loading of the remembered items
      (they had the wrong type) and fixed a bug if we reduce the list of items
   - Folders, dustbin, Network-Monitor: tried to not use cast if it's possible
   - Code cleaned and re-organised a few functions
     (e.g. emblem references has been renamed)
   - Removed useless files: powermanager-dbus*
   - Updating translations
   - Fixed a few warnings at the compilation
   - Removed a few useless output messages
   - Fixed these LP bugs:
    + Empty trash from the trashcan does not delete files
       from usb harddisks: LP: #658681
    + Switcher applet doesn't respect desktop numbers LP: #626782

Note that this is the stable version of the 2.4 branch. It fixes a lot of bugs of the previous version (2.4.0~0beta2).

This bzr branch has been linked to this bug report: lp:~cairo-dock-team/ubuntu/oneiric/cairo-dock-plug-ins/2.4.0-1
This branch should be ready to be pushed on lp:ubuntu/cairo-dock-plug-ins (except the UNRELEASED version in debian/changelog)

Thank you for your help! :)

PS: Don't forget to upload this package AND THE CORE ( LP: #859982 )

Related branches

description: updated
description: updated
summary: - Please update Cairo-Dock (core) to 2.4.0~1 version (bugs fixed version)
+ Please update Cairo-Dock Plug-Ins to 2.4.0~1 version (bugs fixed
+ version)
Fabrice Coutadeur (fabricesp) wrote :

Hi,

As we are actually in Feature Freeze period (and very near from the release date), and given that this is a new upstream release, please follow the FFe process describe at https://wiki.ubuntu.com/FreezeExceptionProcess.

As soon as you get the FFe, please subscribe again the sponsors.

Thanks,
Fabrice

Changed in cairo-dock-plug-ins (Ubuntu):
status: New → Incomplete
Matthieu Baerts (matttbe) wrote :

@ubuntu-release team: It seems we have to follow the FFe process but this is a bug fixed version (the previous version was the second beta release of this new 2.4.0 version)
Translations are much better and it fixes a few annoying problems (see the ChangeLog here above). Please upload this version because the previous one was a beta version.
Please help us because due to all the recent changes in Ubuntu, we need this version to keep the program running well in Oneiric
(I'm thinking of all the changes in the DBus interfaces for instance, Compiz, Messaging-Menu, the Gnome-Panel, XFCE, Gnome3 and others). Cairo-Dock 2.3 just can't run in Oneiric, and 2.4.0-beta ... well, is a beta and many things have changed just before the FF!

This new version is also available on this ppa:cairo-dock-team/ppa and used by many people. We use this version on our ppa and it's not so different than the previous beta version with a lot of fixed bugs and many improvements!

About the build log, this file has been joined to this bug report: cairo-dock-plug-ins_2.4.0~2-0ubuntu1.build.log.gz

Thank you for your help

PS: don't forget the core ( LP: #859982 )

Matthieu Baerts (matttbe) wrote :
Changed in cairo-dock-plug-ins (Ubuntu):
status: Incomplete → New
Martin Pitt (pitti) wrote :

This looks fine to me, approved. Please upload it as soon as possible, thanks!

Changed in cairo-dock-plug-ins (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

Sponsored. I noticed one thing that you should fix for next time though: the location of your plugin in /usr/lib/cli/; it should be /usr/lib/cli/upstream_package_name/blah.dll. Please see http://pkg-mono.alioth.debian.org/cli-policy/ch-packaging.html#s-file-locations for more.

Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package cairo-dock-plug-ins - 2.4.0~2-0ubuntu1

---------------
cairo-dock-plug-ins (2.4.0~2-0ubuntu1) oneiric; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream bug fix release. (LP: #859984)
  * Upstream (short) ChangeLog (2.4.0~0beta2 -> 2.4.0~1):
   - Powermanager: correctly release the reference on the device object
   - logout: now works if there is no session-manager
   - Status-Notifier: fixed a small bug
      (wrong callback in cairo_dock_stop_watching_dbus_name_owner)
   - Folders: fixed the positionning of the new icon
      and the dialog when dropping a folder inside the dock
      and fixed the icon-rendering
   - Dustbin: use the default theme if no icon is found
   - Impulse: the default context seems to be ok and not an error
   - Status-Notifier: On Ubuntu Oneiric (with indicator-0.4)
      the ApplicationAdded signal has changed and has a new parameter
   - Disable MeMenu on Oneiric (no longer available with indicator-0.4)
   - CMakeLists.txt: Improved output messages
   - Slide view: fixed a small offset in vertical view
   - musicPlayer:
    + split MPRIS 1.0 and 2.0 to help debugging and finding the right
       name of the bug.
    + 'rhythmbox-client' tool is no longer available: used MPRIS
    + Disable Amazon service (it no longer work)
    + Cover: fixed corrupted icons: some players (e.g. the latest version
       of RB) copy covers on their cache forlder but it takes a few time.
    + Fixed the update the icon and its name if the player is stopped.
    + Prevent a crash if the name given by MPRIS is NULL
   - Powermanager: try to prevent to have a few dialogues at the same time
   - PowerManager and AlsaMixer: hidden gnome2 or 3 apps if not available
   - Messaging-Menu: Updated for Natty and Oneiric
      (dbus-menu gives us GVariant instead of GValue objects)
   - Alsamixer: fixed a small bug on reload
   - Dbus: Bash interface: Fixed a typo with emblem positions
   - Sys-monitor: fixed a bug which prevented from getting
      the CPU temperature in some cases
   - Compiz (0.9): type filter: replaced type=utility by type=Utility
   - Updated the version of all applets that have gauges
     in order to use the right directory
   - Wifi: Fixed the status if we are not connected
   - Dbus: removed a conflict with the Help applet
   - Messaging-Menu: updated applet-menu.c => Memory leaks on pixbufs
   - Dbus: Fixed a crash when changing dock theme if a 'third-party' applet
      is running
   - Netspeed: in /proc/net/dev, there are 8 values to drop after the card id
      except if there is whitespaces just after this ':' character
      and fixed order and value for ON_ICON display
   - dock-rendering/toto: removed a useless file
   - Clipper: fixed the loading of the remembered items
      (they had the wrong type) and fixed a bug if we reduce the list of items
   - Folders, dustbin, Network-Monitor: tried to not use cast if it's possible
   - Code cleaned and re-organised a few functions
     (e.g. emblem references has been renamed)
   - Removed useless files: powermanager-dbus*
   - Updating translations
   - Fixed a few warnings at the compilation
   - Removed a few usele...

Read more...

Changed in cairo-dock-plug-ins (Ubuntu):
status: Confirmed → Fix Released
Matthieu Baerts (matttbe) wrote :

@laney: thank you for your help!
I'm going to fix this problem directly in lp:cairo-dock-plug-ins!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers