Please update Cairo-Dock Plug-Ins to 2.3.0~3 version (bugs fixed only)

Bug #799774 reported by Matthieu Baerts on 2011-06-20
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cairo-dock-plug-ins (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: cairo-dock-plug-ins

Hello,

The Cairo-Dock team proposes a bugs fixed version for its 2.3.0 branch.

This is the ChangeLog:
  * From 2.3.0~1 to 2.3.0~2:
   - Fixed a typo in CMakeLists.txt about Ruby interface.
   - CMakeLists.txt: Added the status of applets (stable/unstable/unsupported) to help packagers to not include unstable or unsupported applets on Cairo-Dock packages for stable distributions.
  * From 2.3.0~2 to 2.3.0~3:
   - Status Notifier: enable translations (fixed a typo)
   - Weather: prevent a crash if there is an error (Thanks to Tsu Jan & Fabounet)
   - dnd2share: avoid a crash of u1sdtool (already fixed in the 2.3.0~2.1 release)

Bzr branches have been linked to this bug report.

How to reproduce the bugs:
   * Simply drop a file into the Drop to Share (aka DND2Share) applet configured to use UbuntuOne and u1sdtool will crash.
   * If the connection is stopped/slowed down during the download of weather xml files, the dock (version 2.3.0~1 and 2.3.0~2.1) will crash.
   * Translations of Status Notifier applet are not enabled.

Thank you

PS: please don't forget to update the core too (LP: #799773)

Related branches

tags: added: upgrade-software-version
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Confirmed in Oneiric. Setting to High because it prevent cairo-dock from installing.

Changed in cairo-dock-plug-ins (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: oneiric
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 2.3.0~3-0ubuntu1

---------------
cairo-dock-plug-ins (2.3.0~3-0ubuntu1) oneiric; urgency=low

  * New upstream release. (LP: #799774)
  * Upstream ChangeLog:
   - Status Notifier: enable translations (fixed a typo)
   - Weather: prevent a crash if there is an error (LP: #788437)
   - dnd2share: avoid a crash of u1sdtool
  * debian/patches:
   - Removed all patches (now in upstream)
  * debian/control:
   - Updated version
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 05 Jul 2011 13:45:43 -0400

Changed in cairo-dock-plug-ins (Ubuntu):
status: Triaged → Fix Released
Quackers (quackers) wrote :

Thanks for the fix :-)
Seems to be working now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers