showDesktop Applet only seems to work every second time you click on it.

Bug #489349 reported by z-ro.one on 2009-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock-plug-ins (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cairo-dock-plug-ins

showDesktop Applet only seems to work every second time you click on it. First time nothing happens then when u click again it shows/hides all windows as it should on the first click already. Im using Ubuntu 9.10, 64-Bit... Cairo-Dock is version 2.1.1-2 (current version from the repo as I write this).

Related branches

Fabounet (fabounet03) wrote :

Hi,
could you please precise :
- your window manager
- if you have some desklet on your desktop.
Thanks.

z-ro.one (z-ro-ice) wrote :

Im using the standard with Ubuntu 9.10 .. thats gnome desktop i guess.

Using emerald skin, no desklets.. only cairo dock, but still one normal gnome panel.

Have only one dock at buttom of screen, apps and starters can merge activated.

In the dock I have gmenu, showDesktop, and shortcuts apps, rest only starters. No undocked desklets.

z-ro.one (z-ro-ice) wrote :

also I just noticed lately that some other starters also dont always start right as I click them the first time.

Im pretty sure it happened on firefox before, where I had to click it twice to get it to start.

I have autohide on too, and the default skin.. how do i change the dock color btw? I'd like to get it darker.. like black plastic or so

ok, could you please find a way to reproduce these behaviors, so that I can
possibly fix them ?
as for the customisation of your theme, you can visit the wiki, there is a
complete tutorial that will certainly help you ;-)

2009/12/4 z-ro.one <email address hidden>

> also I just noticed lately that some other starters also dont always
> start right as I click them the first time.
>
> Im pretty sure it happened on firefox before, where I had to click it
> twice to get it to start.
>
> I have autohide on too, and the default skin.. how do i change the dock
> color btw? I'd like to get it darker.. like black plastic or so
>
> --
> showDesktop Applet only seems to work every second time you click on it.
> https://bugs.launchpad.net/bugs/489349
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to cairo-dock-plug-ins in ubuntu.
>
> Status in “cairo-dock-plug-ins” package in Ubuntu: New
>
> Bug description:
> Binary package hint: cairo-dock-plug-ins
>
> showDesktop Applet only seems to work every second time you click on it.
> First time nothing happens then when u click again it shows/hides all
> windows as it should on the first click already. Im using Ubuntu 9.10,
> 64-Bit... Cairo-Dock is version 2.1.1-2 (current version from the repo as I
> write this).
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

z-ro.one (z-ro-ice) wrote :

z-ro-one@z-ro-one-laptop:~$ cairo-dock -o
warning : (cairo-dock-modules.c:cairo_dock_preload_module_from_directory:376)
  while opening module '/usr/lib/cairo-dock/libcd_xfce-integration.so' : (libthunar-vfs-1.so.2: cannot open shared object file: No such file or directory)
gtk_widget_get_gl_context: assertion `GTK_IS_WIDGET (widget)' failed
OpenGL version: 2.1.2 NVIDIA 173.14.20
OpenGL vendor: NVIDIA Corporation
OpenGL renderer: Quadro NVS 110M/PCI/SSE2
if your drivers are crappy, we'll know it immediately ... ok, they seem fine enough.
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:182)
  Die Schlüsselwertedatei enthält nicht den Schlüssel »scroll speed«
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:182)
  Die Schlüsselwertedatei enthält nicht den Schlüssel »scroll accel«
cairo_dock_replace_values_in_conf_file (/home/z-ro-one/.config/cairo-dock/current_theme/plug-ins/rendering/rendering.conf)
(null) -> -1;-1
_cd_find_volume_name_from_drive_name: assertion `pDrive != NULL' failed
cairo_dock_refresh_launcher_gui ()
cairo_dock_show_hide_desktop (1)
cairo_dock_show_hide_desktop (1)
cairo_dock_show_hide_desktop (0)
cairo_dock_show_hide_desktop (0)
cairo_dock_show_hide_desktop (1)
cairo_dock_show_hide_desktop (1)
cairo_dock_show_hide_desktop (0)
cairo_dock_show_hide_desktop (0)

z-ro.one (z-ro-ice) wrote :

with the new version it works fine!

Fabounet (fabounet03) wrote :

ok, well let's assume it has been fixed then :-)

2009/12/9 z-ro.one <email address hidden>

> with the new version it works fine!
>
> --
> showDesktop Applet only seems to work every second time you click on it.
> https://bugs.launchpad.net/bugs/489349
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to cairo-dock-plug-ins in ubuntu.
>
> Status in “cairo-dock-plug-ins” package in Ubuntu: New
>
> Bug description:
> Binary package hint: cairo-dock-plug-ins
>
> showDesktop Applet only seems to work every second time you click on it.
> First time nothing happens then when u click again it shows/hides all
> windows as it should on the first click already. Im using Ubuntu 9.10,
> 64-Bit... Cairo-Dock is version 2.1.1-2 (current version from the repo as I
> write this).
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 2.1.3-10-lucid-0ubuntu1

---------------
cairo-dock-plug-ins (2.1.3-10-lucid-0ubuntu1) lucid; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream release (LP: #568083)
  * Fixed some bugs:
   - LP: #455261 (Cannot Modify / Add Custom Launchers)
   - LP: #449422 (Cairo-Dock resize problem)
   - LP: #489349 (showDesktop Applet only seems to work
          every second time you click on it)
   - LP: #526742 (The system monitor plugin and netspeed
          plugin inverts upside-down continuously)
   - Dbus: Used the right DBus API of Cairo-Dock (2.1.3 stable)
   - Used icons of the system
   - alsaMixer: fixed a crash when read several xml data
   - musicPlayer:
    * Removed some annoying warnings
    * Banshee-plugin: fixed some bugs due to the new version (1.4.0)

  [ Iain Lane ]
  * debian/watch: Update to match against current version
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 20 Apr 2010 01:52:21 +0200

Changed in cairo-dock-plug-ins (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers