package ca-certificates 20150426ubuntu1 failed to install/upgrade: triggers looping, abandoned

Bug #1541716 reported by JWright on 2016-02-04
172
This bug affects 37 people
Affects Status Importance Assigned to Milestone
ca-certificates (Ubuntu)
High
Unassigned

Bug Description

during installations on a dell laptop latitude d830

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: ca-certificates 20150426ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
Date: Wed Feb 3 22:29:11 2016
ErrorMessage: triggers looping, abandoned
InstallationDate: Installed on 2016-02-04 (0 days ago)
InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160103)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.1.10
SourcePackage: ca-certificates
Title: package ca-certificates 20150426ubuntu1 failed to install/upgrade: triggers looping, abandoned
UpgradeStatus: No upgrade log present (probably fresh install)

JWright (arizonawrights) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ca-certificates (Ubuntu):
status: New → Confirmed
Changed in ca-certificates (Ubuntu):
importance: Undecided → High
Simon Déziel (sdeziel) wrote :

Looks like a circular dependency that has nothing to do with ca-certificates:

dpkg: cycle found while processing triggers:
 chain of packages whose triggers are or may be responsible:
  gconf2 -> gconf2
 packages' pending triggers which are or may be unresolvable:
  ca-certificates: update-ca-certificates

ca-certificates postinst is not run because it waits for the dpkg problem to be solved first.

Simon Déziel (sdeziel) wrote :

Looks like a circular dependency that has nothing to do with ca-certificates:

dpkg: cycle found while processing triggers:
 chain of packages whose triggers are or may be responsible:
  gconf2 -> gconf2
 packages' pending triggers which are or may be unresolvable:
  ca-certificates: update-ca-certificates

ca-certificates postinst is not run because it waits for the other packages to be taken care of.

gravy45 (gravy45) wrote :

Also add: Package ca-certificates 20160104ubuntu1 failed to install/upgrade: triggers looping, abandoned

Karl Bauers (ktb2010) wrote :

New distro package 16.04 LTS cancelled and not installed. Will try again at later time.

picko (f2272442) wrote :

I got this when upgrading from 14.04.1 LTS.

Removing ca-certificates-java (20130815ubuntu1) ...
Removing openjdk-7-jre-headless:amd64 (7u101-2.6.6-0ubuntu0.14.04.1) ...
dpkg: cycle found while processing triggers:
 chain of packages whose triggers are or may be responsible:
  man-db -> ca-certificates
 packages' pending triggers which are or may be unresolvable:
  ca-certificates: update-ca-certificates
  man-db: /usr/share/man
  gconf2: /usr/share/GConf/gsettings
dpkg: error processing package ca-certificates (--remove):
 triggers looping, abandoned
Errors were encountered while processing:
 ca-certificates
Error in function:

A fatal error occurred

Please report this as a bug and include the files
/var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in
your report. The upgrade has aborted.
Your original sources.list was saved in
/etc/apt/sources.list.distUpgrade.

SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

Could not install the upgrades

The upgrade has aborted. Your system could be in an unusable state. A
recovery will run now (dpkg --configure -a).

Please report this bug in a browser at
http://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+filebug
and attach the files in /var/log/dist-upgrade/ to the bug report.
installArchives() failed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers