ca-certificates-java misses runtime dependency on initscripts

Bug #1307883 reported by Rolf Leggewie on 2014-04-15
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ca-certificates-java (Ubuntu)
Undecided
Unassigned
openjdk-7 (Ubuntu)
Undecided
Unassigned
openjdk-8 (Ubuntu)
Undecided
Unassigned
util-linux (Ubuntu)
Undecided
Unassigned

Bug Description

Jitsi build-depends on openjdk-7-jre but the package fails to install in pbuilder and thus I currently cannot build the package. Here is the output I get while I am logged in to the trusty chroot.

# aptitude install default-jdk
[...]
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up ca-certificates-java (20130815ubuntu1) ...
/var/lib/dpkg/info/ca-certificates-java.postinst: line 90: mountpoint: command not found
the keytool command requires a mounted proc fs (/proc).
dpkg: error processing package ca-certificates-java (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up openjdk-7-jre-headless:i386 (7u51-2.4.6-1ubuntu4) ...
/var/lib/dpkg/info/openjdk-7-jre-headless:i386.postinst: 18: /var/lib/dpkg/info/openjdk-7-jre-headless:i386.postinst: mountpoint: not found
the java command requires a mounted proc fs (/proc).
dpkg: error processing package openjdk-7-jre-headless:i386 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up default-jre-headless (2:1.7-51) ...
dpkg: dependency problems prevent configuration of openjdk-7-jre:i386:
 openjdk-7-jre:i386 depends on openjdk-7-jre-headless (= 7u51-2.4.6-1ubuntu4); however:
  Package openjdk-7-jre-headless:i386 is not configured yet.

dpkg: error processing package openjdk-7-jre:i386 (--configure):
 dependency problems - leaving unconfigured
Setting up default-jre (2:1.7-51) ...
dpkg: dependency problems prevent configuration of openjdk-7-jdk:i386:
 openjdk-7-jdk:i386 depends on openjdk-7-jre (= 7u51-2.4.6-1ubuntu4); however:
  Package openjdk-7-jre:i386 is not configured yet.

dpkg: error processing package openjdk-7-jdk:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-jdk:
 default-jdk depends on openjdk-7-jdk (>= 7~u3-2.1.1); however:
  Package openjdk-7-jdk:i386 is not configured yet.

dpkg: error processing package default-jdk (--configure):
 dependency problems - leaving unconfigured
Processing triggers for ca-certificates (20130906ubuntu2) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
/etc/ca-certificates/update.d/jks-keystore: 33: /etc/ca-certificates/update.d/jks-keystore: mountpoint: not found
the keytool command requires a mounted proc fs (/proc).
E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
done.
Errors were encountered while processing:
 ca-certificates-java
 openjdk-7-jre-headless:i386
 openjdk-7-jre:i386
 openjdk-7-jdk:i386
 default-jdk

# mount
/proc on /proc type proc (rw,relatime)
tmpfs on /run/shm type tmpfs (rw,relatime)
/dev/pts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)

Rolf Leggewie (r0lf) on 2014-04-15
description: updated
description: updated
Rolf Leggewie (r0lf) wrote :

nevermind, it seems my pbuilder chroot was missing th required package initscripts.

Changed in openjdk-7 (Ubuntu):
status: New → Invalid
Rolf Leggewie (r0lf) wrote :

reopening for ca-certificates-java

affects: openjdk-7 (Ubuntu) → ca-certificates-java (Ubuntu)
Changed in ca-certificates-java (Ubuntu):
status: Invalid → New
summary: - openjdk-7-jre fails to install in pbuilder chroot
+ ca-certificates-java misses runtime dependency on initscripts
Adam Conrad (adconrad) wrote :

This is likely due to initscripts having been transitively Essential due to util-linux depending on upstart-job in older releases and no longer doing so in trusty.

util-linux in Debian depends on initscripts, which keeps this stack Essential, and we should probably revert that tiny bit of our delta to do the same for now, unless we want to be more explicit about initscripts being truly Essential.

Either way, not depending on packages that aren't "Essential: yes", even if they're currently transitively Essential, is a bug But I'd prefer not tripping over this bug a few days before release either, so I think we should "fix" initscripts' status for now, and fix buggy packages later.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package util-linux - 2.20.1-5.1ubuntu19

---------------
util-linux (2.20.1-5.1ubuntu19) trusty; urgency=medium

  * Re-introduce the initscripts dep to bring back the transitively
    essential status for the /bin/mountpoint binary. (LP: #1307883)
 -- Adam Conrad <email address hidden> Tue, 15 Apr 2014 20:30:24 +0100

Changed in util-linux (Ubuntu):
status: New → Fix Released
Adam Conrad (adconrad) wrote :

util-linux (2.20.1-5.1ubuntu20) trusty; urgency=medium

  * Revert the previous change, as it subtly perturbs apt's unlooping
    algorithms and causes upgrade failures from saucy (see LP1307883)

 -- Adam Conrad <email address hidden> Wed, 16 Apr 2014 16:41:35 +0100

Changed in util-linux (Ubuntu):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ca-certificates-java (Ubuntu):
status: New → Confirmed
Changed in openjdk-7 (Ubuntu):
status: New → Confirmed

I'm seeing this same issue on a minimal Ubuntu/trusty chroot, where I deliberately didn't want initscripts and upstart installed. Using minimal chroots is very useful for running automated build infrastructure. The chroots can serve as stand-ins for full systems or VMs. Since the base system provides the whole system, including daemons, init, etc. the chroot does not need this stuff, and indeed it can get in the way.

This worked before, since I was able to set up this chroot a while back and use it. I think I set it up around Sept 2014.

Here's the error:
Setting up openjdk-7-jre-headless:amd64 (7u71-2.5.3-0ubuntu0.14.04.1) ...
/var/lib/dpkg/info/openjdk-7-jre-headless:amd64.postinst: 18: /var/lib/dpkg/info/openjdk-7-jre-headless:amd64.postinst: mountpoint: not found
the java command requires a mounted proc fs (/proc).
dpkg: error processing package openjdk-7-jre-headless:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of openjdk-7-jre:amd64:
 openjdk-7-jre:amd64 depends on openjdk-7-jre-headless (= 7u71-2.5.3-0ubuntu0.14.04.1); however:
  Package openjdk-7-jre-headless:amd64 is not configured yet.

David Daynard (nardholio) wrote :

This also affects the new beta Ubuntu on Windows

Ignacio (ignacioiglecast) wrote :

Yes, same problem here with Ubuntu on Windows.

no longer affects: openjdk
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-8 (Ubuntu):
status: New → Confirmed
Narcis Garcia (narcisgarcia) wrote :

Same problem here with a Debian 8 when doing:

apt-get install default-jre icedtea-plugin openjdk-7-jre

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers