bzrtools version 2.4.0~bzr767-2ubuntu1 failed to build in oneiric

Bug #829494 reported by Matthias Klose on 2011-08-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzrtools (Debian)
Fix Released
Unknown
bzrtools (Ubuntu)
High
Jelmer Vernooij
Oneiric
High
Jelmer Vernooij

Bug Description

bzrtools version 2.4.0~bzr767-2ubuntu1 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2689767

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2689767/+files/buildlog_ubuntu-oneiric-i386.bzrtools_2.4.0%7Ebzr767-2ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 870 lines into the build log:

    import graph
  File "/build/buildd/bzrtools-2.4.0~bzr767/graph.py", line 23, in <module>
    from bzrlib.deprecated_graph import node_distances, select_farthest
ImportError: No module named deprecated_graph
------------

----------------------------------------------------------------------
Ran 83 tests in 25.617s

FAILED (errors=1)
Missing feature 'bzrlib.plugins.bzrtools.zap.PipelinePluginFeature' skipped 3 tests.
make[1]: *** [override_dh_auto_test] Error 1
make[1]: Leaving directory `/build/buildd/bzrtools-2.4.0~bzr767'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110817-0026
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/bzrtools-2.4.0~bzr767

Matthias Klose (doko) on 2011-08-19
Changed in bzrtools (Ubuntu):
milestone: none → ubuntu-11.10-beta-1
status: New → Confirmed
importance: Undecided → High
Jelmer Vernooij (jelmer) on 2011-08-19
Changed in bzrtools (Ubuntu Oneiric):
assignee: nobody → Jelmer Vernooij (jelmer)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzrtools - 2.4.0-1ubuntu1

---------------
bzrtools (2.4.0-1ubuntu1) oneiric; urgency=low

  * Merge from Debian, remaining changes.
   + Disable use of subunit, which is not in main.
  * New upstream release.
   + Fixes compatibility with newer versions of bzr. LP: #829494
   + Only bug fixes since last upstream snapshot (r767).
 -- Jelmer Vernooij <email address hidden> Fri, 19 Aug 2011 16:31:22 +0200

Changed in bzrtools (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in bzrtools (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.