bzr-builddeb version 2.7.7 failed to build in oneiric

Bug #831351 reported by Matthias Klose on 2011-08-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr (Debian)
Fix Released
Unknown
bzr (Ubuntu)
High
Jelmer Vernooij
Oneiric
High
Jelmer Vernooij

Bug Description

bzr-builddeb version 2.7.7 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2689746

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2689746/+files/buildlog_ubuntu-oneiric-i386.bzr-builddeb_2.7.7_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1304 lines into the build log:

    _repack_other(target_transport, new_name, source_name)
  File "/build/buildd/bzr-builddeb-2.7.7/repack_tarball.py", line 209, in _repack_other
    target_f = target_transport.open_write_stream(new_name)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/local.py", line 331, in open_write_stream
    handle = osutils.open_file(abspath, 'wb')
IOError: [Errno 20] Not a directory: u'/tmp/testbzr-Jyt_h5.tmp/bzrlib.plugins.builddeb.tests.test_repack_tarball.TestRepackTarball.test_repack_tarball_with_target_dir_not_dir(.tar)/work/tarballs/package_0.2.orig.tar.gz'
------------

----------------------------------------------------------------------
Ran 472 tests in 96.228s

FAILED (errors=7)
3 tests skipped
make: *** [build-python2.7] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110820-1803
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/bzr-builddeb-2.7.7

Related branches

Matthias Klose (doko) on 2011-08-22
Changed in bzr-builddeb (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Jelmer Vernooij (jelmer) on 2011-08-22
Changed in bzr-builddeb (Ubuntu Oneiric):
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr-builddeb (Debian):
status: Unknown → Confirmed
Jelmer Vernooij (jelmer) on 2011-08-23
Changed in bzr-builddeb (Ubuntu Oneiric):
status: Confirmed → In Progress
Jelmer Vernooij (jelmer) on 2011-08-31
affects: bzr-builddeb (Debian) → bzr (Debian)
affects: bzr-builddeb (Ubuntu Oneiric) → bzr (Ubuntu Oneiric)
Changed in bzr (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.4.0-3ubuntu1

---------------
bzr (2.4.0-3ubuntu1) oneiric; urgency=low

  * Merge from Debian. Remaining changes:
   + Drop build dependencies on python-{subunit,meliae,lzma,medusa}, which are
     not in main.
   + Disable support for running selftest in parallel (requires subunit).

bzr (2.4.0-3) unstable; urgency=medium

  * Fix regression in open_write_stream, which breaks the bzr-builddeb
    testsuite. Closes: #638219, LP: #831351

bzr (2.4.0-2) unstable; urgency=medium

  * Ignore permission denied errors when opening configuration files.
    LP: #837324, Closes: #639004

bzr (2.4.0-1) unstable; urgency=low

  * New upstream release.
   + Suggest python-gpgme python-gpgme-dbg for new signatures features.
   + Build-conflict with python-gpgme for the moment because of
     failing GPG tests when it is installed.
 -- Jelmer Vernooij <email address hidden> Wed, 31 Aug 2011 17:08:56 +0200

Changed in bzr (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.