Ubuntu

bzr package build should run the test suite

Reported by Martin Pool on 2010-09-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bzr

The normal Ubuntu policy is that test suites should be run during packaging. According to <https://lists.ubuntu.com/archives/technical-board/2010-September/000508.html> this was turned off due to intermittent hangs. Several of these have now been fixed and we have a build farm that does repeated builds on various systems and should catch them. I think it would now be worth turning back on in the development release.

Liam Dunn (ldunn) wrote :

I re-enabled the test suite to see what results I would get. The build failed, with 16 failed tests. A few of these are related to unicode errors, and a few were related to broken pipes with the test HTTP server. I'm at a loss for how to handle these.

Thanks very much for trying that so quickly, Liam.

Please paste the failures up here as an attachment and we'll try to debug them.

Liam Dunn (ldunn) wrote :

Here they are.
It seems that at least the unicode-related ones are caused by a bug in the test suite. Those shouldn't be running with LANG=C.

Martin Packman (gz) wrote :

We've got bug 632387 for the LANG=C stuff, and poolie has filed bug 644855 for the test isolation failure.

Martin Pool (mbp) on 2010-09-23
Changed in bzr (Ubuntu):
status: New → Confirmed
Vincent Ladeuil (vila) wrote :

I've filed bug #646133 for the failures related to running the test suite as root.

Max Bowsher (maxb) wrote :

2.3b2 in the bzr-beta-ppa was built with the test suite running (and passing). I have one small change that was made directly in the packaging branch, which I need to submit back to bzr.dev. We should be good to have the testsuite on for all 2.3 packages in Ubuntu.

Vincent Ladeuil (vila) wrote :

Fixed as of 2.3b3-1

Changed in bzr (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers