acute accent marks in man page

Bug #234771 reported by Jelmer Vernooij on 2008-05-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Low
Jelmer Vernooij
bzr (Debian)
Fix Released
Unknown
bzr (Ubuntu)
Low
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Russ Allbery wrote:
> Package: bzr Version: 1.0-1 Severity: minor
>
> The man page generated by the generate_docs.py tool tries to escape
> apostrophes with \. This doesn't work correctly with a current
> groff. \' is converted to an acute accent mark rather than an
> apostrophe.
>
> With groff, what you want is \(aq. Unfortunately, that's
> groff-specific and won't work with, for example, Solaris man.
>
> Pod::Man adds:
>
> .ie \n(.g .ds Aq \(aq .el .ds Aq '
>
> to the preamble of the man page and then uses \*(Aq as the escape
> for apostrophes in the man page.
  affects bzr
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQCVAwUBSDliKgy0JeEGD2blAQJ6SgP/dnmvYp9T71Dl1bwBnlx1OLHm0J/4vZDa
nxkj44O6gY9qXyUKyBtfEme25ho/dLSDapL8HTolJK6H9jHp92Mnkz/IaJfL79OR
LhRahYgSZVgHt4c0IkwcxltXqFzVAJTU3KiZHDZ/cz8sht8U8atojlDfdqGUsWuU
FY3yTAPhnGY=
=qrgA
-----END PGP SIGNATURE-----

Related branches

James Westby (james-w) on 2008-06-16
Changed in bzr:
importance: Undecided → Low
status: New → Confirmed
Changed in bzr (Debian):
status: Unknown → Confirmed
Anders Kaseorg (andersk) on 2010-10-19
summary: - Re: [Pkg-bazaar-maint] Bug#458157: bzr: acute accent marks in man page
+ acute accent marks in man page
Jelmer Vernooij (jelmer) wrote :

Newer versions of groff happily support "\'"

Changed in bzr:
status: Confirmed → Fix Released
Anders Kaseorg (andersk) wrote :

Uh, no they don’t. I have groff 1.21, the latest released version, and there are still acute accent marks in the man page. And I don’t see anything relevant in the post-1.21 CVS ChangeLog.

$ groff --version
GNU groff version 1.21

$ man bzr | grep ´
           --dry-run Show what would be done, but don´t
           --no-recurse Don´t recursively add the contents of
       recursively into versioned directories. If no names are given ´.´ is

Robert Roth (evfool) on 2011-02-08
tags: added: manpage
Jelmer Vernooij (jelmer) on 2011-04-11
Changed in bzr (Ubuntu):
status: New → Fix Released
status: Fix Released → Confirmed
Jelmer Vernooij (jelmer) on 2011-06-17
Changed in bzr (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
JC Hulce (soaringsky) wrote :

This bug is marked as being fixed upstream, but not in Ubuntu. However, we don't have any details about the upstream fix. What upstream revision/ version fixed this issue?

Jelmer Vernooij (jelmer) wrote :

There is some discussion over whether or not this is fixed.

Both ' and ` display properly in the bzr manpage here on Ubuntu 12.04, and I don't get any errors. If this is still an issue, please let us know where this shows up as a problem and/or how to reproduce it.

Changed in bzr:
status: Fix Released → Incomplete
Changed in bzr (Ubuntu):
status: Triaged → Incomplete
Anders Kaseorg (andersk) wrote :

The problem is still present in bzr 2.5.0: the man page still has acute accent marks instead of apostrophes, as you can check for yourself by running
man bzr | grep "´"
man bzr | grep "'"

Changed in bzr:
status: Incomplete → Confirmed
Changed in bzr (Ubuntu):
status: Incomplete → Confirmed
Jelmer Vernooij (jelmer) on 2012-03-14
Changed in bzr:
assignee: nobody → Jelmer Vernooij (jelmer)
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2012-03-15
Changed in bzr:
milestone: none → 2.6b1
status: In Progress → Fix Released
Changed in bzr (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.