command export zip produces files with permission 000

Bug #207253 reported by Daniel Cordeiro on 2008-03-26
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Jelmer Vernooij
bzr (Ubuntu)
Medium
Jelmer Vernooij

Bug Description

Binary package hint: bzr

All files and directories looses its permissions after being exported to a zip file by the command "export".

Steps to reproduce:
- create a new repository, add a file and commit;
- bzr export ../test.zip
- unzip the new file "test.zip".

All files in test.zip are unzipped with permissions 000 (what is very annoying). :(

ProblemType: Bug
Architecture: i386
Date: Wed Mar 26 18:48:16 2008
DistroRelease: Ubuntu 8.04
Package: bzr 1.2~rc1-1build2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin:/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=pt_BR.UTF-8
SourcePackage: bzr
Uname: Linux 2.6.24-12-generic i686

Related branches

Daniel Cordeiro (dcordeiro) wrote :
Kjell Braden (afflux) wrote :

I can confirm this problem using hardy and the same version as the reporter (bzr 1.2~rc1-1build2).

Changed in bzr:
status: New → Confirmed
Martin Pool (mbp) on 2009-11-24
Changed in bzr:
status: New → Confirmed
importance: Undecided → Medium
Ivan Sagalaev (isagalaev) wrote :

Martin, I'd like to fix this bug. What's the preferred way of submitting a patch? Should I register a new branch for https://code.launchpad.net/bzr or just make a bundle and attach it here?

Ivan Sagalaev (isagalaev) wrote :

To clarify... I've read the guide: http://doc.bazaar-vcs.org/developers/HACKING.html. I've made a local stacked branch of bzr.dev which is probably why I can't commit directly to it. I can convert it to a standalone one and push it. What bothers me is pushing the whole Bazaar to LP just for a trivial one-line fix. Sounds rather ineffective :-).

On Tue, 2009-11-24 at 10:00 +0000, Ivan Sagalaev wrote:
> To clarify... I've read the guide: http://doc.bazaar-
> vcs.org/developers/HACKING.html. I've made a local stacked branch of
> bzr.dev which is probably why I can't commit directly to it. I can
> convert it to a standalone one and push it. What bothers me is pushing
> the whole Bazaar to LP just for a trivial one-line fix. Sounds rather
> ineffective :-).

You should try it before you knock it :). It should take ~ 30 seconds to
push. Tops.

-Rob

Ian Clatworthy (ian-clatworthy) wrote :

Ivan Sagalaev wrote:
> To clarify... I've read the guide: http://doc.bazaar-
> vcs.org/developers/HACKING.html. I've made a local stacked branch of
> bzr.dev which is probably why I can't commit directly to it. I can
> convert it to a standalone one and push it. What bothers me is pushing
> the whole Bazaar to LP just for a trivial one-line fix. Sounds rather
> ineffective :-).
>

The recommended workflow is to grab a full copy of the branch locally,
make a change, then push your branch to LP. The push to LP will create a
stacked branch *there* - stacked against the trunk. So only a small
amount of data is transferred by the push.

Ian C.

Ivan Sagalaev (isagalaev) wrote :

Ah! Will do. Once I "unstack" my bzr.dev copy locally :-)

Matt Nordhoff (mnordhoff) wrote :

Ivan Sagalaev wrote:
> Martin, I'd like to fix this bug. What's the preferred way of submitting
> a patch? Should I register a new branch for
> https://code.launchpad.net/bzr or just make a bundle and attach it here?

You should register a branch and then file a merge proposal with the
"Propose for merging" link on the branch's page.
--
Matt Nordhoff

Jelmer Vernooij (jelmer) wrote :

I can't reproduce this for files, but directories still have permission 0 in zip files.

tags: added: export
Jelmer Vernooij (jelmer) on 2011-02-17
Changed in bzr:
status: Confirmed → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2011-02-17
Changed in bzr (Ubuntu):
status: Confirmed → In Progress
Jelmer Vernooij (jelmer) on 2011-02-26
Changed in bzr:
status: Fix Committed → Fix Released
Jelmer Vernooij (jelmer) on 2011-04-11
Changed in bzr:
milestone: none → 2.4b2
Jelmer Vernooij (jelmer) on 2011-04-28
Changed in bzr (Ubuntu):
importance: Undecided → Medium
Jelmer Vernooij (jelmer) on 2011-06-01
Changed in bzr (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers