bzr fails to build on vivid (release) and trusty (test-rebuild only)

Bug #1451448 reported by Matthias Klose on 2015-05-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil
bzr (Debian)
Fix Released
Unknown
bzr (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Vivid
High
Unassigned

Bug Description

bzr fails to build on vivid (release) and trusty (test-rebuild only)

various test failures seen, likely exposed by python 2.7.10.

release:
https://launchpad.net/ubuntu/+archive/test-rebuild-20150402/+build/7133674

test rebuild:
https://launchpad.net/ubuntu/+archive/test-rebuild-20150501-updates/+build/7375272

how to validate: successful build. the testsuite is run during the build

Related branches

Matthias Klose (doko) on 2015-05-04
Changed in bzr (Ubuntu Trusty):
importance: Undecided → High
milestone: none → trusty-updates
status: New → Confirmed
Changed in bzr (Ubuntu):
milestone: vivid-updates → ubuntu-15.10
Vincent Ladeuil (vila) on 2015-05-28
Changed in bzr:
status: New → Confirmed
importance: Undecided → High
Vincent Ladeuil (vila) wrote :

Sorry for the reply delay :-/

I've been able to reproduce on vivid.

These tests are racy (yet another occurrence of running a TCP server and client in the same process (different threads)).

Out of the ~800 http tests, those two ones are the simplest: they connect to an http server that always reply with a 'Bad status' message and close the connection.

Running 'bzr selftest --parallel=fork -v -s bt.test_http.TestBadStatusServer' repeatedly, I can:
- see the test pass,
- see the test fail as reported,
- see the test hang

Definitely a race :-/

This can be fixed in two ways:
- run the server in a separate process,
- identify the race more precisely and fix it.

The former requires some tedious work, the later requires some deep investigation :-/

I've sent a patch to debian to disable these tests until they are properly fixed. We don't lose significant coverage doing so (pqm will still run them to gate lp:bzr).

Matthias Klose (doko) wrote :

fixed in 2.6.0+bzr6602-2ubuntu2 in wily. backporting the same fix to trusty

Changed in bzr (Ubuntu Vivid):
status: Confirmed → Fix Released
Changed in bzr (Debian):
status: Unknown → Confirmed

Hello Matthias, or anyone else affected,

Accepted bzr into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bzr/2.6.0+bzr6593-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bzr (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Matthias Klose (doko) wrote :

my bad, the second patch to fix the win32 paths tests only works with python 2.7.9 and .10. I'll keep it in -proposed for now, keeping the verification-needed tag.

Changed in bzr (Debian):
status: Confirmed → Fix Released
tags: added: verification-failed
removed: verification-needed
Changed in bzr (Ubuntu Trusty):
status: Fix Committed → Confirmed
Matthias Klose (doko) wrote :

no, please keep it this way. it succeeds with the python2.7 proposed for trusty

tags: added: verification-done
removed: ftbfs verification-failed
Changed in bzr (Ubuntu Trusty):
status: Confirmed → Fix Committed
Mathew Hodson (mathew-hodson) wrote :

Do I understand correctly that there needs to be a trusty SRU for python2.7 first to get this to build? Is there a launchpad bug for the proposed python2.7 package?

Steve Langasek (vorlon) wrote :

There is no python2.7 package currently in the queue or in -proposed for trusty. Trying to rebuild the bzr package in trusty-proposed still fails.

tags: added: verification-needed
removed: verification-done
tags: added: ftbfs
Vincent Ladeuil (vila) on 2015-09-06
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
status: Confirmed → In Progress
milestone: none → 2.7b1
Changed in python2.7 (Ubuntu):
status: New → Invalid
Changed in python2.7 (Ubuntu Vivid):
status: New → Invalid
Changed in python2.7 (Ubuntu):
importance: Undecided → High
Changed in python2.7 (Ubuntu Trusty):
importance: Undecided → High
Changed in python2.7 (Ubuntu Vivid):
importance: Undecided → High
Vincent Ladeuil (vila) on 2015-11-11
Changed in bzr:
status: In Progress → Fix Released
Mathew Hodson (mathew-hodson) wrote :

Comment #2 says that this was fixed in 2.6.0+bzr6602-2ubuntu2 in wily.

Vivid has 2.6.0+bzr6595-6ubuntu1, so I don't think a fix was ever released there.

Changed in bzr (Ubuntu):
milestone: ubuntu-15.10 → none
status: Confirmed → Fix Released
Changed in bzr (Ubuntu Vivid):
status: Fix Released → New

system still wont work did all sugg. still get get to work right

On Tue, Dec 1, 2015 at 10:37 AM, Mathew Hodson <email address hidden>
wrote:

> Comment #2 says that this was fixed in 2.6.0+bzr6602-2ubuntu2 in wily.
>
> Vivid has 2.6.0+bzr6595-6ubuntu1, so I don't think a fix was ever
> released there.
>
> ** Changed in: bzr (Ubuntu)
> Status: Confirmed => Fix Released
>
> ** Changed in: bzr (Ubuntu)
> Milestone: ubuntu-15.10 => None
>
> ** Changed in: bzr (Ubuntu Vivid)
> Status: Fix Released => New
>
> --
> You received this bug notification because you are subscribed to bzr in
> Ubuntu.
> Matching subscriptions: bugs1
> https://bugs.launchpad.net/bugs/1451448
>
> Title:
> bzr fails to build on vivid (release) and trusty (test-rebuild only)
>
> Status in Bazaar:
> Fix Released
> Status in bzr package in Ubuntu:
> Fix Released
> Status in python2.7 package in Ubuntu:
> Invalid
> Status in bzr source package in Trusty:
> Fix Committed
> Status in python2.7 source package in Trusty:
> New
> Status in bzr source package in Vivid:
> New
> Status in python2.7 source package in Vivid:
> Invalid
> Status in bzr package in Debian:
> Fix Released
>
> Bug description:
> bzr fails to build on vivid (release) and trusty (test-rebuild only)
>
> various test failures seen, likely exposed by python 2.7.10.
>
> release:
>
> https://launchpad.net/ubuntu/+archive/test-rebuild-20150402/+build/7133674
>
> test rebuild:
>
> https://launchpad.net/ubuntu/+archive/test-rebuild-20150501-updates/+build/7375272
>
> how to validate: successful build. the testsuite is run during the
> build
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bzr/+bug/1451448/+subscriptions
>

Matthias Klose (doko) wrote :

verified again, that the package in -proposed builds fine with the python2.7 from the ubuntu-toolchain-r/ppa PPA. The tests are dependent on 2.7.9 or higher.

Hello Matthias, or anyone else affected,

Accepted bzr into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bzr/2.6.0+bzr6593-1ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Matthias, or anyone else affected,

Accepted bzr into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bzr/2.6.0+bzr6593-1ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Matthias Klose (doko) wrote :

package built in trusty-proposed

tags: added: verification-done
removed: verification-needed
no longer affects: python2.7 (Ubuntu Vivid)
no longer affects: python2.7 (Ubuntu Trusty)
no longer affects: python2.7 (Ubuntu)

The verification of the Stable Release Update for bzr has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.6.0+bzr6593-1ubuntu1.5

---------------
bzr (2.6.0+bzr6593-1ubuntu1.5) trusty-proposed; urgency=medium

  * SRU: LP: #1451448.
  * Backport disabling the win32 failing tests as they can't succeed for all
    Ubuntu releases.

 -- Vincent Ladeuil <email address hidden> Tue, 15 Dec 2015 10:26:52 +0100

Changed in bzr (Ubuntu Trusty):
status: Fix Committed → Fix Released

is the fix if so what do i do dont want to mess up anything so please
instruct me and thanks for all efforts

On Thu, Jan 21, 2016 at 10:23 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package bzr - 2.6.0+bzr6593-1ubuntu1.5
>
> ---------------
> bzr (2.6.0+bzr6593-1ubuntu1.5) trusty-proposed; urgency=medium
>
> * SRU: LP: #1451448.
> * Backport disabling the win32 failing tests as they can't succeed for
> all
> Ubuntu releases.
>
> -- Vincent Ladeuil <email address hidden> Tue, 15 Dec 2015 10:26:52
> +0100
>
> ** Changed in: bzr (Ubuntu Trusty)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1451448
>
> Title:
> bzr fails to build on vivid (release) and trusty (test-rebuild only)
>
> Status in Bazaar:
> Fix Released
> Status in bzr package in Ubuntu:
> Fix Released
> Status in bzr source package in Trusty:
> Fix Released
> Status in bzr source package in Vivid:
> New
> Status in bzr package in Debian:
> Fix Released
>
> Bug description:
> bzr fails to build on vivid (release) and trusty (test-rebuild only)
>
> various test failures seen, likely exposed by python 2.7.10.
>
> release:
>
> https://launchpad.net/ubuntu/+archive/test-rebuild-20150402/+build/7133674
>
> test rebuild:
>
> https://launchpad.net/ubuntu/+archive/test-rebuild-20150501-updates/+build/7375272
>
> how to validate: successful build. the testsuite is run during the
> build
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bzr/+bug/1451448/+subscriptions
>

Changed in bzr (Ubuntu Vivid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.