FTBFS/autopkgtest failure: FAIL: bzrlib.tests.test_email_message.TestEmailMessage

Bug #1303879 reported by Andrew Starr-Bochicchio on 2014-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil
bzr (Ubuntu)
High
Andrew Starr-Bochicchio

Bug Description

These three test have been failing on the last few autopkgtest runs. The also fail in Debian unstable.

https://jenkins.qa.ubuntu.com/view/Trusty/view/AutoPkgTest/job/trusty-adt-bzr/25/ARCH=amd64,label=adt/console

Interestingly, they aren't failing on upstream's trusty jenkins instance:

http://babune.ladeuil.net:24842/job/selftest-chroot-trusty/

FAIL: bzrlib.tests.test_email_message.TestEmailMessage.test_send
----------------------------------------------------------------------
Traceback (most recent call last):
_StringException: Empty attachments:
  log

Traceback (most recent call last):
  File "/tmp/buildd/bzr-2.6.0+bzr6592/build/lib.linux-x86_64-2.7/bzrlib/tests/test_email_message.py", line 168, in test_send
    messages[0])
  File "/tmp/buildd/bzr-2.6.0+bzr6592/build/lib.linux-x86_64-2.7/bzrlib/tests/__init__.py", line 1380, in assertEqualDiff
    self._ndiff_strings(a, b))
AssertionError: first string is missing a final newline.
  Content-Type: multipart/mixed; boundary="=====123456=="
  MIME-Version: 1.0
  From: <email address hidden>
  Subject: subject
  To: <email address hidden>
  User-Agent: Bazaar (2.7.0dev1)

  --=====123456==
  MIME-Version: 1.0
  Content-Type: text/plain; charset="us-ascii"
  Content-Transfer-Encoding: 7bit
  Content-Disposition: inline

  body
  --=====123456==
  MIME-Version: 1.0
  Content-Type: text/plain; charset="us-ascii"; name="lines.txt"
  Content-Transfer-Encoding: 7bit
  Content-Disposition: inline

  a
  b
  c
  d
  e

  --=====123456==--

======================================================================
FAIL: bzrlib.tests.test_osutils.TestWin32Funcs.test_pathjoin
----------------------------------------------------------------------
Traceback (most recent call last):
_StringException: Empty attachments:
  log

Traceback (most recent call last):
  File "/tmp/buildd/bzr-2.6.0+bzr6592/build/lib.linux-x86_64-2.7/bzrlib/tests/test_osutils.py", line 947, in test_pathjoin
    osutils._win32_pathjoin('C:/path/to/', '/foo'))
  File "/tmp/buildd/bzr-2.6.0+bzr6592/build/lib.linux-x86_64-2.7/bzrlib/tests/__init__.py", line 1360, in assertEqual
    pprint.pformat(a), pprint.pformat(b)))
AssertionError: not equal:
a = '/foo'
b = 'C:/foo'

======================================================================
FAIL: bzrlib.tests.test_email_message.TestEmailMessage.test_multipart_message
----------------------------------------------------------------------
Traceback (most recent call last):
_StringException: Empty attachments:
  log

Traceback (most recent call last):
  File "/tmp/buildd/bzr-2.6.0+bzr6592/build/lib.linux-x86_64-2.7/bzrlib/tests/test_email_message.py", line 106, in test_multipart_message
    self.assertEqualDiff(SIMPLE_MULTIPART_MESSAGE, msg.as_string(BOUNDARY))
  File "/tmp/buildd/bzr-2.6.0+bzr6592/build/lib.linux-x86_64-2.7/bzrlib/tests/__init__.py", line 1380, in assertEqualDiff
    self._ndiff_strings(a, b))
AssertionError: first string is missing a final newline.
  Content-Type: multipart/mixed; boundary="=====123456=="
  MIME-Version: 1.0
  From: <email address hidden>
  Subject: subject
  To: <email address hidden>
  User-Agent: Bazaar (2.7.0dev1)

  --=====123456==
  MIME-Version: 1.0
  Content-Type: text/plain; charset="us-ascii"
  Content-Transfer-Encoding: 7bit
  Content-Disposition: inline

  body
  --=====123456==--

----------------------------------------------------------------------
Ran 28533 tests in 379.365s

FAILED (failures=3, known_failure_count=59)

Related branches

Changed in bzr (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Vincent Ladeuil (vila) wrote :

Fix available in associated branch. Only tests are affected. This has been caused by python 2.7.6 introducing one backward incompatible change and fixing a bug in nt path handling.

> Interestingly, they aren't failing on upstream's trusty jenkins instance:

<cough> chroot out-of-date <cough> lack of automation / resources <cough>

http://babune.ladeuil.net:24842/job/selftest-chroot-trusty/

shows the failures now ;)

Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
importance: Undecided → High
milestone: none → 2.7b1
status: New → Fix Committed
Vincent Ladeuil (vila) on 2014-04-09
Changed in bzr:
status: Fix Committed → Fix Released
Changed in bzr (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.6.0+bzr6593-1ubuntu1

---------------
bzr (2.6.0+bzr6593-1ubuntu1) trusty; urgency=medium

  * Merge from Debian unstable. Remaining changes:
   - Drop non-main build dependencies on python-{meliae,lzma,medusa}

bzr (2.6.0+bzr6593-1) unstable; urgency=medium

  * New upstream snapshot:
   - Use LooseVersion from distutils to check Pyrex/Cython version
     in order to handle non-integers in the version string.
     Closes: #743096, #683130, LP: #1030521
   - Fix test failures with python-2.7.6 (LP: #1303879).
  * debian/control: No longer suggest bzr-svn (Closes: #709290).
 -- Andrew Starr-Bochicchio <email address hidden> Wed, 09 Apr 2014 21:36:21 -0400

Changed in bzr (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers