Wishlist: Include "bzr log -s" as Changelog with export

Bug #130225 reported by Sebastian Heinlein on 2007-08-03
6
Affects Status Importance Assigned to Milestone
bzr (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: bzr-builddeb

It would be nice to have an option to include the bzr log as Changelog file in the tarball.

James Westby (james-w) wrote :

Hello Sebastian,

I think this should be easy, I would just like a little more information first.

Firstly what mode are you running in? I guess this could be applicable to
native and split modes, and at a push export-upstream, but I wouldn't
be so happy with that.

Secondly you are not meaning debian/changelog, but just Changelog so the raw output of
bzr log is fine, is that correct?

Changed in bzr-builddeb:
status: New → Incomplete
James Westby (james-w) on 2008-05-15
Changed in bzr-builddeb:
importance: Undecided → Wishlist
Jayson Rowe (jayson.rowe) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in bzr-builddeb:
status: Incomplete → Invalid
James Westby (james-w) wrote :

Hi,

Please keep it open, it's a valid wish, I'd just like
more information on what is wanted.

Thanks,

James

Changed in bzr-builddeb:
status: Invalid → Incomplete

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Sebastian Heinlein (glatzor) wrote :

I would like to have a classic ./ChangeLog in my tarballs. So perhaps it is generally a bzr whish list item. It is interesting to keep the changelog as soon as the source code is exported outside of bzr.

Changed in bzr-builddeb (Ubuntu):
status: Incomplete → New
Jelmer Vernooij (jelmer) wrote :

That seems like unnecessary duplication, isn't that what debian/changelog is intended for.

I can see the use of this for e.g. "bzr export", as used by upstream projects, but it doesn't seem useful for Debian packages.

Jelmer Vernooij (jelmer) on 2011-06-17
summary: - Wishlist: Include "bzr log -s" as Changelog
+ Wishlist: Include "bzr log -s" as Changelog with export
affects: bzr-builddeb (Ubuntu) → bzr (Ubuntu)
Changed in bzr (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers