bzr builds against python2.4

Bug #120659 reported by Jeff Waugh on 2007-06-16
4
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
bzr (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: bzr

bzr in gusty builds against python2.4, and thus depends on it.

I am using the "${python:Depends}" macro in the control file, and somehow it expand to include python2.4. That's definitely not the behavior that we want.

Changed in bzr:
status: Unconfirmed → Confirmed
assignee: nobody → etienne-goyer-outlands

The following files have a shebang line that specify python2.4 explicitly :

    bzrlib/tests/test_weave.py
    tools/capture_tree.py
    tools/trace-revisions
    tools/rst2prettyhtml.py

I will ask upstream to look into it and determine if these shebang line really need to specify python2.4 explicitly (if at all).

John A Meinel (jameinel) wrote :

test_weave.py doesn't need a shebang at all

I think the reason the rest of them use python2.4 is because of python2.3 sitting around.

If we feel like 2.4+2.5 is significantly more common that 2.3+2.4, then we can turn them back into '/usr/bin/env python' instead.

As I understand it, though, Red Hat specifically has been really slow to upgrade their version of python in their "Enterprise" lines. So we probably will see 2.3 around for quite a while.

John A Meinel (jameinel) wrote :

Thinking about it, though. If we are using '/usr/bin/env python' anywhere, then it should be fine to do it everywhere. Probably the differences is just because different people have coded different tools.
So I think we would be happy to have these standardized.

Changed in bzr:
importance: Undecided → Medium
status: Unconfirmed → Confirmed

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

John A Meinel wrote:
> Thinking about it, though. If we are using '/usr/bin/env python' anywhere, then it should be fine to do it everywhere. Probably the differences is just because different people have coded different tools.
> So I think we would be happy to have these standardized.

Well, consider that in bzr, we reinvoke bzr if python is less than 2.4.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGdqvk0F+nu1YWqI0RAknCAJ48BWHHwEtQyb33Dl8O2U/76D/qOwCfb0Gx
TUuxNw2BplxCtZSC2qVDGyA=
=/u6m
-----END PGP SIGNATURE-----

John A Meinel (jameinel) wrote :

Sure, but these are extra tools that not everyone who uses bzr needs. It seems a little perverse to make all of them include the re-invoke code.

Also, bzr will reinvoke to python2.5 is 2.4 isn't available, and won't re-invoke if it is running python2.5

I think this specific bug is that Fiesty is moving to python2.5 and they don't want to have to include 2.4 since we don't actually need it.

Aaron Bentley (abentley) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

John A Meinel wrote:
> Sure, but these are extra tools that not everyone who uses bzr needs. It
> seems a little perverse to make all of them include the re-invoke code.
>
> Also, bzr will reinvoke to python2.5 is 2.4 isn't available, and won't
> re-invoke if it is running python2.5

Right. I agree that the reinvocation stuff is more elegant than simply
invoking python2.4. I meant to say that using 2.4 in those scripts was
driven by the lack of reinvocation.

> I think this specific bug is that Fiesty is moving to python2.5 and they

Gutsy?

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGdr/40F+nu1YWqI0RAthfAJ9Y/R3BHB6BhGVpyIZAKdFVm0IybACfVWz2
HkZsYJ7xfi3FEoZ6kvxGCHM=
=1NcB
-----END PGP SIGNATURE-----

Robert Collins (lifeless) wrote :

On Mon, 2007-06-18 at 13:06 +0000, Etienne Goyer wrote:
> The following files have a shebang line that specify python2.4
> explicitly :
>
> bzrlib/tests/test_weave.py
> tools/capture_tree.py
> tools/trace-revisions
> tools/rst2prettyhtml.py
>
> I will ask upstream to look into it and determine if these shebang line
> really need to specify python2.4 explicitly (if at all).

These should not be installed into /usr/bin, and as such are not on the
users path anyway.

I'd be in favour of:
nuke the #! in test_weave
use /bin/env python for capture_Tree, trace-revisions and rst2prettyhtml

-Rob
--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

Re: Red Hat Enterprise Python version. RHEL5 have been out for a few months, and ship with 2.4. RHEL4, which enjoy a very large installed base at the moment, shipped with Python 2.3 and won't be EOLed until February 2012.

Bubba Siggler (bud3) wrote :

On 6/19/07, Etienne Goyer <email address hidden> wrote:
>
> Re: Red Hat Enterprise Python version. RHEL5 have been out for a few
> months, and ship with 2.4. RHEL4, which enjoy a very large installed
> base at the moment, shipped with Python 2.3 and won't be EOLed until
> February 2012.

Hi Every,
I ask for pardon to step in, but being in the construction biz most of my
live the biggler the base on a LP gave a great way for things coming to
center an the straight up .

regards

flint

--
> bzr builds against python2.4
> https://bugs.launchpad.net/bugs/120659
> You received this bug notification because you are a member of Bazaar
> Developers, which is the registrant for Bazaar.
>

--
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFFkcN7yXWcajQQndYRAgbqAKCMyXN9Jx4g0X7jocg+aUSFz0x4LwCgrURW
eGtqLjpzQVYa9+gzpCRtB84=
=zrpM
-----END PGP SIGNATURE-----

Martin Pitt (pitti) wrote :

Etienne, I take this from you, I hope you don't mind. We need to get rid of python2.4 to solve space problems of the alternate CDs. I'll implement the solution proposed by Robert.

Changed in bzr:
assignee: etienne-goyer-outlands → pitti
importance: Undecided → High
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

bzr (0.17-0ubuntu2) gutsy; urgency=low

  * Add debian/patches/no-python-2.4.patch: Remove hashbangs that are Python
    2.4 specific, so that we get rid of python2.4 from the CDs. (LP: #120659)

 -- Martin Pitt <email address hidden> Mon, 25 Jun 2007 10:40:25 +0200

Changed in bzr:
status: In Progress → Fix Released
Martin Pool (mbp) wrote :

I don't think this requires any further changes in upstream bzr: bzr run from source uses whatever the system calls 'python'. If it does, please reopen it.

Changed in bzr:
status: Confirmed → Fix Released
John A Meinel (jameinel) wrote :

Sort of. It *does* have the logic to reinvoke itself if python == python2.3 and python2.4/5/6 can be found on the path.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers