bzr: would FTBFS whenever cython's version has alphabetic portion (e.g. beta)

Bug #1030521 reported by Jelmer Vernooij on 2012-07-29
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Andrew Starr-Bochicchio
bzr (Debian)
Fix Released
Unknown
bzr (Ubuntu)
Medium
Andrew Starr-Bochicchio

Bug Description

Imported from Debian bug http://bugs.debian.org/683130:

Package: bzr
Version: 2.6.0~bzr6526-1
Severity: minor

you might like to patch/report upstream to make bzr cython version checking more robust. Currently it FTBFS with version (0.17.beta1) in experimental:

make[1]: Entering directory `/tmp/buildd/bzr-2.6.0~bzr6526'
dh_auto_clean
Traceback (most recent call last):
  File "setup.py", line 205, in <module>
    pyrex_version_info = tuple(map(int, pyrex_version.rstrip("+").split('.')))
ValueError: invalid literal for int() with base 10: 'beta1'
[21314 refs]
dh_auto_clean: python2.6-dbg setup.py clean -a returned exit code 1
make[1]: *** [override_dh_auto_clean] Error 1

just in case -- attaching full build log

-- System Information:
Debian Release: 6.0.5
  APT prefers stable
  APT policy: (900, 'stable'), (700, 'testing'), (600, 'unstable'), (300, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-vserver-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Related branches

Jelmer Vernooij (jelmer) on 2012-07-30
Changed in bzr:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in bzr (Ubuntu):
status: New → Triaged
Martin Packman (gz) wrote :

My fault, I weakened the check that was incidentally added as part of bug 837221 when Cython changed versioning scheme, and then they changed it again. Have been carrying a patch locally that should have been landed.

Changed in bzr (Ubuntu):
importance: Undecided → Medium
Changed in bzr (Debian):
importance: Undecided → Unknown
Changed in bzr (Debian):
status: New → Confirmed

bzr is now failing to build in Debian unstable due to this:

> fakeroot debian/rules clean
> dh clean --with python2,sphinxdoc --buildsystem=python_distutils
> dh_testdir -O--buildsystem=python_distutils
> debian/rules override_dh_auto_clean
> make[1]: Entering directory `/«BUILDDIR»/bzr-2.6.0+bzr6591'
> dh_auto_clean
> Traceback (most recent call last):
> File "setup.py", line 205, in <module>
> pyrex_version_info = tuple(map(int, pyrex_version.rstrip("+").split('.')))
> ValueError: invalid literal for int() with base 10: '1post0'
> [27420 refs]
> dh_auto_clean: python-dbg setup.py clean -a returned exit code 1
> make[1]: *** [override_dh_auto_clean] Error 1

Changed in bzr:
status: Triaged → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Vincent Ladeuil (vila) on 2014-04-03
Changed in bzr:
milestone: none → 2.7b1
status: In Progress → Fix Released
Changed in bzr (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.6.0+bzr6593-1ubuntu1

---------------
bzr (2.6.0+bzr6593-1ubuntu1) trusty; urgency=medium

  * Merge from Debian unstable. Remaining changes:
   - Drop non-main build dependencies on python-{meliae,lzma,medusa}

bzr (2.6.0+bzr6593-1) unstable; urgency=medium

  * New upstream snapshot:
   - Use LooseVersion from distutils to check Pyrex/Cython version
     in order to handle non-integers in the version string.
     Closes: #743096, #683130, LP: #1030521
   - Fix test failures with python-2.7.6 (LP: #1303879).
  * debian/control: No longer suggest bzr-svn (Closes: #709290).
 -- Andrew Starr-Bochicchio <email address hidden> Wed, 09 Apr 2014 21:36:21 -0400

Changed in bzr (Ubuntu):
status: In Progress → Fix Released
Changed in bzr (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.