bzr: Unable to sign commits: "no terminal at all requested"

Bug #1014570 reported by Jelmer Vernooij on 2012-06-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Jelmer Vernooij
bzr (Debian)
Confirmed
Unknown
bzr (Ubuntu)
High
Jelmer Vernooij
Precise
High
Jelmer Vernooij
Quantal
High
Jelmer Vernooij

Bug Description

Imported from Debian bug http://bugs.debian.org/673484:

Without any modification in my configuration, Bzr is now rejecting my
signatures to commits:

    $ bzr sign-my-commits
    <email address hidden>
    gpg: Sorry, no terminal at all requested - can't get input
    bzr: ERROR: Failed to GPG sign data with command "[u'gpg', '--clearsign', '-u', <email address hidden>', '--no-tty']"

This bug was introduced in 2.5.1 and later snapshots of bzr 2.6. 2.5.1 was SRU'ed into precise.

[Impact]
This affects users of the 2.5.1 SRU who sign commits on the command-line without a GPG agent. The proposed fix reverts the use of --no-tty which will reintroduce bug 847388, which was also present long before 2.5.1.

[Test Case]
Install bzr and gpg. Make sure there is no active GPG agent ("unset GPG_AGENT_INFO") and try to sign a few commits ("bzr sign-my-commits"). This should succeed, and prompt for a GPG password on the terminal.

[Regression Potential]
This is a revert of a problematic change in a SRU. We'll definitely reintroduce bug 847388, but that is a bug that has been present for a long time and only affects a really limited amount of users.

Related branches

Jelmer Vernooij (jelmer) on 2012-06-18
Changed in bzr (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: regressionb
Changed in bzr:
status: New → Triaged
importance: Undecided → High
Changed in bzr (Ubuntu):
importance: Medium → High
Changed in bzr (Debian):
importance: Undecided → Unknown
Changed in bzr (Debian):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2012-06-26
tags: added: regression
removed: regressionb
Martin Packman (gz) wrote :

This appears to be a regression from the fix for bug 847388, which is a little odd that seemed to be a well thought out change.

tags: added: regression-update
Jelmer Vernooij (jelmer) wrote :

I'll have a look at reverting the fix for 847388 tomorrow; that should at least fix this regression. I think the bug of gpg not working in bzr explorer is a lot less common and it has been around for a while.

We'll then have to look at fixing bug 847388 again properly.

Changed in bzr:
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr (Ubuntu Precise):
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr (Ubuntu Quantal):
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) wrote :

Since we already use gpgme for verifying signatures, it might make sense to use it for signing them as well rather than trying to muck about and find the right magic options for the gpg command line utility.

Jelmer Vernooij (jelmer) on 2012-06-26
Changed in bzr:
status: Triaged → In Progress
Changed in bzr (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
Changed in bzr (Ubuntu Quantal):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.6.0~beta1-0ubuntu2

---------------
bzr (2.6.0~beta1-0ubuntu2) quantal; urgency=low

  * Revert use of --no-tty. LP: #1014570
 -- Jelmer Vernooij <email address hidden> Fri, 29 Jun 2012 11:17:51 +0200

Changed in bzr (Ubuntu Quantal):
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2012-06-29
Changed in bzr:
milestone: none → 2.6b2
Changed in bzr (Ubuntu Precise):
milestone: none → precise-updates
Changed in bzr (Ubuntu Quantal):
milestone: none → quantal-alpha-3
description: updated

Hello Jelmer, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/None/2.5.1-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bzr (Ubuntu Precise):
status: In Progress → Fix Committed
Scott Kitterman (kitterman) wrote :

I both replicated the problem with the old package and verified the fix as described in the test case.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.5.1-0ubuntu2

---------------
bzr (2.5.1-0ubuntu2) precise-proposed; urgency=low

  * Revert use of --no-tty when using gpg to sign commits. LP: #1014570
 -- Jelmer Vernooij <email address hidden> Fri, 29 Jun 2012 12:44:09 +0200

Changed in bzr (Ubuntu Precise):
status: Fix Committed → Fix Released
Jelmer Vernooij (jelmer) on 2012-07-08
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.