bzr crashed with TypeError in __init__(): __init__() got an unexpected keyword argument 'ca_certs'

Bug #953154 reported by Václav Šmilauer on 2012-03-12
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Bazaar WebDAV plugin
High
Vincent Ladeuil
bzr-webdav (Ubuntu)
High
Unassigned

Bug Description

I get this error when commiting over the https+webdav transport.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bzr 2.5.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: nvidia fglrx
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
BzrDebugFlags: set()
BzrVersion: 2.5.0
CommandLine:
 ['/usr/bin/bzr',
  'qsubprocess',
  '--bencode',
  '@/tmp/QBzr/qsubprocess/tmp1z1RMO']
CrashDb: bzr
Date: Mon Mar 12 17:02:20 2012
ExecutablePath: /usr/bin/bzr
FileSystemEncoding: UTF-8
InterpreterPath: /usr/bin/python2.7
Locale: en_US.UTF-8
PackageArchitecture: all
Platform: Linux-3.2.0-18-generic-x86_64-with-Ubuntu-12.04-precise
ProcCmdline: /usr/bin/python /usr/bin/bzr qsubprocess --bencode @/tmp/QBzr/qsubprocess/tmp1z1RMO
PythonVersion: 2.7.3rc1
SourcePackage: bzr
Title: bzr crashed with TypeError in __init__(): __init__() got an unexpected keyword argument 'ca_certs'
UpgradeStatus: Upgraded to precise on 2012-03-12 (0 days ago)
UserEncoding: utf-8
UserGroups: adm admin audio cdrom dip floppy lpadmin plugdev sudo video

Václav Šmilauer (eudoxos) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr (Ubuntu):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2012-03-16
Changed in bzr:
status: New → Confirmed
importance: Undecided → High
Changed in bzr (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Vincent Ladeuil (vila) on 2012-03-17
affects: bzr → bzr-webdav
Václav Šmilauer (eudoxos) wrote :

Is there a workaround for this bug, given its importance? (Even if it should consist in adjusting a few lines of sources)

Vincent Ladeuil (vila) wrote :

@eudoxos: Yes, see https://code.launchpad.net/~andidog/bzr-webdav/trunk/+merge/96339

I will cut a new release for bzr-webadv asap.

Changed in bzr-webdav:
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2012-03-26
Changed in bzr-webdav:
status: Confirmed → Fix Released
Axzel Marin (axzelmarin) wrote :

Today i installed lubuntu 12.04 beta 2 and tried to upload some changes on a bzr branch to my company server got the same error mentioning ca_certs the thing is i'm using http+webdav insted of https, any idea when this fix will be uploaded to 12.04 before release, i really need to update my branch.

Khaled Blah (khaled-blah) wrote :

Unfortunately, this bug can still be found in trusty, here's the traceback:

bzr: ERROR: exceptions.TypeError: __init__() got an unexpected keyword argument 'ca_certs'

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/builtins.py", line 1641, in run
    branch_location)
  File "/usr/lib/python2.7/dist-packages/bzrlib/controldir.py", line 780, in open_tree_or_branch
    controldir = klass.open(location)
  File "/usr/lib/python2.7/dist-packages/bzrlib/controldir.py", line 687, in open
    t = _mod_transport.get_transport(base, possible_transports)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1680, in get_transport
    return get_transport_from_url(location_to_url(base), possible_transports)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1655, in get_transport_from_url
    transport, last_err = _try_transport_factories(url, factory_list)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1687, in _try_transport_factories
    return factory.get_obj()(base), None
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/_urllib.py", line 48, in __init__
    report_activity=self._report_activity, ca_certs=ca_certs)
TypeError: __init__() got an unexpected keyword argument 'ca_certs'

bzr 2.7.0dev1 on python 2.7.6 (Linux-3.13.0-23-generic-i686-athlon-with-
    Ubuntu-14.04-trusty)
arguments: ['/usr/bin/bzr', 'co',
    'https+webdav://xxx']
plugins: bash_completion[2.7.0dev1], changelog_merge[2.7.0dev1],
    grep[2.7.0dev1], launchpad[2.7.0dev1], netrc_credential_store[2.7.0dev1],
    news_merge[2.7.0dev1], po_merge[2.7.0dev1], weave_fmt[2.7.0dev1],
    webdav[1.12.2]
encoding: 'utf-8', fsenc: 'UTF-8', lang: 'de_DE.UTF-8'

Vincent Ladeuil (vila) wrote :

@Khaled:
> webdav[1.12.2]

It seems like you're using an outdated version of the plugin.

'bzr plugins -v' will report where you get that plugin from, can you paste the relevant output here ?

Khaled Blah (khaled-blah) wrote :

Here's the output you asked here (posting it in full):

bash_completion 2.7.0dev1
  Generate a shell function for bash command line completion.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/bash_completion

changelog_merge 2.7.0dev1
  Merge hook for GNU-format ChangeLog files
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/changelog_merge

grep 2.7.0dev1
  Print lines matching PATTERN for specified files and revisions.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/grep

launchpad 2.7.0dev1
  Launchpad.net integration plugin for Bazaar.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad

netrc_credential_store 2.7.0dev1
  Use ~/.netrc as a credential store for authentication.conf.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/netrc_credential_store

news_merge 2.7.0dev1
  Merge hook for bzr's NEWS file.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/news_merge

po_merge 2.7.0dev1
  Merge hook for ``.po`` files.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/po_merge

weave_fmt 2.7.0dev1
  Weave formats.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/weave_fmt

webdav 1.12.2
  An http transport, using webdav to allow pushing.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/webdav

This is on u14.04 beta-2 machine with plugins from the ubuntu repository. I think that should be a current version.

Khaled Blah (khaled-blah) wrote :

FYI this bug still persists on u14.04.

Khaled Blah (khaled-blah) wrote :

Any news on this?

Vincent Ladeuil (vila) wrote :

Yes, sorry for the delay, I'm trying to find the right people to help me packaging the latest bzr-webdav version into ubuntu.

In the mean time, running from source is your best option.

Khaled Blah (khaled-blah) wrote :

Thank you for your efforts, Vincent!

Vincent Ladeuil (vila) on 2014-07-02
affects: bzr (Ubuntu) → bzr-webdav (Ubuntu)

Do we have updated pywbem module with this. say 0.7.25 or so?

Khaled Blah (khaled-blah) wrote :

Since there's no progress on this bug I am going to post a patch which solves this problem for me. I only tested it on lucid (10.04) though but I believe it will also work on newer versions.

The attachment "_urllib.py.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers