bzr crashed with AssertionError in add(): adding busy connection in pool

Bug #890529 reported by Steve Langasek on 2011-11-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
High
Jelmer Vernooij
bzr-svn (Ubuntu)
Low
Unassigned

Bug Description

bzr-svn in precise is apparently completely unable to push a branch.

Output on console:

Using saved push location: svn+ssh://svn.debian.org/svn/dep
bzr: ERROR: exceptions.AssertionError: adding busy connection in pool

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 923, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1128, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 676, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 698, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/builtins.py", line 1238, in run
    use_existing_dir=use_existing_dir, no_tree=no_tree)
  File "/usr/lib/python2.7/dist-packages/bzrlib/push.py", line 143, in _show_push_branch
    remember, create_prefix)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/remote.py", line 535, in push_branch
    overwrite=overwrite)
  File "/usr/lib/python2.7/dist-packages/bzrlib/branch.py", line 1136, in push
    lossy, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/branch.py", line 1149, in push
    lossy=lossy, fetch_non_mainline=fetch_non_mainline))
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/branch.py", line 1128, in _basic_push
    lossy=lossy, fetch_non_mainline=fetch_non_mainline)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/branch.py", line 1085, in _update_revisions
    stop_revision, overwrite=overwrite, push_metadata=(not lossy))
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/branch.py", line 1065, in _push
    layout=self.target.layout, project=self.target.project)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/push.py", line 342, in push_branch
    append_revisions_only=append_revisions_only)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/push.py", line 363, in push_todo
    push_metadata=push_metadata)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/push.py", line 400, in push_revision_series
    project=project, layout=layout)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/push.py", line 419, in push_revision_inclusive
    base_foreign_info=base_foreign_info)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/push.py", line 449, in push_single_revision
    root_action=root_action)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/push.py", line 181, in push_revision_tree
    revid = builder.commit(rev.message)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/errors.py", line 141, in convert
    return unbound(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/commit.py", line 870, in commit
    self.repository.transport.add_connection(self.conn)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/transport.py", line 403, in add_connection
    self.connections.add(conn)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/transport.py", line 332, in add
    assert not connection.busy, "adding busy connection in pool"
AssertionError: adding busy connection in pool

You can report this problem to Bazaar's developers by running
    apport-bug /var/crash/bzr.1000.2011-11-15T03:16.crash
if a bug-reporting window does not automatically appear.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bzr 2.5.0~beta3-1ubuntu1
ProcVersionSignature: Ubuntu 3.1.0-3.3-generic 3.1.0
Uname: Linux 3.1.0-3-generic x86_64
ApportVersion: 1.26-0ubuntu1
Architecture: amd64
BzrDebugFlags: set()
BzrVersion: 2.5b3
CommandLine: ['/usr/bin/bzr', 'push']
CrashDb: bzr
Date: Mon Nov 14 19:16:07 2011
ExecutablePath: /usr/bin/bzr
FileSystemEncoding: UTF-8
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
InterpreterPath: /usr/bin/python2.7
Locale: en_US.UTF-8
PackageArchitecture: all
Platform: Linux-3.1.0-3-generic-x86_64-with-Ubuntu-12.04-precise
ProcCmdline: /usr/bin/python /usr/bin/bzr push
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonVersion: 2.7.2
SourcePackage: bzr
Title: bzr crashed with AssertionError in add(): adding busy connection in pool
UpgradeStatus: Upgraded to precise on 2011-11-08 (6 days ago)
UserEncoding: UTF-8
UserGroups: adm admin cdrom dialout libvirtd lpadmin mythtv plugdev sambashare src

Steve Langasek (vorlon) wrote :
visibility: private → public
Changed in bzr-svn (Ubuntu):
importance: Undecided → High
tags: removed: need-duplicate-check
Jelmer Vernooij (jelmer) wrote :

I can't reproduce this. What happens if you comment out line 870 of /usr/lib/python2.7/dist-packages/bzrlib/plugins/svn/commit.py, do you get a different exception?

Steve Langasek (vorlon) wrote :

I can reproduce this with the oneiric bzr-svn package as well; it looks like this might be a problem with permissions on the repo.

Changed in bzr-svn (Ubuntu):
importance: High → Low
Steve Langasek (vorlon) wrote :

After commenting out the line in question, I now get:

bzr: ERROR: [Errno 13] Can't create directory '/svn/dep/db/transactions/206-1.txn': Permission denied

Jelmer Vernooij (jelmer) on 2011-11-15
Changed in bzr-svn:
status: New → Triaged
Changed in bzr-svn (Ubuntu):
status: New → Triaged
Changed in bzr-svn:
importance: Undecided → High
Jelmer Vernooij (jelmer) on 2011-12-10
Changed in bzr-svn:
status: Triaged → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 1.1.2
Jelmer Vernooij (jelmer) on 2011-12-11
Changed in bzr-svn:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-svn - 1.1.2-1

---------------
bzr-svn (1.1.2-1) unstable; urgency=low

  * Update copyright file to match DEP5.
  * New upstream release.
   + Fixes compatibility with newer versions of bzr. LP: #902539
   + Better error message when a commit fails. LP: #890529

 -- Jelmer Vernooij <email address hidden> Sun, 11 Dec 2011 15:29:35 +0100

Changed in bzr-svn (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers