bzr-notify crashed with SIGSEGV in g_return_if_fail_warning()

Bug #903696 reported by yohgaz on 2011-12-13
280
This bug affects 42 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
High
Siriya Gosuwin
bzr-gtk (Ubuntu)
Medium
Siriya Gosuwin

Bug Description

This bug seems to the starting up of ubuntu after a few seconds. I don't know if that plays, but I use gnome-shell

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bzr-gtk 0.100.0+bzr763-1
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Uname: Linux 3.2.0-4-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Tue Dec 13 13:51:11 2011
ExecutablePath: /usr/bin/bzr-notify
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/bzr-notify
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xc1fee4 <_IO_default_xsputn+4>: push %esi
 PC (0x00c1fee4) ok
 source "%esi" ok
 destination "(%esp)" (0xbf76b000) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: bzr-gtk
StacktraceTop:
 g_return_if_fail_warning () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_type_get_qdata () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
Title: bzr-notify crashed with SIGSEGV in g_return_if_fail_warning()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

yohgaz (yohanngazziero) wrote :

StacktraceTop:
 g_return_if_fail_warning (log_domain=0x519678 "GLib-GObject", pretty_function=0x521bb8 "g_type_get_qdata", expression=0x51f227 "node != NULL") at /build/buildd/glib2.0-2.31.4.is.2.31.2/./glib/gmessages.c:801
 g_type_get_qdata (type=0, quark=55) at /build/buildd/glib2.0-2.31.4.is.2.31.2/./gobject/gtype.c:3681
 pygobject_lookup_class (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:905
 pygobject_lookup_class (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:894
 pyg_type_get_bases (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:659

Changed in bzr-gtk (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr-gtk (Ubuntu):
status: New → Confirmed
visibility: private → public
John Vivirito (gnomefreak) wrote :

I'm seeing this as well upon login.
I'm going to assume since it is marked as confirmed you dont need my crash info but if you would like it let me know.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

NeilGreenwood (neil-greenwood) wrote :

It's also not related to gnome-shell, since I'm using Unity.

Andy Whitcroft (apw) wrote :

Also confirming on Unity. I suspect its actually a shutdown crash.

Curtis Hovey (sinzui) wrote :

This may relate to bug 903444. the gtk3 version of it is import pynotify and appindicator, gtk2 libs.

Curtis Hovey (sinzui) wrote :

Unity and Shell are handled differently in bzr-notify, but both are currently using gtk2 api.

Curtis Hovey (sinzui) wrote :

I marked this fix committed because the fix for bug 903444 removed gtk2 paths of execution. This should be verified with lp:bzr or version 0.104.0 when it is released.

Changed in bzr-gtk:
milestone: none → 0.104.0
importance: Undecided → High
status: New → Fix Committed
Toni (antoniovx) wrote :

Also crash in gnome-session-fallback. Something related with gkt new updates.

tags: added: bugpattern-needed
Changed in bzr-gtk (Ubuntu):
assignee: nobody → Siriya Gosuwin (siriya123)
Changed in bzr-gtk:
assignee: nobody → Siriya Gosuwin (siriya123)
Toni (antoniovx) wrote :

It crashes when starting session, but in my case in gnome classic without effects.
GDM descktop manager.
I use nvidia-current module (295.20).

Today on a just upgraded 12.04 beta1 release 32 bits

Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers