Multiple packages are titled "Bazaar" in the Ubuntu Software Center

Bug #854245 reported by Māris Fogels on 2011-09-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Medium
Jelmer Vernooij
bzr-gtk (Ubuntu)
High
Jelmer Vernooij

Bug Description

The Ubuntu Software Center shows multiple similar-looking packages when you search for the word "Bazaar". The first package shown in the results list is not Bazaar, it is bzr-gtk, but nothing in the package information shown will tell you that. This is confusing to users and may lead them to view the wrong package information pages or install the wrong software. I would expect "Bazaar Version Control System" to be the first and obvious choice when searching for the term 'bazaar' in the Ubuntu Software Center.

The Unity window manager's 'Installable Software' search lens in Oneiric uses the same search results but displays even less information. Making a distinction between the two packages is even more difficult.

I have attached a screenshot showing the results I am seeing.

Jelmer Vernooij (jelmer) wrote :

reassigning to bzr-gtk since that should probably have its title changed.

affects: bzr → bzr-gtk (Ubuntu)
Changed in bzr-gtk (Ubuntu):
importance: Undecided → High
status: New → Triaged

That's coming from the bzr-handle-patch.desktop file. As none of the desktopfiles in the package really do a good job of describing the package as a whole, it might be best to over-ride it in app-install-data-ubuntu.

On Mon, 19 Sep 2011 23:05:06 -0000, Andrew Starr-Bochicchio <email address hidden> wrote:
> That's coming from the bzr-handle-patch.desktop file. As none of the
> desktopfiles in the package really do a good job of describing the
> package as a whole, it might be best to over-ride it in app-install-
> data-ubuntu.

I would have thought that desktop file would have an option for it to
not show up in menus (as it's a handler rather than an application you
would run from a menu I think,) and that app-install-data would
similarly ignore it.

Am I wrong on any of those points? If not, is the file missing such an
option?

Thanks,

James

On Mon, Sep 19, 2011 at 7:47 PM, James Westby <email address hidden> wrote:
> On Mon, 19 Sep 2011 23:05:06 -0000, Andrew Starr-Bochicchio <email address hidden> wrote:
>> That's coming from the  bzr-handle-patch.desktop file. As none of the
>> desktopfiles in the package really do a good job of describing the
>> package as a whole, it might be best to over-ride it in app-install-
>> data-ubuntu.
>
> I would have thought that desktop file would have an option for it to
> not show up in menus (as it's a handler rather than an application you
> would run from a menu I think,) and that app-install-data would
> similarly ignore it.
>
> Am I wrong on any of those points? If not, is the file missing such an
> option?

I think app-install-data should ignore it as "NoDisplay=true" is set.
See: http://bazaar.launchpad.net/~bzr-gtk/bzr-gtk/trunk/view/head:/bzr-handle-patch.desktop.in

But the text in the Name field is simply Bazaar and the Comment field
is "Apply Bazaar Bundle" That is exact what appears in Software
Center. I can't imagine anywhere else it would be picked up from...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in app-install-data-ubuntu (Ubuntu):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2012-03-23
Changed in bzr-gtk (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2012-03-24
no longer affects: app-install-data-ubuntu (Ubuntu)
Changed in bzr-gtk:
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 0.104.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-gtk - 0.103.0+bzr792-1ubuntu1

---------------
bzr-gtk (0.103.0+bzr792-1ubuntu1) precise; urgency=low

  * Merge from Debian. Remaining changes:
   + Add build dependency on appmenu-gtk3, required to prevent module
     loading errors in bzr-notify tests.

bzr-gtk (0.103.0+bzr792-1) unstable; urgency=low

  * New upstream snapshot.
   + Prevents bzr-handle-patch from showing up in software center.
     LP: #854245
   + Fixes crash when no revision is available in 'bzr viz'. LP: #281717
   + Fixes searching in 'bzr viz'. LP: #928301

bzr-gtk (0.103.0+bzr780-2) unstable; urgency=low

  * Swap elements of or condition build-dependecy, to make some autobuilders
    happy. Closes: #664958
 -- Jelmer Vernooij <email address hidden> Tue, 03 Apr 2012 02:19:20 +0200

Changed in bzr-gtk (Ubuntu):
status: Triaged → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-08
Changed in bzr-gtk:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers