git clone bzr::lp:armel-cross-toolchain-base creates duplicated tags

Bug #905275 reported by Marcin Juszkiewicz
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar Git Plugin
Fix Released
Medium
Jelmer Vernooij
bzr-git (Ubuntu)
Fix Released
Medium
Jelmer Vernooij

Bug Description

hrw@puchatek:tmp$ git clone bzr::lp:ubuntu/armel-cross-toolchain-base actb-bzrclone
Cloning into 'actb-bzrclone'...
unknown command "commit"
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
Most recent Ubuntu version: 1.76
Packaging branch version: 1.72
Packaging branch status: OUT-OF-DATE
hrw@puchatek:tmp$ cd actb-bzrclone/
hrw@puchatek:actb-bzrclone$ git tag -l
warning: Duplicated ref: refs/tags/1.16
warning: Duplicated ref: refs/tags/1.19
warning: Duplicated ref: refs/tags/1.20
warning: Duplicated ref: refs/tags/1.22
warning: Duplicated ref: refs/tags/1.23
warning: Duplicated ref: refs/tags/1.24
warning: Duplicated ref: refs/tags/1.25
warning: Duplicated ref: refs/tags/1.26
warning: Duplicated ref: refs/tags/1.27
warning: Duplicated ref: refs/tags/1.28
warning: Duplicated ref: refs/tags/1.29
warning: Duplicated ref: refs/tags/1.30
warning: Duplicated ref: refs/tags/1.31
warning: Duplicated ref: refs/tags/1.32
warning: Duplicated ref: refs/tags/1.33
warning: Duplicated ref: refs/tags/1.34
warning: Duplicated ref: refs/tags/1.35
warning: Duplicated ref: refs/tags/1.36
warning: Duplicated ref: refs/tags/1.37
warning: Duplicated ref: refs/tags/1.38
warning: Duplicated ref: refs/tags/1.39
warning: Duplicated ref: refs/tags/1.40
warning: Duplicated ref: refs/tags/1.41
warning: Duplicated ref: refs/tags/1.42
warning: Duplicated ref: refs/tags/1.43
warning: Duplicated ref: refs/tags/1.44
warning: Duplicated ref: refs/tags/1.45
warning: Duplicated ref: refs/tags/1.46
warning: Duplicated ref: refs/tags/1.47
warning: Duplicated ref: refs/tags/1.48
warning: Duplicated ref: refs/tags/1.49
warning: Duplicated ref: refs/tags/1.50
warning: Duplicated ref: refs/tags/1.52
warning: Duplicated ref: refs/tags/1.53
warning: Duplicated ref: refs/tags/1.54
warning: Duplicated ref: refs/tags/1.55
warning: Duplicated ref: refs/tags/1.57
warning: Duplicated ref: refs/tags/1.58
warning: Duplicated ref: refs/tags/1.58+build1
warning: Duplicated ref: refs/tags/1.59
warning: Duplicated ref: refs/tags/1.61
warning: Duplicated ref: refs/tags/1.61build1
warning: Duplicated ref: refs/tags/1.62
warning: Duplicated ref: refs/tags/1.64
warning: Duplicated ref: refs/tags/1.65
warning: Duplicated ref: refs/tags/1.66
warning: Duplicated ref: refs/tags/1.67
warning: Duplicated ref: refs/tags/1.68
warning: Duplicated ref: refs/tags/1.69
warning: Duplicated ref: refs/tags/1.70
warning: Duplicated ref: refs/tags/1.71
warning: Duplicated ref: refs/tags/1.72
1.16
1.19
1.20
1.22
1.23
1.24
1.25
1.26
1.27
1.28
1.29
1.30
1.31
1.32
1.33
1.34
1.35
1.36
1.37
1.38
1.39
1.40
1.41
1.42
1.43
1.44
1.45
1.46
1.47
1.48
1.49
1.50
1.52
1.53
1.54
1.55
1.57
1.58
1.58+build1
1.59
1.61
1.61build1
1.62
1.64
1.65
1.66
1.67
1.68
1.69
1.70
1.71
1.72

But when I use remotes (git remote add bzr bzr::lp:ubuntu/armel-cross-toolchain-base) I do not get warnings about duplicated tags.
---
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
Package: bzr-git 0.6.5+bzr1465-1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Tags: precise
Uname: Linux 3.2.0-4-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare vboxusers video

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : Dependencies.txt

apport information

tags: added: apport-collected precise
description: updated
Revision history for this message
Marcin Juszkiewicz (hrw) wrote : ProcEnviron.txt

apport information

Jelmer Vernooij (jelmer)
Changed in bzr-git:
status: New → Triaged
Changed in bzr-git (Ubuntu):
status: New → Triaged
Changed in bzr-git:
importance: Undecided → Medium
Changed in bzr-git (Ubuntu):
importance: Undecided → Medium
tags: added: git-remote-bzr
Revision history for this message
Jelmer Vernooij (jelmer) wrote :

I can no longer reproduce this using trunk on precise - can you?

Changed in bzr-git:
status: Triaged → Incomplete
Revision history for this message
Jelmer Vernooij (jelmer) wrote :

Found it - the issue seems to be that bzr-git's implementation of 'fetch' also copies tags, while git also does this on its own.

Changed in bzr-git:
status: Incomplete → Triaged
Jelmer Vernooij (jelmer)
Changed in bzr-git:
status: Triaged → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 0.6.8
status: In Progress → Fix Committed
Jelmer Vernooij (jelmer)
Changed in bzr-git:
status: Fix Committed → Fix Released
Changed in bzr-git (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-git - 0.6.8-1

---------------
bzr-git (0.6.8-1) unstable; urgency=low

  * New upstream release.
   + Fixes creation of duplicate tags in git-remote-bzr. LP: #905275
  * Install upstream changelog.

 -- Jelmer Vernooij <email address hidden> Wed, 28 Mar 2012 14:58:18 +0200

Changed in bzr-git (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers