bzr crashed with AttributeError in load_using_delta(): 'PackRootCommitBuilder' object has no attribute '_config'

Bug #923031 reported by Antono Vasiljev on 2012-01-28
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Bazaar Fast Import
Medium
Jelmer Vernooij
bzr-fastimport (Ubuntu)
High
Jelmer Vernooij

Bug Description

used from git-bzr-ng

git bzr push lp:~antono/+junk/xnoise

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bzr 2.5.0~beta5-3ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-11.19-generic 3.2.1
Uname: Linux 3.2.0-11-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
BzrDebugFlags: set()
BzrVersion: 2.5b5
CrashDb: bzr
Date: Sat Jan 28 14:23:13 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/bzr
FileSystemEncoding: UTF-8
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
InterpreterPath: /usr/bin/python2.7
Locale: en_US.UTF-8
PackageArchitecture: all
Platform: Linux-3.2.0-11-generic-i686-with-Ubuntu-12.04-precise
ProcCmdline: /usr/bin/python /usr/bin/bzr fast-import --import-marks=/home/username/Code/synapse/.git/bzr/map/master-bzr --export-marks=/home/username/Code/synapse/.git/bzr/map/xnoise-plugin-bzr - /home/username/Code/synapse/.git/bzr/repo/xnoise-plugin
PythonVersion: 2.7.2
SourcePackage: bzr
Title: bzr crashed with AttributeError in load_using_delta(): 'PackRootCommitBuilder' object has no attribute '_config'
UpgradeStatus: Upgraded to precise on 2012-01-26 (1 days ago)
UserEncoding: utf-8
UserGroups: adm admin cdrom debian-tor dialout kismet libvirtd lpadmin plugdev sambashare stapdev wireshark

Antono Vasiljev (antono) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr (Ubuntu):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2012-02-10
visibility: private → public
Changed in bzr (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
affects: bzr (Ubuntu) → bzr-fastimport (Ubuntu)
Changed in bzr-fastimport (Ubuntu):
assignee: Jelmer Vernooij (jelmer) → nobody
Changed in bzr-fastimport:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 0.12.0
Jelmer Vernooij (jelmer) on 2012-02-18
Changed in bzr-fastimport (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr-fastimport:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-fastimport - 0.12.0-1

---------------
bzr-fastimport (0.12.0-1) unstable; urgency=low

  * New upstream release.
   + Fixes compatibility with bzr 2.5. LP: #923031

 -- Jelmer Vernooij <email address hidden> Sat, 18 Feb 2012 15:19:59 +0100

Changed in bzr-fastimport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers