bzr crashed with AttributeError in iter_entries_by_dir() during fast-export

Bug #631979 reported by Henrik Nyberg on 2010-09-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar Fast Import
Medium
Jelmer Vernooij
bzr-fastimport (Ubuntu)
Medium
Jelmer Vernooij

Bug Description

Binary package hint: bzr-fastimport

This crash happens during a fast-export of a small repository, with nothing fancy as far as I know.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: bzr 2.2.0-1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
BzrDebugFlags: set()
BzrVersion: 2.2.0
CheckboxSubmission: 3be438dd131cd5b7b50bcec276ba0c45
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
CommandLine: ['/usr/bin/bzr', 'fast-export', '--plain', 'pool-work', 'foo']
CrashDb: bzr
Date: Mon Sep 6 23:38:08 2010
ExecutablePath: /usr/bin/bzr
FileSystemEncoding: UTF-8
InterpreterPath: /usr/bin/python2.6
Locale: sv_SE.UTF-8
Platform: Linux-2.6.35-19-generic-x86_64-with-Ubuntu-10.10-maverick
ProcCmdline: /usr/bin/python /usr/bin/bzr fast-export --plain pool-work foo
ProcEnviron:
 LANGUAGE=sv:en
 PATH=(custom, user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/zsh
PythonVersion: 2.6.6
SourcePackage: bzr
Title: bzr crashed with AttributeError in iter_entries_by_dir()
UserEncoding: UTF-8
UserGroups: admin pulse pulse-access video

Henrik Nyberg (henrik-mysko) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Henrik Nyberg (henrik-mysko) wrote :

The problem seems to be caused by a file that is renamed into a directory. I don't know how this rename ended up in the repository, but according to Jelmer it is a valid operation.

I made a small patch that appears to solve this problem for me, but I don't know if it might break in other cases. The patch stops fast-export from trying to rename all children of a file (which has no children).

tags: added: patch
Jelmer Vernooij (jelmer) on 2011-06-17
Changed in bzr-fastimport (Ubuntu):
status: New → Triaged
Changed in bzr-fastimport:
status: New → Triaged
importance: Undecided → Medium
Changed in bzr-fastimport (Ubuntu):
importance: Undecided → Medium
Jelmer Vernooij (jelmer) on 2011-08-17
Changed in bzr-fastimport:
status: Triaged → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 0.11.0
Jelmer Vernooij (jelmer) on 2011-08-22
Changed in bzr-fastimport:
status: Fix Committed → Fix Released
Changed in bzr-fastimport (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-fastimport - 0.11.0-1

---------------
bzr-fastimport (0.11.0-1) unstable; urgency=low

  * New upstream release.
   + Fixes crash in "bzr fast-import-filter". LP: #792935
   + Fixes attribute error in iter_entries_by_dir() during fast-export.
     LP: #631979
 -- Jelmer Vernooij <email address hidden> Wed, 24 Aug 2011 08:12:51 +0000

Changed in bzr-fastimport (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers