Bazaar explorer crashes on startup

Bug #877654 reported by Jay Ó Broin on 2011-10-18
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Bazaar Explorer
Undecided
Unassigned
bzr-explorer (Ubuntu)
Undecided
Unassigned

Bug Description

Bazaar explorer crashes on startup. Here's the terminal output:

$ bzr explorer -v

(python:5953): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(python:5953): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(python:5953): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(python:5953): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Connected to accessibility bus at: "unix:abstract=/tmp/dbus-eH1OTyi8v5,guid=0d87a0361936d970112fad1a00000020"
Registered DEC: true
Invalid parent: 0xafc1950 QToolBox(0xafafc18)
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xafafc18) 1
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xafafc18) 2
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xafafc18) 3
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xafafc18) 4
ASSERT: "interface->childCount() == children.count()" in file adaptor.cpp, line 200
Aborted

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: bzr-explorer 1.2.1-1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Tue Oct 18 15:42:22 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110909)
PackageArchitecture: all
SourcePackage: bzr-explorer
UpgradeStatus: Upgraded to oneiric on 2011-09-22 (26 days ago)

Jay Ó Broin (ismise) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr-explorer (Ubuntu):
status: New → Confirmed
Pete Pope (pete-pope) wrote :

peterp@peterp-ThinkPad-R50p:~$ bzr explorer -v
Connected to accessibility bus at: "unix:abstract=/tmp/dbus-araJ4LqQ6d,guid=3818055a741b2def4e778e9c00004b4d"
Registered DEC: true
Invalid parent: 0xabbaff0 QToolBox(0xabae860)
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xabae860) 1
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xabae860) 2
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xabae860) 3
QSpiAdaptor::getChild INVALID CHILD: QToolBox(0xabae860) 4
ASSERT: "interface->childCount() == children.count()" in file adaptor.cpp, line 200
Aborted
peterp@peterp-ThinkPad-R50p:~$

mostly the same problem

Pete Pope (pete-pope) wrote :

Apparently this is a problem in package qt-at-spi. Removing the package fixes the problem.

sudo apt-get remove qt-at-spi

Jay Ó Broin (ismise) wrote :

Thanks for the tip, removing qt-at-spi worked for me as well.

Changed in bzr-explorer:
status: New → Invalid
Phill (phill.l) wrote :

Is there a bug report for this problem against package qt-at-spi? Should we re-assign this bug to that package? My understanding is that the package is part of the accessibility stuff so I'm loathed to remove it permanently.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers