missing dependency on quilt

Bug #951207 reported by Steve Langasek on 2012-03-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bzr-builddeb
Medium
Jelmer Vernooij
bzr-builddeb (Ubuntu)
Medium
Jelmer Vernooij

Bug Description

Every time I try to build a package in a chroot with bzr bd, I now get this:

Building using working tree
Building package in normal mode
Looking for a way to retrieve the upstream tarball
Using pristine-tar to reconstruct libvisual-plugins_0.4.0.dfsg.1.orig.tar.gz.
bzr: ERROR: quilt is not installed, please install it

The quilt package is not otherwise required in order to build packages (including v3 packages) from source; it's only because bzr bd now calls quilt that this error occurs.

Either bzr-builddeb needs to depend on quilt, or it needs to be more graceful about not finding it when it's not needed (I suspect it's not actually needed here).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bzr-builddeb 2.8.2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94.1-0ubuntu1
Architecture: amd64
CheckboxSubmission: 017452a27eca3c8b498abbfa5ef91db9
CheckboxSystem: ecaaad6fa1e0799a0aa1126bf620f39e
Date: Fri Mar 9 14:46:16 2012
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: bzr-builddeb
UpgradeStatus: Upgraded to precise on 2011-11-08 (122 days ago)

Steve Langasek (vorlon) wrote :
Changed in bzr-builddeb (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Jelmer Vernooij (jelmer) on 2012-03-13
Changed in bzr-builddeb:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr-builddeb (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-builddeb - 2.8.4

---------------
bzr-builddeb (2.8.4) unstable; urgency=low

  * Add dependency on quilt. LP: #951207
  * Cope with missing tags when looking up upstream versions.
  * Skip quilt unapplying for trees that can not be copied (such as
    _PreviewTree). LP: #950419
  * Document the argument for --export-upstream. LP: #959065

 -- Jelmer Vernooij <email address hidden> Mon, 19 Mar 2012 11:10:21 +0100

Changed in bzr-builddeb (Ubuntu):
status: Fix Committed → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-03
Changed in bzr-builddeb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers