Latest byobu in Precise ignores byobu-ctrl-a settings, treats CTRL-A like Emacs

Bug #931345 reported by Graham Binns on 2012-02-13
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
High
Dustin Kirkland 

Bug Description

After the most recent update, byobu-ctrl-a ran when I logged in. I selected option (1) (Screen mode). However, hitting CTRL-A does nothing any more (so CTRL-A, c, which used to create a new window, now just types the letter "c"). This is true regardless of what I choose in byobu-ctrl-a.

The current version I'm running is:

$ byobu -v
byobu version 5.9
tmux 1.6

Related branches

Dustin Kirkland  (kirkland) wrote :

Doh, sorry Graham.

I made a few changes to byobu-ctrl-a this weekend to get it to work in tmux. I must have broken something....

Can you paste the output of:
 $ cat ~/.byobu/keybindings.tmux ?

Changed in byobu (Ubuntu):
importance: Undecided → High
assignee: nobody → Dustin Kirkland (kirkland)
status: New → Incomplete
Dustin Kirkland  (kirkland) wrote :

One followup... The fact that byobu-ctrl-a ran was introduced by byobu 5.9 -- previously, byobu-ctrl-a was not supported by tmux.

Dustin Kirkland  (kirkland) wrote :

So I tried to reproduce this as follows, but it seems to be working as desired...

1) rm -f ~/.byobu/keybindings.tmux
2) F5 refresh profile
3) press ctrl-a
4) byobu-ctrl-a script runs, prompting for selecting 1 or 2
5) select 1
6) press "ctrl-a c" and it creates a new window

Then I do this:
1) rm -f ~/.byobu/keybindings.tmux
2) F5 refresh profile
3) press ctrl-a
4) byobu-ctrl-a script runs, prompting for selecting 1 or 2
5) select 2
6) 'asdfasdf' then press "ctrl-a" and watch the cursor go to the beginning of the line

Patrick Martin (pmartin176) wrote :

I am experiencing the same thing as Graham since the package from the PPA got updated to the 5.9 version.

I too use tmux 1.6.

Graham Binns (gmb) wrote :

Hi Dustin,

Following your steps above, I always get the emacs / start-of-line behaviour, regardless of whether I choose option 1 or 2 in byobu-ctrl-a.

Here are the contents of ~/.byobu/keybindings.tmux:

unbind-key -n C-a
set -g prefix ^A,F12
bind a send-prefix

Patrick Martin (pmartin176) wrote :

What Graham describes in his latest message also applies to me.

Changed in byobu (Ubuntu):
status: Incomplete → In Progress
Dustin Kirkland  (kirkland) wrote :

Oh, hmm... I'm still running Oneiric, and I have byobu 5.9 but tmux 1.5. You're on tmux 1.6.

I'll install tmux 1.6 now and see if I can reproduce the issue...

Dustin Kirkland  (kirkland) wrote :

Aha... Tmux 1.6 changelog shows:
 * Drop the ability to have a list of keys in the prefix in favour of two
  separate options, prefix and prefix2.
 * Flag -2 added to send-prefix to send the secondary prefix key.

And that breaks us :-( I'll need to work around this....

Dustin Kirkland  (kirkland) wrote :

Ugh, this is going to be a pain... We'll have to have two different configuration file options here...one for tmux 1.5 users, and one for tmux 1.6 users.

Dustin Kirkland  (kirkland) wrote :

Okay, fix committed.

Note that users affected by this (users who upgraded to byobu 5.9) will need to manually run byobu-ctrl-a one time to fix their ~/.byobu/keybindings.tmux file. Sorry!

Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.10-0ubuntu1

---------------
byobu (5.10-0ubuntu1) precise; urgency=low

  * usr/bin/byobu-ctrl-a: LP: #931345
    - fix ctrl-a support for tmux 1.5 and 1.6
 -- Dustin Kirkland <email address hidden> Sun, 12 Feb 2012 11:07:46 -0600

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Graham Binns (gmb) wrote :

Thanks Dustin, great work!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers