Some terminal shortcuts don't work within byobu-tmux

Bug #923134 reported by Chris Wayne on 2012-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
High
Dustin Kirkland 

Bug Description

If the user tries to use ctrl+a to go to the beginning of the line or ctrl+e to go to the end, byobu-tmux gets confused and thinks youre either trying to resize the current window or switch windows.

Ubuntu: (Seen in Oneiric and Precise)
byobu: 5.5-0ubuntu1

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: byobu 5.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic-pae 3.2.1
Uname: Linux 3.2.0-10-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sat Jan 28 14:29:35 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ScreenRC:

SourcePackage: byobu
UpgradeStatus: Upgraded to precise on 2012-01-13 (14 days ago)

Chris Wayne (cwayne18) wrote :

I'm not sure if this is a bug or a design decision ... please set importants and assign/unassign as appropriate

Changed in byobu (Ubuntu):
assignee: nobody → Canonical Server Team (canonical-server)
Serge Hallyn (serge-hallyn) wrote :

I can't actually reproduce this. ctrl-e works just fine. ctrl-a is intercepted because it is the escape code, but 'ctrl-a' followed by 'a' does what it should (act like ctrl-a). Note you can change the escape code by hitting 'f9' and choosing 'change escape sequence'.

Changed in byobu (Ubuntu):
assignee: Canonical Server Team (canonical-server) → Dustin Kirkland (kirkland)
Changed in byobu (Ubuntu):
importance: Undecided → High
status: New → In Progress

Excerpts from Serge Hallyn's message of Wed Feb 08 15:15:03 UTC 2012:
> I can't actually reproduce this. ctrl-e works just fine. ctrl-a is
> intercepted because it is the escape code, but 'ctrl-a' followed by 'a'
> does what it should (act like ctrl-a). Note you can change the escape
> code by hitting 'f9' and choosing 'change escape sequence'.
>

This does seem like a regression from the screen flavor of byobu, which
would pop up a question "do you want ctrl-A to be the escape code or
use f12?". Perhaps that was just a transitional thing, and I found it
rather offputting to be asked actually (I'd prefer that the esc code
just be f12 since f-keys are meant for terminal/application control).

Anyway, I think this just needs to be well documented. It would be
especially helpful if byobu changed something on the status line to
inform people that the escape key had been pressed.

Dustin Kirkland  (kirkland) wrote :

On Wed, Feb 8, 2012 at 10:51 AM, Clint Byrum <email address hidden> wrote:
> This does seem like a regression from the screen flavor of byobu, which
> would pop up a question "do you want ctrl-A to be the escape code or
> use f12?". Perhaps that was just a transitional thing, and I found it
> rather offputting to be asked actually (I'd prefer that the esc code
> just be f12 since f-keys are meant for terminal/application control).

Some users tell me that they don't have an F12 key on their keyboard,
Clint. I've never encountered such a keyboard, personally, but that's
what they tell me...

The first-time-you-press-ctrl-a thing is meant to be pretty permanent,
I'm afraid, Clint. You'll be asked the question in byobu tmux or
screen. You have the option of choosing to have ctrl-a behave in GNU
Screen mode, or behave in GNU Emacs mode (and F12 becomes your
escape).

> Anyway, I think this just needs to be well documented. It would be
> especially helpful if byobu changed something on the status line to
> inform people that the escape key had been pressed.

Unfortunately, I don't think that the status line refreshes fast
enough for this to be useful. It refreshes about once-per-second,
which is eons in the scope of keypresses. I'll give that some more
thought, though, as I do like the idea of a visual queue that you're
in screen or tmux escape mode...

Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.9-0ubuntu1

---------------
byobu (5.9-0ubuntu1) precise; urgency=low

  * usr/bin/byobu-status:
    - fix broken status expiration, which wasn't working and probably
      had a huge performance penalty :-(
  * usr/bin/byobu-ctrl-a, usr/share/byobu/keybindings/f-keys.tmux,
    usr/share/byobu/keybindings/f-keys.tmux.disable,
    usr/share/byobu/profiles/tmuxrc: LP: #923134
    - get byobu-ctrl-a working within tmux, like screen
    - prompt the user for ctrl-a to work in Screen/escape mode, or emacs
      mode
 -- Dustin Kirkland <email address hidden> Sun, 12 Feb 2012 10:01:36 -0600

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers