byobu emacs mode escape key fails

Bug #887387 reported by asdf on 2011-11-08
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Medium
Unassigned

Bug Description

Byobu now offers not to use ctrl-a as its escape sequence because it interferes with Emacs. However, on choosing 'Emacs mode (go to beginning of line)' when prompted, I found that neither F12 nor the alternative escape sequence I choose via F9 did anything, despite the implication that they would.

To reproduce:

$ byobu-ctrl-a

Configure Byobu's ctrl-a behavior...

When you press ctrl-a in Byobu, do you want it to operate in:
    (1) Emacs mode (go to beginning of line)
    (2) Screen mode (GNU Screen's default escape sequence)

Note that:
  - F12 also operates as Screen escape in Byobu
  - You can press F9 and choose your escape character
  - You can run 'byobu-ctrl-a' at any time to change your selection

Select [1 or 2]: 1

$ byobu

F12 c (<- expect new screen, get 'c')

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: byobu 4.37-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Nov 8 00:36:07 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
ScreenRC:

SourcePackage: byobu
UpgradeStatus: Upgraded to oneiric on 2011-11-07 (0 days ago)

asdf (1920119-d) wrote :
Dustin Kirkland  (kirkland) wrote :

Okay, I've tested this and it's working fine in byobu-screen, but not in byobu-tmux. I'm confirming it and fixing it there.

Changed in byobu (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
status: Incomplete → In Progress
Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 4.46-0ubuntu1

---------------
byobu (4.46-0ubuntu1) precise; urgency=low

  * debian/control: LP: #887344
    - promote tmux to a 'recommends'; will 'depend' on it soon
  * === added directory etc/profile.d, etc/byobu/Makefile.am,
    etc/profile.d/Makefile.am, etc/profile.d/Z97-byobu.sh, Makefile.am:
    - LP: #586546
    - Enable any user to remotely opt into launching byobu by default,
      using an LC_BYOBU=1 environment variable, which is transmitted over
      SSH
  * configure.ac, debian/install, etc/byobu/Makefile.am,
    etc/profile.d/Makefile.am:
    - fix installations to /etc
  * usr/bin/byobu, usr/bin/byobu-reconnect-sockets,
    usr/share/byobu/profiles/tmux: LP: #883637
    - fix reconnection to SESSION_MANAGER and DBUS_SESSION_BUS_ADDRESS
    - add C-F5 key to tmux profile
  * usr/bin/byobu-ctrl-a, usr/share/byobu/profiles/tmux: LP: #887387
    - support F12 as escape key in tmux mode
    - reorder byobu-ctrl-a to offer screen first, then emacs mode
    - make byobu-ctrl-a slighty more compatible with tmux (not quite
      there yet...)
  * usr/bin/byobu: LP: #713879
    - add ulimit checks to byobu -v
  * usr/lib/byobu/.constants:
    - don't use UTF8 C an F for now
  * usr/lib/byobu/network: LP: #880410
    - localize some variables, fix variable colision with cpu_temp
  * debian/control:
    - bump standards version
  * debian/install, debian/rules, etc/byobu/Makefile.am,
    etc/profile.d/Makefile.am:
    - fighting with autoconf to get shtuff installing in /etc, argh
 -- Dustin Kirkland <email address hidden> Mon, 31 Oct 2011 09:46:46 -0400

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
asdf (1920119-d) wrote :

Thanks! ^_^

FYG: tmux was never installed. On the other hand, on an almost-virgin install of 11.10 on a virtual machine, F12 does work in Emacs mode, so perhaps something has gone wonky on my main machine. Glad something ended up getting fixed, anyway!

Dražen Lučanin (kermit666) wrote :

Something similar affects me. I can't use F12 as an escape char (clashes with Guake on my desktop), so I tried remapping the escape key in Byobu's F9 menu to ctrl+V. Pressing this combo doesn't do anything, though, as long as I have tmux as a backend (even after restarting byobu). Only after switching to screen, the non-default backend, did it start working.

I'm running this version:
kermit@snowwhite:~$ byobu --version
byobu version 5.17
tmux 1.6

Dražen Lučanin (kermit666) wrote :

Byobu version 5.21-0ubuntu1 and I'm still experiencing this issue.

Dana Goyette (danagoyette) wrote :

I'm still affected on byobu 5.21 in Ubuntu Quantal.

Looks like there's a duplicate here, as well:
https://bugs.launchpad.net/byobu/+bug/1045070

My observation:

Byobu uses "prefix" instead of "escape" -- see anything wrong in /usr/bin/byobu-ctrl-a?

Line 35: [ "$BYOBU_BACKEND" = "tmux" ] && keybindings="$keybindings.tmux"
Line 40: grep -qs "^escape" "$keybindings" && bind_to="emacs"

Dražen Lučanin (kermit666) wrote :

I can confirm that this issue is fixed in Ubuntu 14.04 with:

    byobu version 5.74
    tmux 1.8

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers