byobu colors do not work when connected to ssh server

Bug #800195 reported by Mike Robinson on 2011-06-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: byobu

Note, this works fine in gnome-terminal, but not in byobu.

How to reproduce:

Connect to ssh server and issue `ls -la` in a directory with various different files. Notice that the output text is not multi-colored. Disconnect and issue the same command on the local computer and notice how the output is colored.

Expected behavior:

Output should be colored like it is on the localhost

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-terminal 2.32.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
NonfreeKernelModules: fglrx wl
Architecture: i386
Date: Tue Jun 21 07:43:54 2011
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to natty on 2011-04-29 (53 days ago)
XsessionErrors: (<unknown>:5184): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed

Dustin Kirkland  (kirkland) wrote :

Hi there, thanks for the report.

I'm marking this incomplete, as I'm not able to reproduce this just yet. I'm attaching a screen shot to a server running in EC2, which I've ssh'd to. You can see colors are working well.

Can you give me a bit more info about this setup? What OS version is your ssh client and your host? What byobu version? Can you reproduce this on every host you ssh to, or just some?

Changed in byobu (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium

You're right. It does appear to be host-specific. I connected to an Ubuntu host and it did output colors, however a Centos 5.6 host did not. Connecting with regular gnome-terminal, however did output colors for both hosts. My byobu is version 3.33-0ubuntu1, GNOME Terminal 2.32.1

On your CentOS host, what version of screen are you running?

Screen version 4.00.03 (FAU) 23-Oct-06

Dustin Kirkland  (kirkland) wrote :

Hi Mike,

Can you try running:

TERM=xterm-256color byobu

and tell me if that helps?

Thanks,
Dustin

That still has the same effect. Not that it would make a difference, but I tried that command from both gnome-terminal and konsole. I tried it on another computer also running Ubuntu 11.04 and it didn't show the colors either. Perhaps if it would help, I could give a moderator temporary SSH access. Attached is a screenshot.

Launchpad Janitor (janitor) wrote :

[Expired for byobu (Ubuntu) because there has been no activity for 60 days.]

Changed in byobu (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers