byobu doesn't show disk io for non-dm drives

Bug #764584 reported by Philip Muškovac on 2011-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Medium
Dustin Kirkland 

Bug Description

Binary package hint: byobu

It seems that the fix for bug 709224 broke the disk_io output of normal drives. Adding -f to readlink in line 32 fixes it for me.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: byobu 3.32-0ubuntu1 [modified: usr/lib/byobu/disk_io]
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Apr 18 14:51:11 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110124)
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US.UTF-8
ScreenRC:

SourcePackage: byobu
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Philip Muškovac (yofel) wrote :
tags: added: regression-release
Dustin Kirkland  (kirkland) wrote :

Good catch! Thanks!

Changed in byobu (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland (kirkland)
Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 3.33-0ubuntu1

---------------
byobu (3.33-0ubuntu1) natty; urgency=low

  * usr/bin/byobu-launch: make sure this finishes with a true
  * usr/lib/byobu/disk_io: conditionally use readlink -f, LP: #764584
 -- Dustin Kirkland <email address hidden> Sun, 17 Apr 2011 13:30:34 -0500

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers