gnome-terminal thinks it's Byobu Terminal

Bug #1512498 reported by Barry Warsaw on 2015-11-02
28
This bug affects 7 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
High
Dustin Kirkland 

Bug Description

After dist-upgrading from Wily to Xenial, gnome-terminal has a global menu bar entry, and switcher icon of Byobu Terminal. This is regardless of whether I start Terminal via gnome-do, unity (search or sidebar), or Emacs shell buffer typing 'gnome-terminal'. Other than that, I can't tell any difference from "traditional" gnome-terminal.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-terminal 3.18.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Nov 2 15:48:52 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-12-06 (696 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: gnome-terminal
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Barry Warsaw (barry) wrote :
summary: - gnome-terminal thinks its Byobu Terminal
+ gnome-terminal thinks it's Byobu Terminal
Dustin Kirkland  (kirkland) wrote :

So this is caused by a bad fix for Bug: #1503418, where byobu thinks it's gnome-terminal. That was a regression introduced in Wily. We need a good fix for both...

Changed in gnome-terminal (Ubuntu):
importance: Undecided → High
assignee: nobody → Dustin Kirkland  (kirkland)
status: New → Confirmed
affects: gnome-terminal (Ubuntu) → byobu (Ubuntu)
Changed in byobu (Ubuntu):
status: Confirmed → Triaged
Barry Warsaw (barry) wrote :

Probably should be duped with LP: #1513113

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.99-0ubuntu2

---------------
byobu (5.99-0ubuntu2) xenial; urgency=medium

  * debian/patches/revert_desktop_match.patch:
    Revert upstream .desktop changes to match against gnome-terminal-server.
    This causes regressions as the one in bug 1503418. (LP: #1512498)

 -- Didier Roche <email address hidden> Wed, 02 Dec 2015 11:56:47 +0100

Changed in byobu (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers