byobu (screen backend) hangs when hitting the escape sequence

Bug #1316059 reported by Toshio Ito on 2014-05-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Undecided
Unassigned

Bug Description

I use fresh-installed Xubuntu 14.04 with Japanese language environment.

Versions
--------

- byobu: 5.77-0ubuntu1
- screen: 4.1.0~20120320gitdb59704-9

Procedure
---------

 $ byobu-select-backend ## use screen
 $ byobu

- Then, hit ctrl-a
- In the menu, select 1.
- After returning from the menu, hit ctrl-a

Result
------

byobu won't respond anymore.
You need to close the terminal.

Note
----

- tmux backend is fine.
- The problem exists both with xfce4-terminal and xterm.
- The problem still exists when you change the escape sequence to, e.g., ctrl-z or ctrl-e.
- I did not have this problem in Xubuntu 12.04.

Workaround
----------

- Write ~/.byobu/keybindings manually.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in byobu (Ubuntu):
status: New → Confirmed
m1fcj (hakan-koseoglu) wrote :

Verified on brand new up to date installations of Kubuntu, Lubuntu and Xubuntu on different machines.
Very annoying.

Ben Coleman (oloryn) wrote :

I first comented on this in #1322538 (which brings Ubuntu into the mix). As I noted there, I worked around this by purging byobu, tmux, and screen, removing the .byobu directory, and re-installing byobu. I suspect that merely disabling byobu, removing .byobu, and re-enabling byobu might do the trick, also. I'm not sure what triggers this. Also, it has been a few weeks since the machine I ran into this on was upgraded to 14.04, and I use the escape sequence often enough that I'm questioning whether this actually *was* the first time using the escape sequence on this machine.

Ben Coleman (oloryn) wrote :

Could this be related to https://lists.gnu.org/archive/html/screen-devel/2014-04/msg00044.html ? If so, going to the upstream version 5.78 might fix it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers