byobu-screen ctrl-a causes death

Bug #1311177 reported by Scott Moser on 2014-04-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Medium
Unassigned

Bug Description

byobu-screen seems badly broken with regard to 'ctrl-a'.

fresh instance/user:

 * run 'byobu-screen'
 * hit 'ctrl-a'
 * answer '1' to the ctrl-a prompt

byobu (screen) dies.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: byobu 5.77-0ubuntu1
ProcVersionSignature: User Name 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
Date: Tue Apr 22 15:09:34 2014
Ec2AMI: ami-00000079
Ec2AMIManifest: FIXME
Ec2AvailabilityZone: serverstack-az-1
Ec2InstanceType: m1.small
Ec2Kernel: aki-00000002
Ec2Ramdisk: ari-00000002
PackageArchitecture: all
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: byobu
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Scott Moser (smoser) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in byobu (Ubuntu):
status: New → Confirmed
Changed in byobu (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.78-0ubuntu1

---------------
byobu (5.78-0ubuntu1) utopic; urgency=medium

  * usr/share/byobu/profiles/dircolors:
    - give executables just a little more pop
    - use a light grey underline for symlinks
    - add whitespace before inline comment
  * usr/share/byobu/profiles/bashrc:
    - Enable Ubuntu-themed dircolors on Ubuntu systems
  * usr/bin/byobu-janitor.in: LP: #1311919
    - ensure that windows.tmux exists; fixes warning with F5
  * usr/bin/byobu-ctrl-a.in: LP: #1311177, #1274720
    - revert r2317 as this is breaking ctrl-a in byobu-screen in a bad way
 -- Dustin Kirkland <email address hidden> Sun, 30 Mar 2014 20:42:10 -0500

Changed in byobu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers