.screenrc bindings overrides .byobu/keybindings

Bug #1244509 reported by wgw on 2013-10-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Low
Dustin Kirkland 

Bug Description

to get copy from byobu to x clipboard I added this to ./byobu/keybindings

bind b eval writebuf 'exec /bin/sh -c "parcellite < $BYOBU_RUN_DIR/printscreen && xsel -i < $BYOBU_RUN_DIR/printscreen "'

but in the .screenrc there was this:

bind b eval writebuf 'exec /bin/sh -c "xsel -i -b < /tmp/screen-exchange"' 'exec /bin/sh -c "killall xsel"'

And that was the command that ran UNDER byobu in spite of my keybinding .

bill@bill-laptop:~$ lsb_release -rd
Description: Ubuntu 12.04.3 LTS
Release: 12.04

Axel Beckert (xtaran) wrote :

This doesn't look like a screen issue but a byobu issue to me. Hence reassigning.

P.S.: The path should be .byobu/keybindings (relative to the home directory of the user), not ./byobu/keybindings. But I suspect that's just a typo and not the cause for the issue.

affects: screen (Ubuntu) → byobu (Ubuntu)
wgw (wgwinder) wrote :

Yes, you are right: ~./byobu....

And, yes, I do think it is a byobu issue: I just have a hard time distinguishing between the two!

Thanks for the triage. The work-araound is to get rid of the key definition in .sreenrc

Dustin Kirkland  (kirkland) wrote :

Committed revision 2230.

Changed in byobu (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Dustin Kirkland  (kirkland)
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.62-0ubuntu1

---------------
byobu (5.62-0ubuntu1) trusty; urgency=low

  * usr/share/byobu/keybindings/f-keys.tmux:
    - as it turns out, showing the current window name when renaming
      is really annoying
  * usr/bin/byobu-janitor, usr/lib/byobu/menu,
    usr/share/byobu/profiles/screenrc: LP: #1244509
    - customizations of screen configuration should go in
      $BYOBU_CONFIG_DIR/.screenrc, which will be sourced last; rather than
      ~/.screenrc (which should be reserved for screen-without-byobu)
  * usr/bin/byobu-reconnect-sockets, usr/bin/byobu-select-session:
    - LP: #1243017
    - add a few environment variables to restore, including upstart
      to ensure upstart commands resume working in a session restart
  * README, usr/bin/byobu-config, usr/bin/byobu-select-session,
    usr/lib/byobu/include/ec2instancespricing.py:
    - LP: #996559, LP: #988471, LP: #1237071
    - Okay, this is the last time I'm going back and forth on this;
      for real ;-)
    - In our 3 python scripts, we are going to use #!/usr/bin/python
      + The vast majority of Byobu users are getting it from their
        distro, and the package itself appropriately depends on python
    - Advanced users, developers, and others who want to run a different
      python in their environment will need to sed update three scripts
    - I've left a hint in the README to that effect
 -- Dustin Kirkland <email address hidden> Fri, 18 Oct 2013 16:29:56 -0500

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers