/usr/bin/byobu-launch: line 59: syntax error near unexpected token `fi'

Bug #1119446 reported by Shahar Or on 2013-02-08
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
byobu
Critical
Dustin Kirkland 
byobu (Ubuntu)
Critical
Dustin Kirkland 

Bug Description

I boot up and when trying to log in through lightdm I am thrown back to lightdm.

So I switch to text console and login there. What I see is that byobu throws out an error:

-bash: /usr/bin/byobu-launch: line 59: syntax error near unexpected token `fi'
-bash: /usr/bin/byobu-launch: line 59: ` fi'
shahar@shahar-desktop:~$

So I go 'byobu-disable' and that works around the problem, allowing me to log in to the desktop session.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: byobu 5.32-0ubuntu1 [modified: usr/bin/byobu-config usr/bin/byobu-select-session usr/lib/byobu/include/ec2instancespricing.py]
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Fri Feb 8 15:24:02 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-10-12 (849 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MarkForUpload: True
PackageArchitecture: all
ScreenRC:

SourcePackage: byobu
UpgradeStatus: Upgraded to raring on 2012-11-07 (92 days ago)

Shahar Or (mightyiam) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in byobu (Ubuntu):
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

Damn. Syntax regression. Sorry. Fixing now.

Changed in byobu:
importance: Undecided → Critical
status: New → In Progress
Changed in byobu (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Critical
assignee: nobody → Dustin Kirkland (kirkland)
Changed in byobu:
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.33-0ubuntu1

---------------
byobu (5.33-0ubuntu1) raring; urgency=low

  * usr/bin/byobu-launch: LP: #1119446, #1119345
    - fix shell syntax regression
 -- Dustin Kirkland <email address hidden> Thu, 07 Feb 2013 18:11:44 -0600

Changed in byobu (Ubuntu):
status: In Progress → Fix Released

Excellent, Dustin. Thank you very much.

Sent from mobile נשלח מנייד
On Feb 9, 2013 12:55 AM, "Launchpad Bug Tracker" <email address hidden>
wrote:

> This bug was fixed in the package byobu - 5.33-0ubuntu1
>
> ---------------
> byobu (5.33-0ubuntu1) raring; urgency=low
>
> * usr/bin/byobu-launch: LP: #1119446, #1119345
> - fix shell syntax regression
> -- Dustin Kirkland <email address hidden> Thu, 07 Feb 2013 18:11:44
> -0600
>
> ** Changed in: byobu (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1119446
>
> Title:
> /usr/bin/byobu-launch: line 59: syntax error near unexpected token
> `fi'
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/byobu/+bug/1119446/+subscriptions
>

Changed in byobu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers