Some included .x model files start with UTF-8 BOM

Bug #409921 reported by Paul Sladen
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bve-route-cross-city-south (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: bve-route-cross-city-south

The MS Direct3D "X Object" format for 3D models starts with a binary header in the format:

  xof\ 0303txt\ 0032

or similar variations. Some of the files included and claiming to be '.x' files however have a UTF-8 BOM (\xef\xbb\xbf) prepended on the front.

  $ file /usr/share/games/bve/Railway/Object/Bham_X-City_South/X-CitySouth_1_3/PSR_Modern/*.x
  10mph.x: UTF-8 Unicode (with BOM) text, with CRLF line terminators
  ...

Ideally, these files should be fixed to have the errornous BOM removed.

Paul Sladen (sladen)
Changed in bve-route-cross-city-south (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bve-route-cross-city-south - 1.31.03-0ubuntu2

---------------
bve-route-cross-city-south (1.31.03-0ubuntu2) karmic; urgency=low

  * debian/watch: populate with better match attempt
  * Remove erroneous UTF-8 BOM from start of PSR_Modern/*.x (LP: #409921)
  * Remove leftover 'debian/tmp' file from Source upload

 -- Paul Sladen <email address hidden> Thu, 6 Aug 2009 18:03:00 +0100

Changed in bve-route-cross-city-south (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Paul Sladen (sladen) wrote :

After fixing this, it turns out that none of the broken .x files were actually being used... Equivalently named .csv models in the same directory were being used, as were identically name .x models in other directories; but just not the ten broken BOMed .x files!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers