does not boot from usb drive

Bug #455935 reported by mixersoft
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
busybox (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: busybox

I started "USB Startup Disk Creator" from a healthy 9.04 system and pointed to "ubuntu-9.10-beta-desktop-i386.iso". Created a USB startup disk with no errors. But when I tried to boot, I got the following:

   /init: line 1: can't open /dev/sr0: no medium found
   BusyBox v1.13.3 (Ubuntu 1:1.13-1ubuntu7) built-in shell (ash)
   ...
   (initramfs) stdin error 0
   ...
   can not mount /dev/loop1 on /cow

and it left me at initramfs.

BTW, I was never able to get a 9.04 iso to boot from a USB key either, similar problem in busybox. Right now I have to use a USB startup disk based on an 8.10 iso.

Tags: startup usb
Revision history for this message
Hugo Chinchilla (hchinchilla88) wrote :

I can confirm this bug

Revision history for this message
@patricksilva (packland) wrote :

I can confirm this bug too.

Using an Asus EEE PC 900.

Revision history for this message
catcharat (catcharat) wrote :

Me too on an EEE 901.... didn't have this problem with the 9.04 iso build though, I've only been stuck trying to build a 9.10

Revision history for this message
@patricksilva (packland) wrote :

Its just happens with the UNR version. I installed the desktop version right now, without problems.

Revision history for this message
SeiaCair (sasha-adaki) wrote :

The same problem with EEE 900 from USB with UNR

Revision history for this message
Titan3025 (titan3025) wrote :

I can confirm too on an Eee Box B202. Any solution yet?

The UNR 9.10 Release does not install from an usb key here.

Revision history for this message
Darryl H (fidelite) wrote :

I can also confirm that this affects me on an Acer Aspire One A0A 150, however, I think this has to do with the way in which it was installed to the USB disk, rather than the hardware it's going to.

Troubleshooting:
First I tried using both unetbootin-windows-377.exe and usb-creator.exe that comes with the UNR 9.10 from windows 7 with the same results. This was either a hang with a black screen, or I would get dumped to busybox with "can not mount /dev/loop1 on /cow"

Further Diagnosis:
I formatted a USB disk in Windows 7 using quick format (Fat16) and copied the ISO to to the USB drive to try to run the linux utility in to install the UNR, however, upon inserting the USB disk into the other machine (Dell D620) it displayed all kinds of different partitions (Novell being one of them) and not being able to mount the volume. Formatting the volume on Linux and presenting it back to both Windows XP and Windows 7 resulted in files that had illegal file names, and sizes that were larger than the capacity of the USB drive could hold, as well as file dates from 1980, 1999, and 2064 (If only it could have also provided me with next week's lottery numbers...)

Solution:
I then formatted a second USB key in windows 7 not specifying the quick format, then moved to a Windows XP box and used unetbootin-windows-377.exe to extract the ISO to the USB drive and the installation went off without a hitch.

I'm not sure if it's the non-quick format, or, the moving to Windows XP to copy the ISO to the USB key, but one (or both in tandem) resolved the issue for me.

Cheers!

Revision history for this message
Titan3025 (titan3025) wrote :

Found a solution which worked for me. If you use usb creator from ubuntu you need to choose the option "Discarded on shutdown, unless you save them elsewhere" at the bottom of the window. Then the usb key is created correctly and the installation works.

Revision history for this message
Darryl H (fidelite) wrote :

The above solution (Discarded on shutdown, unless you save them elsewhere) was noted in the New York Ubuntu threads located here: http://newyork.ubuntuforums.org/showthread.php?p=8213174

This solution did not work for me.

Revision history for this message
catcharat (catcharat) wrote :

Worked a treat for me, thanks @Titan3025

Revision history for this message
daxm (daxm) wrote :

Selecting the "Discarded on shutdown, unless you save them elsewhere" option got me past this issue as well. I'm installing on a Lenovo S10e.

Revision history for this message
another_sam (anothersam) wrote :

On Windows XP/7, quick/non-quick format, it failed. Until selecting "Discarded on shutdown, unless you save them elsewhere". <--- That was what solved the problem for my case.

Revision history for this message
another_sam (anothersam) wrote :

I missed: Eee PC 901

Revision history for this message
danielillu (danielillu) wrote :

My alchemy receipt for creating the USB drive bootable Ubuntu UNR 9.10 was:
- Windows XP SP2 (also worked on Win 7-x64)
- Slow format (slow cooked filesystems tastes better)
- "Discarded on shutdown, unless you save them elsewhere"

Using a Asus Eee PC 901.

It's a useful application but it's still full of bugs, but it does it job when you find the correct receipt.

Revision history for this message
Rudolf Reuter (reuterr) wrote :

The solution from "titan3025" did work for me on an ASUS EeePC 900A:
If you use usb creator from ubuntu you need to choose the option "Discarded on shutdown, unless you save them elsewhere" at the bottom of the window. Then the usb key is created correctly and the installation works.

That works, thank you

Revision history for this message
JimH (jhamilton11235) wrote :

None of the following worked for me of WinXp pro:
   -Fast or slow reformatting
   -Unetbootin or the built-in app

What did work:
   1) repartition the usb drive on Linux w/ fdisk. I was surprised to see 4 partitions there
   2) build filesystem with linux mkfs.vfat -F 32
   3) use unetbootin back on WinXp box. Haven't tried it with the built-in app

Revision history for this message
mcmosi (mcmosi) wrote :

The solution from "titan3025" did work for me on an ASUS EeePC 901
Sorry @ another_sam

But I can't shutdown my Eee, because otherwise all my changes/files/configurations are gone.
Is there an easy way to do this by hand and not by checking the option at the usb-creater respectively? (I'm new to linux-systems)

Revision history for this message
MillenniumBug (millenniumbug) wrote :

Closing this bug report, since it concerns 9.10 and UNR, both obsolete.

If a similar problem occurs in 11.04, feel free to open a new bug report or comment on an existing one.
https://bugs.launchpad.net/ubuntu/+source/usb-creator

Changed in busybox (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers