/etc/default/console-setup ignored on boot

Bug #392218 reported by José Alburquerque on 2009-06-25
72
This bug affects 10 people
Affects Status Importance Assigned to Milestone
busybox (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: console-setup

Hi. This is probably not necessarily a console-setup problem but I really did not know where else to report it. I hope it can be forwarded if necessary. The problem is that after reconfiguring with 'dpkg-reconfigure', running through the options and selecting 'TerminusBoldVGA' for the console font, after a reboot, the font in the console is the standard font and not 'TerminusBoldVGA'.

This could be related to a problem with a recent kernel upgrade because my scsi controller card (an LSI Logic / Symbios Logic 53c875), which normally worked out of the box was no longer recognized in the initrd process of the boot up. I had to add the card's module to the /etc/initramfs-tools/modules and run 'update-initramfs -u' for the booting to work correctly.

I'm pretty new at bug reporting because I just switched from debian. Should I report a bug elsewhere? Thanks.

ProblemType: Bug
Architecture: amd64
Date: Thu Jun 25 13:31:17 2009
DistroRelease: Ubuntu 9.10
Package: console-setup 1.34ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SourcePackage: console-setup
Uname: Linux 2.6.30-10-generic x86_64

Related branches

Colin Watson (cjwatson) wrote :

I've seen this myself, and it's reproducible on live CDs, but I haven't figured out what's up yet. I expect it may be due to initramfs changes in Karmic.

In the meantime, you can run 'sudo setupcon' at a console after boot to fix it temporarily.

Changed in console-setup (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Triaged
Nicolò Chieffo (yelo3) wrote :

it's because init.d scripts are not called by default (see that rc2.d/ does not contain the necessary links).
This means that in the postinst and postrm script we should call update-rc.d

No, it isn't. The console font is supposed to be set in the initramfs at
the moment; trying to set it in rc2.d would be ineffective because you
can't do that stuff while usplash is running. Why it isn't working in
the initramfs right now when it previously did is an open question.

Nicolò Chieffo (yelo3) wrote :

Also the keyboard layout? if not I will unmark my bug as a duplicate of this.

Colin Watson (cjwatson) wrote :

Both. Please leave your bug as a duplicate.

I'm also seeing this; it's frustrating to have to type my lvm crypt passphrase in qwerty instead of dvorak... :)

Paul Hummer (rockstar) on 2009-07-17
summary: - Console font not accepted after boot up
+ /etc/default/console-setup ignored on boot
Matt Zimmerman (mdz) on 2009-07-18
tags: added: regression-potential
Colin Watson (cjwatson) wrote :

I finally had time to work out what's going on here. Turns out that gzip was missing from the initramfs, so we couldn't uncompress either the cached keymap or the font. I'll fix this now.

affects: console-setup (Ubuntu) → busybox (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package busybox - 1:1.13.3-1ubuntu5

---------------
busybox (1:1.13.3-1ubuntu5) karmic; urgency=low

  * [initramfs] Enable gunzip and gzip (LP: #392218). (gzip is overkill in
    most respects, but is needed to make the 'gzip' command visible for the
    benefit of kbd.)

 -- Colin Watson <email address hidden> Mon, 03 Aug 2009 10:54:02 +0100

Changed in busybox (Ubuntu):
status: Triaged → Fix Released

I still have problems which seem to be the same as described here with a fresh Karmic install, busybox 1:1.13.3-1ubuntu7.

I made a custom keyboard layout, saved as /usr/share/X11/xkb/symbols/de_us . Manually loading the layout in GNOME with
  setxkbmap -layout de_us
works fine.

The relevant part of my /etc/default/console-setup:
XKBMODEL="pc105"
XKBLAYOUT="de_us"
#XKBVARIANT=""
XKBOPTIONS=""

Following https://lists.ubuntu.com/archives/ubuntu-installer/2009-May/000365.html , I ran then
  sudo /etc/init.d/console-setup restart
Which returned OK.

However, after a reboot the layout is not loaded. I can manually do so in a TTY with
  sudo setupcon
or in GNOME using setxkbmap.

dirk (dirk-kuijsten) wrote :

I also have the same problem. Very irritating on my laptop. Completely up-to-date.

nithin shetty (shetty-nith) wrote :

hi,,

My /etc/default/console-setup file itself is not there.., so wenever i boot , there ll be a white screen. No gui nothing.
can anybody tel me how to generate this file??

I've been experiencing the same blank screen problem for weeks now and have not filed a bug because of lack of time. I'm not sure it's related to this bug though. I do think something with this package might be relevant. Maybe a separate bug should be filed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers