Sleep of Float broken! (Enable SLEEP_FANCY & FLOAT)

Bug #391299 reported by Jean-Louis Dupond
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
busybox (Ubuntu)
Fix Released
Critical
Colin Watson

Bug Description

Binary package hint: busybox

CONFIG_FEATURE_FANCY_SLEEP=y
CONFIG_FEATURE_FLOAT_SLEEP=y

Should be enabled in the busybox config, because else we don't have the possibility to sleep a floating number of seconds (like 0.1). This breaks the initramfs, and makes booting unpossible!!!!!

Patch: http://launchpadlibrarian.net/28257759/busybox_1%3A1.13.3-1ubuntu2_1%3A1.13.3-1ubuntu3.diff.gz

I already added it to my PPA:
https://launchpad.net/~dupondje/+archive/ppa

Related branches

tags: added: 0.1 invalid number sleep
Changed in busybox (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Thanks for spotting this. Either that, or the sleep 0.1 needs to be replaced with something else. I'll let Colin comment, and if he's fine with this approach, I'll sponsor this.

Changed in busybox (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Revision history for this message
Jean-Louis Dupond (dupondje) wrote :
Revision history for this message
Colin Watson (cjwatson) wrote :

I'm pretty sure we don't need fractional sleep in the udeb, so I'll omit that part of the patch.

Changed in busybox (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Revision history for this message
Colin Watson (cjwatson) wrote :

This is really odd, BTW, because I *did* test booting with my new initramfs-tools (which switched to using busybox sleep rather than klibc sleep). I guess I didn't hit the right case. :-/

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package busybox - 1:1.13.3-1ubuntu3

---------------
busybox (1:1.13.3-1ubuntu3) karmic; urgency=high

  * [deb, initramfs, static] Enable fractional sleep (thanks, Jean-Louis
    Dupond; LP: #391299).

 -- Colin Watson <email address hidden> Wed, 24 Jun 2009 09:02:31 +0100

Changed in busybox (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Alfred Chen (alfredchen) wrote :

Tips for who unable to boot the system to apply the package update.

Try add rootdelay=60 or bigger to kernel options in grub, this works for my x200.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches