Upgrade busybox

Bug #145484 reported by SurJector on 2007-09-27
6
Affects Status Importance Assigned to Milestone
busybox (Debian)
Fix Released
Unknown
busybox (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: busybox

Shouldn't busybox be updated, recompiled dynamically linked with much more applets ?

I've busybox 1.7.0 (svn current) with the following applets:
        [, [[, arp, arping, ash, awk, basename, bunzip2, bzcat,
        cat, chgrp, chmod, chown, chroot, chvt, clear, cmp, comm,
        cp, cpio, cut, date, dc, dd, deallocvt, df, diff, dirname,
        dmesg, dos2unix, dpkg, dpkg-deb, du, dumpkmap, echo, egrep,
        eject, env, expr, false, fbset, fdflush, fdformat, fdisk,
        fgrep, find, ftpget, ftpput, grep, gunzip, gzip, halt,
        head, hexdump, hostname, ifconfig, insmod, ip, kill, less,
        ln, loadfont, loadkmap, losetup, ls, lsmod, md5sum, microcom,
        mkdir, mkfifo, mknod, mkswap, mktemp, more, mount, mv,
        od, openvt, patch, pidof, ping, ping6, pivot_root, poweroff,
        printf, ps, pwd, readlink, reboot, reset, rm, rmdir, rmmod,
        route, sed, setkeycodes, sh, sha1sum, sleep, sort, stat,
        strings, stty, su, swapoff, swapon, sync, tail, tar, tee,
        telnet, test, touch, tr, traceroute, true, tty, umount,
        uname, uniq, unix2dos, vi, wc, wget, which, xargs, yes,
        zcat
(dynamically linked). Using this busybox, my initramfs is 650Kb smaller
than the default one and I can troubleshoot problems (which, unfortunately,
are rather frequent with my setup) because a lot more utilities are present.

Related branches

Colin Watson (cjwatson) wrote :

Certainly not for Gutsy. I'd prefer Debian to upgrade first.

Changed in busybox:
importance: Undecided → Wishlist
status: New → Confirmed

2007/9/28, Colin Watson <email address hidden>:
> Certainly not for Gutsy.

    Of course, I wanted to express my wish early enough for Hardy
  Heron.

> I'd prefer Debian to upgrade first.

    Since Debian is my other distrib, I'll try there as well.

        Loïc

Albert Damen (albrt) wrote :

Can you please confirm if you filed a bug at Debian for this, so we can add a tracker here? I think it may be http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=444825 Is that right?

SurJector (loic-grenie) wrote :

2007/10/7, albert <email address hidden>:
> Can you please confirm if you filed a bug at Debian for this, so we can
> add a tracker here? I think it may be http://bugs.debian.org/cgi-
> bin/bugreport.cgi?bug=444825 Is that right?

    Indeed. As far as I can tell, busybox should be upgraded in Debian
  at some point (especially since bug
402482
<http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402482>has
been corrected
  in svn).

        Loïc

Changed in busybox:
status: Unknown → New
Changed in busybox:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package busybox - 1:1.10.2-1ubuntu1

---------------
busybox (1:1.10.2-1ubuntu1) intrepid; urgency=low

  * Resynchronise with Debian (LP: #145484). Remaining changes (upstream
    code changes converted to quilt):
    - Enable chvt, getopt, killall, losetup, mktemp, NFS mount, ping, stat,
      and remote syslog for udeb targets.
    - Add busybox-initramfs.
    - mkswap-uuid.patch: Set UUIDs on swap areas.
    - sleep-fractional.patch: Add support for fractional times.
    - procps-kernel-threads.patch: Avoid killing kernel threads in init when
      killing all processes.
    - test-bin.patch: Move test and friends to /bin.
    - mount-helper-fixes.patch: Add proper support for mount -i (don't use
      external mount helper), and trivial support for umount -i although
      busybox umount doesn't support external helpers yet. Fix handling of
      mount -f and -n.
  * busybox-initramfs Breaks: initramfs-tools (<< 0.85eubuntu41) and
    klibc-utils (<< 1.5.9-1), since it now prefers external tools over
    built-in applets and some changes were needed to tolerate the use of
    klibc tools.

busybox (1:1.10.2-1) unstable; urgency=low

  * New upstream release.

busybox (1:1.9.2-3) unstable; urgency=low

  * Readd package version into greeting.
  * Ignore init action if device is not available. (closes: #473659)

busybox (1:1.9.2-2) unstable; urgency=low

  * Set correct source section.
  * Move busybox-static to extra.
  * Update Standards-Version to 3.7.3, no changes.
  * Add generic applet fallback. (closes: #472653)

busybox (1:1.9.2-1) unstable; urgency=low

  * New upstream release.
  * [deb] Reenable prefer applets.
  * [deb, static] Make the shell use applets first. (closes: #472389)

busybox (1:1.9.1-3) unstable; urgency=low

  * debian/config.udeb:
    - Reenable fancy prompt.
  * Readd copyright file.

busybox (1:1.9.1-2) experimental; urgency=low

  * Readd sections gc to dynamic built binaries.
  * debian/config.udeb:
    - Fix remaining problems.
    - Disable ifconfig.
  * util-linux/mount.c:
    - Support relatime. (closes: #460824)

busybox (1:1.9.1-1) experimental; urgency=low

  * New upstream release.
  * Drop unused busybox-floppy-udeb.

 -- Colin Watson <email address hidden> Wed, 11 Jun 2008 18:33:41 +0100

Changed in busybox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.