buildbot not start on ubuntu 16 lts

Bug #1617810 reported by Dushistov on 2016-08-28
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
buildbot (Debian)
Fix Released
Unknown
buildbot (Ubuntu)
Undecided
Unassigned

Bug Description

buildbot can not start, in stdout it print:

exceptions.AttributeError: Requirements are not satisfied for buildbot.buildslave:BuildSlave: (sqlalchemy-migrate 0.10.0 (/usr/lib/python2.7/dist-packages), Requirement.parse('sqlalchemy-migrate==0.7.2'))

The strange and bad thing that
systemctl start buildbot report all ok,
but actully starts nothing and nothing works.

William Grant (wgrant) on 2016-08-31
affects: lpbuildbot → buildbot (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in buildbot (Ubuntu):
status: New → Confirmed
Charles Lepple (clepple) wrote :

I did a quick check on Ubuntu 16.04, but I don't have that box in front of me at the moment. Pretty sure it was up-to-date, so using version 0.8.12-3.

Notes just added to Debian bug #867588:

"So far, I have not observed any failures after removing the offending
lines ("sqlalchemy >= 0.6, <= 0.7.10" and "sqlalchemy-migrate==0.7.2")
from
/usr/lib/python2.7/dist-packages/buildbot-0.8.12.egg-info/requires.txt

[Debian-specific version info]

This commit to upstream seems to indicate that the newer versions of
sqlalchemy and sqlalchemy-migrate included in Debian should be compatible
with each other:

https://github.com/buildbot/buildbot/commit/222361a0e061291c9ba7fd7e6a660c7356ecd218

"Accept sqlalchemy-migrate versions 0.8 and up as compatible with
sqlalchemy version 0.8 and up."

Changed in buildbot (Debian):
status: Unknown → New
Changed in buildbot (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package buildbot - 1.7.0-2

---------------
buildbot (1.7.0-2) unstable; urgency=medium

  * Avoid prompting the user for "unmodified" default files.
  * Fix typos in man pages and scripts.
  * Move from experimental to unstable.

 -- Robin Jarry <email address hidden> Wed, 09 Jan 2019 14:47:18 +0100

Changed in buildbot (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.