bugnumbers crashed with RuntimeError in get_current_task()

Bug #288075 reported by Dereck Wonnacott on 2008-10-23
6
Affects Status Importance Assigned to Milestone
python-launchpad-bugs
Undecided
Unassigned
bughelper (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: bughelper

logged on to my computer and this apport crash was waiting for me. I have no clue when the crash occurred but I was using bugnumbers heavily yesterday while writing a script for HugDay.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/bugnumbers
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: bughelper 0.2.16
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/bin/bugnumbers --status=confirmed -p scim --format=bugday --sort=-nr --file=Confirmed\ Bugs
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/bugnumbers', '--status=confirmed', '-p', 'scim', '--format=bugday', '--sort=-nr', '--file=Confirmed Bugs']
SourcePackage: bughelper
Title: bugnumbers crashed with RuntimeError in get_current_task()
Uname: Linux 2.6.27-7-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy leachers lpadmin netdev plugdev powerdev sambashare scanner video

Dereck Wonnacott (dereck) wrote :
Changed in bughelper:
importance: Undecided → Low
Markus Korn (thekorn) wrote :

Hi Dereck,
thanks for reporting this. This is 'just' one of the bad described error messages in python-launchpad-bugs.
As I cannot reproduce this bug here I guess this RuntimeError was raised because of a problem connecting to launchpad.

I will add a python-launchpad-bugs task to raise a better Exception in such cases.

Markus

Changed in bughelper:
status: New → Invalid
Brian Murray (brian-murray) wrote :

Fixed in bzr and the Jaunty version of python-launchpad-bugs.

Changed in python-launchpad-bugs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers