[SRU] Cherrypick bug-fixes and usability issues for budgie-desktop

Bug #1811620 reported by fossfreedom on 2019-01-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
budgie-desktop (Ubuntu)
Medium
fossfreedom
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

The budgie-desktop package is the heart of Ubuntu Budgie - the desktop-environment.

A number of issues have been raised since the 18.04 release. As part of ongoing 18.04 & 18.10 support the Ubuntu Budgie Team proposes to wrap up fixes as a SRU release for both 18.04 and 18.10. In this SRU we have wrapped up reported issues that have been classified as LOW by the UB dev team. In addition the scope of the change has been assessed to limit the potential of regression. This is to ensure this SRU requests is strictly limited in scope with the risk(s) being easily determinable.

Upstream Solus project is preparing for the budgie-desktop v10.5 release. This is an opportune time to look across the work developed since the August 2017 baseline that budgie-desktop 18.04 is primarily based on. Solus has been user testing budgie-desktop v10.5 since approx Oct last year - Debian and Ubuntu 19.04 have now received this v10.5 preview since the beginning of this year.

[Impact]

The following budgie-desktop issues have been resolved for 18.04:

     1. Ensure show-desktop applet toggles correctly after showing a tooltip
     2. Allow cancel from polkit windows
     3. Make notifications consistent size; stop overlarge notification
      windows
     4. Ensure notifications remain visible if mouse is hovering over theme
     5. Support user based themes in legacy ~/.themes folder
     6. Enable autohiding when using multiple budgie panels
     7. deduplicate All category Menu

Most of these issues have been wrapped up in the 18.10 release. The remaining issues from the above that apply to 18.10 are:

     6. Enable autohiding when using multiple budgie panels
     7. deduplicate All category Menu
In addition a 18.10 specific bug-fix has been applied as part of this SRU:
     8. Ensure Raven controls can be correctly hidden if configured on
      a relogon

[Test Case - 18.04]

1. Examine the Menu - All. Look for menu options that appear to be duplicated. Note these.
2. Add the show-desktop applet to the panel. Logout and login. Hover over the showdesktop applet until the tooltip shows. Now toggle the button. The desktop application windows do not toggle correctly on and off
3. Install from proposed the following packages: budgie-core budgie-desktop gir1.2-budgie-1.0 libbudgie-plugin0 libbudgietheme0 libraven0
4. logout and login. Repeat 1 & 2 and note that they have been resolved
5. Mouse-over over a notification when it occurs - note it will now no longer disappear until you no longer mouse over.

[Test Case - 18.10]

1. Examine the Menu - All. Look for menu options that appear to be duplicated. Note these.
2. From budgie-desktop-settings - configure Raven to hide a few options. Logout and login. Examine Raven - notice that the options chosen to hide have incorrectly reappeared.
3. Install from proposed the following packages: budgie-core budgie-desktop gir1.2-budgie-1.0 libbudgie-plugin0 libbudgietheme0 libraven0 libbudgie-private0
4. logout and login. Repeat 1 & 2 and note that they have been resolved

[Regression Potential]

 * The worst case scenario is that the cherry-pick fixes may introduce instability issues. Whilst the fixes themselves are - code-wise tiny - there is a small possibility that a follow-up resolution may be required. This however is thought highly unlikely since the commits have been cherry-picked to be self contained and are not dependent on other commits. Any issues are specific to Ubuntu Budgie or users how are using budgie-desktop and have no impact on the wider Ubuntu community.

[Other Info]

 None

fossfreedom (fossfreedom) wrote :
fossfreedom (fossfreedom) wrote :
tags: added: patch
Łukasz Zemczak (sil2100) wrote :

A well prepared SRU tracking bug, as always! I re-uploaded the cosmic version with a slightly modified version (-2ubuntu0.1 instead of -2.1, as the latter would more imply this is a 'Debian' upload). Hope you didn't mind!

Changed in budgie-desktop (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic

Hello fossfreedom, or anyone else affected,

Accepted budgie-desktop into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-desktop/10.4+git20180830.02.f2dbc215fdb-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in budgie-desktop (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello fossfreedom, or anyone else affected,

Accepted budgie-desktop into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-desktop/10.4+git20171031.10.g9f71bb8-1.2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

fossfreedom (fossfreedom) wrote :

10.4+git20171031.10.g9f71bb8-1.2ubuntu1.1 was tested successfully on a clean 18.04.1 ISO install. The test case was completed without any issues.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Jacob Vlijm (vlijm) wrote :

10.4+git20180830.02.f2dbc215fdb-2ubuntu0.1 was tested successfully on 18.10, from proposed. The test case was completed without any issues.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop - 10.4+git20180830.02.f2dbc215fdb-2ubuntu0.1

---------------
budgie-desktop (10.4+git20180830.02.f2dbc215fdb-2ubuntu0.1) cosmic; urgency=medium

  * cherrypick upstream commits (LP: #1811620)
    - fix_panel_autohide.patch
      Enable autohiding when using multiple budgie panels
    - deduplicate-menuall.patch
      deduplicate All category Menu
    - 0012-Force-raven-widget-show-hide-to-display-contents-cor.patch
      Ensure Raven controls can be correctly hidden if configured on
      a relogon

 -- David Mohammed <email address hidden> Sun, 13 Jan 2019 19:23:14 +0000

Changed in budgie-desktop (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for budgie-desktop has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop - 10.4+git20171031.10.g9f71bb8-1.2ubuntu1.1

---------------
budgie-desktop (10.4+git20171031.10.g9f71bb8-1.2ubuntu1.1) bionic; urgency=medium

  * cherrypick upstream commits (LP: #1811620)
    - 0003-Fix-show-desktop-applet-1609.patch:
      Ensure show-desktop applet toggles correctly after showing a tooltip
    - 0004-polkit-Ensure-the-cancellable-is-truly-unowned.patch:
      Allow cancel from polkit windows
    - 0005-Set-ellipsize-property-on-notifications.patch
      0006-Ensure-notification-title-is-properly-ellipsized.-Re.patch
      Make notifications consistent size; stop overlarge notification
      windows
    - 0007-Disable-notification-timeout-when-mouse-hovering.-Re.patch
      Ensure notifications remain visible if mouse is hovering over theme
    - 0008-Fix-reading-themes-from-users-.themes-folder.patch
      Support user based themes in legacy ~/.themes folder
    - fix_panel_autohide.patch
      Enable autohiding when using multiple budgie panels
    - deduplicate-menuall.patch
      deduplicate All category Menu

 -- David Mohammed <email address hidden> Sun, 13 Jan 2019 19:02:27 +0000

Changed in budgie-desktop (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in budgie-desktop (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers