Budgie Desktop session interferes with gnome session

Bug #1713071 reported by Corey Kearney on 2017-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
budgie-desktop (Ubuntu)
Undecided
fossfreedom
budgie-desktop-environment (Ubuntu)
Undecided
fossfreedom

Bug Description

On an uptodate install of Ubuntu 17.10
Budgies setttings overwrite settings for the GNOME session. For example xsettings overrides need to be different in Budgie, but Budgie uses the same key as GNOME causing a conflict.

Cinniamon has its own xsettings overides. Gnome classic is another gnome session that doesn't affect the regular GNOME session, and Ubunutu's upcoming release will have a GNOME session that does not interfere with the default gnome session.

Budgie should have its own xsettings and not trample other sessions.

fossfreedom (fossfreedom) wrote :

overrides exist for both budgie-desktop and budgie-desktop-environment.

We should really tag each override schema with ":budgie-desktop" so that the override does not impact on another desktop's override

no longer affects: ubuntubudgie
Changed in budgie-desktop (Ubuntu):
status: New → Confirmed
Changed in budgie-desktop-environment (Ubuntu):
status: New → Confirmed
Changed in budgie-desktop (Ubuntu):
assignee: nobody → fossfreedom (fossfreedom)
Changed in budgie-desktop-environment (Ubuntu):
assignee: nobody → fossfreedom (fossfreedom)
tags: added: artful
fossfreedom (fossfreedom) wrote :

enc is a debdiff to resolve this issue for the package budgie-desktop

Tested via build and install.

Test case.

Create brand new user.
change the desktop session to Gnome-Shell
login

open nautilus (files)

examine the desktop - the desktop should look and feel "Gnome Shell" i.e. nautilus should have its appmenu in the top-bar

fossfreedom (fossfreedom) wrote :

enc is a debdiff to resolve this issue for the package budgie-desktop-environment

Tested via build and install.

Test case.

Create brand new user.
change the desktop session to Gnome-Shell (Ubuntu)
login

examine the desktop - the desktop should look and feel "Gnome Shell" i.e. desktop wallpaper, fonts should be Ubuntu / ambiance

i.e. if that new user had first logged in via budgie-desktop, desktop wallpaper, fonts would be "xplo" and "pocillo"

tags: added: patch
Changed in budgie-desktop (Ubuntu):
status: Confirmed → In Progress
Changed in budgie-desktop-environment (Ubuntu):
status: Confirmed → In Progress
fossfreedom (fossfreedom) wrote :

going to test this more before submitting

fossfreedom (fossfreedom) wrote :

Extra testing for budgie-desktop-environment:

1. create new user
2. logon to Ubuntu GNOME session
3. check that the environment is set as per Ubuntu GNOME
4. logout and login to budgie-desktop
5. check that the environment is set as per Ubuntu Budgie

Note: as soon as the user changes a setting such as font/icons/theme in one session, this is automatically seen in the second session i.e. GNOME sessions such as Budgie and Ubuntu are not truly separated. This appears to be a GNOME feature.

Second note:

Rhythmbox, Plank & Tilix appears to ignore when a per desktop override is made. Thus these have to remain all sessions overrides. No idea if these observations are per app or a limitation of the glib patch we are holding in artful.

fossfreedom (fossfreedom) wrote :
Łukasz Zemczak (sil2100) wrote :

Ok, those uploads look good to me. Uploading in a moment, thanks!

Changed in budgie-desktop (Ubuntu):
status: In Progress → Fix Committed
Changed in budgie-desktop-environment (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop-environment - 0.8.3

---------------
budgie-desktop-environment (0.8.3) artful; urgency=medium

  * Bug-fix release
    - explicitly set budgie-desktop for overrides so that we
      don't trample over other desktops overrides
      (LP: #1713071)
    - Add distro specific override for budgie-menu that was previously
      (but incorrectly) in package budgie-desktop
    - Ensure plank only starts for Budgie, not for all desktop sessions
      (LP: #1713128)
    - Revert panel dynamic transparency by default since this cannot
      be overridden; transparency can be user-defined

 -- David Mohammed <email address hidden> Fri, 25 Aug 2017 16:18:02 +0100

Changed in budgie-desktop-environment (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop - 10.4-0ubuntu3

---------------
budgie-desktop (10.4-0ubuntu3) artful; urgency=medium

  * Bug-fix release
    - Do not override budgie menu settings. This should be distro
      specific
    - Add "Budgie" desktop override to ensure this package does
      not trample over other desktops using the xsettings key
      (LP: #1713071)

 -- David Mohammed <email address hidden> Fri, 25 Aug 2017 21:02:12 +0100

Changed in budgie-desktop (Ubuntu):
status: Fix Committed → Fix Released

That was cool

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers