[SRU] .desktop file strings shown untranslated in Budgie

Bug #1772238 reported by fuenf drei 69 on 2018-05-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
budgie-desktop-environment (Ubuntu)
Status tracked in Cosmic
Bionic
High
fossfreedom
Cosmic
High
fossfreedom

Bug Description

This SRU fixes Menu issues reported since 18.04, details below.

[Impact]

 * This high priority issue is highly visible to all Ubuntu Budgie users who are using their account with a non-english language.
   Menu options for Settings (gnome-control-center) are incorrectly displayed in english; Settings tab are also shown (mostly) in english.
 * Bundled with this high priority SRU are a number of low priority menu issues that have been reported since the start of 18.04 via
   launchpad, Ubuntu Budgie github tracker or Ubuntu Budgie discourse support site

   1. If someone has gufw installed there is no associated menu option available to open the GUI.
   2. Users that need to use complex keyboard control require ibus which is installed by default in Ubuntu Budgie. The associated
      menu option to configure Ibus is missing. (LP: #1755831)
   3. For some users with non-english setups show two menu options for Files (nautilus).
   4. Linked to this are for these users, when Files (nautilus) is launched from Plank, two icons are displayed in plank - it should just
      be the launch icon with a "." highlight.
   5. GNOME Disks did not always display a menu option with its translated
      name or comment

 * Ubuntu Budgie includes menu overrides for .desktop files in /usr/share/budgie-desktop/applications. Almost all GNOME Settings .desktop
   files by default do not show in the Budgie menu due to one or more categories in the .desktop file + the "NoDisplay=true" designation in the GNOME based .desktop file.
 * Similarly, GUFW has the same issue as described above.
 * Nautilus.desktop by default does not show for GNOME - but should be for Budgie. The GNOME 3.28 .desktop file has Icon= statements for each supported locate that needs to be merged into the Ubuntu Budgie override. The Plank configuration for new users is docked with the deprecated nautilus.desktop - it should be launching the standard GNOME org... based .desktop file.

[Test Case]

 * Use the user account with a non english language e.g. German.
 * Examine the Menu options - choose "Settings" - this will open GNOME Settings (gnome-control-center).
 * Settings tabs should be all translated into your native language (assuming that a translation exists)
 * All Settings tabs should have a Menu option - this should also be displayed with the translated string. Hover over the menu option
   and a popup comment should be displayed similarly in your language (assuming that a translation exists).
 * If gufw is installed a menu option "Firewall Configuration" should be available. When clicked, a popup asking for your password is shown; enter your password and the GUFW configuation window is displayed
 * IBus Preferences should be a menu option that is now available to be chosen; this will open a window "IBus Preferences"
 * GNOME Disks should have a menu option displayed with a name and comment (if available) in your native language.

[Regression Potential]

 * Since these are .desktop overrides, the risk is limited to either menu options continuing to be not available as before
   or not displaying translated strings.

[Other Info]

 * Testing for this SRU has confirmed each of the low priority issues in the test case show the result described.
 * For the high priority issue - see that attachment that shows that the Settings (gnome-control-center) displays all in German i.e. compare with the OP attachment.

[Original Description]

mix of german/english words in ubuntubudgie 18.04

Paul White (paulw2u) on 2018-05-20
tags: added: bionic
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report. I'm wondering if you have the latest package versions. Can you please run this command:

dpkg-query -W gnome-control-center language-pack-gnome-de

and let us know what it outputs.

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
fuenf drei 69 (fuenfdrei69) wrote :

gnome-control-center 1:3.28.1-0ubuntu1
language-pack-gnome-de 1:18.04+20180423

Changed in gnome-control-center (Ubuntu):
assignee: nobody → fuenf drei 69 (fuenfdrei69)
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks; apparently your packages are updated.

I can't reproduce the issue on Ubuntu 18.04. Can it be that Budgie doesn't understand the line "X-Ubuntu-Gettext-Domain=gnome-control-center-2.0" in the .desktop files?

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Gunnar Hjalmarsson (gunnarhj) wrote :

Can confirm the issue on Ubuntu Budgie 18.04. It looks like strings in .desktop files generally show up untranslated (not only for German).

To test my theory about "X-Ubuntu-Gettext-Domain" I edited

/usr/share/applications/gnome-region-panel.desktop

and added this line:

Name[de]=Region und Sprache

That didn't help - still "Region & Language" - so the issue seems to be caused by something else.

Changed in ubuntubudgie:
status: New → Confirmed
importance: Undecided → High
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
assignee: fuenf drei 69 (fuenfdrei69) → nobody
summary: - mix of german/english words
+ .desktop file strings shown untranslated
summary: - .desktop file strings shown untranslated
+ .desktop file strings shown untranslated in Budgie

Attaching the env output.

When browsing the Budgie menus, the "Comment" strings from the .desktop files show up translated also for items whose "Name" strings are untranslated. Is it a matter of timing, i.e. are the menu items loaded with the C locale or something?

Also, we are talking about strings which are translated. Examples:

$ echo $(gettext -d gnome-control-center-2.0 Background)
Hintergrund
$ echo $(gettext -d gnome-control-center-2.0 'Region & Language')
Region und Sprache

fossfreedom (fossfreedom) wrote :

Just got pinged about this.

I strongly suspect this is because in UB the gnome-control-center .desktop files are overridden in /usr/share/budgie-desktop/applications. This is because the one or more of the categories prevent the .desktop files from appearing in the menu. UB holds an override with a modified category list.

From a quick look it looks like the Name= field value has changed more most of the gnome-control-center .desktop files between GNOME 3.26 in 17.10 and GNOME 3.28. UB at the very minimum needs to fix this via a budgie-desktop-environment package change.

Will confirm that asap - hopefully cross-fingers - this will also fix this reported issue with gnome-control-center. If it does I'll remove the other affected packages.

no longer affects: ubuntubudgie
Changed in budgie-desktop-environment (Ubuntu):
importance: Undecided → High
assignee: nobody → fossfreedom (fossfreedom)
fossfreedom (fossfreedom) wrote :

Confirmed - removing the other affect packages. Will fix via SRU

no longer affects: gnome-control-center (Ubuntu)
no longer affects: ubuntu-translations
Changed in budgie-desktop-environment (Ubuntu Bionic):
importance: Undecided → High
assignee: nobody → fossfreedom (fossfreedom)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop-environment - 0.10.0

---------------
budgie-desktop-environment (0.10.0) cosmic; urgency=medium

  * New release
    - Display ibus-setup in the menu to enable configuration
      on ibus (LP: #1755831)
    - Merge GNOME 3.28 Settings .desktop files to ensure menus and
      Settings display translations correctly (LP: #1772238)
    - Use the correct GNOME Nautilus .desktop file for plank; this
     stops duplicate icons when Files (Nautilus) is run
    - Add budgie override for gufw.desktop to enable displaying
      of the gufw menu firewall option
    - Remove file-roller.desktop override since the application
      now provides a .desktop that can be displayed in the menu
    - Merge mpv.desktop and nautilus.desktop overrides with the
      18.04 applications version to ensure translations are displayed

 -- David Mohammed <email address hidden> Wed, 23 May 2018 20:47:18 +0100

Changed in budgie-desktop-environment (Ubuntu Cosmic):
status: New → Fix Released
fossfreedom (fossfreedom) wrote :
description: updated
description: updated
fossfreedom (fossfreedom) wrote :
description: updated
summary: - .desktop file strings shown untranslated in Budgie
+ [SRU] .desktop file strings shown untranslated in Budgie

Hello fuenf, or anyone else affected,

Accepted budgie-desktop-environment into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-desktop-environment/0.9.9ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in budgie-desktop-environment (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jacob Vlijm (vlijm) wrote :

Tested budgie-desktop-environment 0.9.9. I confirm this fixes it for me.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: removed: verification-needed
Jacob Vlijm (vlijm) on 2018-06-11
tags: added: verification-done
removed: verification-done-bionic
Jacob Vlijm (vlijm) wrote :

For clarity reasons: I tested budgie-desktop-environment 0.9.9. on Bionic. Confirming this fixes it for me.

tags: added: verification-done-bionic
Jacob Vlijm (vlijm) wrote :

For clarity reasons: I tested budgie-desktop-environment 0.9.9ubuntu1. Confirming it fixes it for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop-environment - 0.9.9ubuntu1

---------------
budgie-desktop-environment (0.9.9ubuntu1) bionic; urgency=medium

  * Bug-fix release
    - Merge GNOME 3.28 Settings .desktop files to ensure menus and
      Settings display translations correctly (LP: #1772238)
    - Display ibus-setup in the menu to enable configuration
      on ibus (LP: #1755831)
    - Use the correct GNOME Nautilus .desktop file for plank; this
     stops duplicate icons when Files (Nautilus) is run
    - Add budgie override for gufw.desktop to enable displaying
      of the gufw menu firewall option
    - Remove file-roller.desktop override since the application
      now provides a .desktop that can be displayed in the menu
    - Merge nautilus.desktop overrides with the
      18.04 application version to ensure menu options are not
      duplicated
    - Merge GNOME Disks .desktop override to ensure all translations are
      displayed

 -- David Mohammed <email address hidden> Thu, 24 May 2018 19:24:19 +0100

Changed in budgie-desktop-environment (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for budgie-desktop-environment has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers