ibus not working properly

Bug #1755831 reported by Toan Nguyen on 2018-03-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
budgie-desktop-environment (Ubuntu)
Status tracked in Cosmic
Bionic
Wishlist
fossfreedom
Cosmic
Wishlist
fossfreedom

Bug Description

The complete SRU for this fix is https://bugs.launchpad.net/ubuntu/+source/budgie-desktop-environment/+bug/1772238

Relevant part of the SRU that applies to this issue is below:

[Impact]

 * See the high-priority issue for the complete SRU:
   https://bugs.launchpad.net/ubuntu/+source/budgie-desktop-environment/+bug/1772238

 * Users that need to use complex keyboard control require ibus which is installed by default in Ubuntu Budgie. The associated
      menu option to configure Ibus is missing. (LP: #1755831)

[Test Case]

 * IBus Preferences should be a menu option that is now available to be chosen; this will open a window "IBus Preferences"

[Regression Potential]

 * Since this is a .desktop override, and that the menu option is not
   currently visible, there is no risk; this fix enables something
   that was always available via the command line.

[Other Info]

N/A

[Original Description]

Ubuntu Budgie 18.04 beta 1

After adding vietnamese unikey input method, the input method icon is nowhere to be seen. I know there's an keyboard layout indicator applet but it can't help me to configure my input method. And the option 'Allow different sources for each windows' has no effect whatsover.

fossfreedom (fossfreedom) wrote :

Please can you talk me through how you installed your input method - I have never done this (I'm an english user) so cannot reproduce your issue.

What "input method icon" are you expecting to see?

What options do you see in in the drop-down when you click the keyboard layout indicator?

Changed in ubuntubudgie:
status: New → Incomplete
Toan Nguyen (dtoan96) wrote :

My input method (ibus-unikey) was automatically installed when I checked Vietnamese in "Language Support".
There should be an icon like this in system tray: http://2.bp.blogspot.com/-n_blnCYePd4/VzNzI3OdpCI/AAAAAAAAA1A/Tw7mC70z2BcQyD9SGSrLr5noIyZLc6oNACK4B/s1600/Screenshot%2Bfrom%2B2016-05-12%2B00-59-37.png
But I cannot find it in my case and this is what show in the drop-down (it seems I can't take screenshot when point to the keyboard layout indicator, so I used my phone to take this picture): https://i.imgur.com/dPM35rT.jpg
That's why I can't configure my input method.

fossfreedom (fossfreedom) wrote :

What are those options?

That looks like unity.

In GNOME keyboard stuff is via Settings - keyboard

Toan Nguyen (dtoan96) wrote :

That picture is indeed unity, but I have used Ubuntu Gnome, Ubuntu 17.10 and Fedora, they all support this feature.
By the way, there're many stuffs in that option, the main thing is key combination, there are two types:
_ 1 character + 1 number
    Ex: 'a' + '1' -> 'á'
        'e' + '6' -> 'ê'
_ 2 character
    Ex: 'a' + 's' -> 'á'
        'e' + 'e' -> 'ê'
Some people are used to the first and some are used to the second way.

Talking about Settings - keyboard, all I can see are shortcuts, after choosing "Reset All", I now cannot use Print to screenshot anymore, and I can't even disable default shorcuts by setting them to <space>.

Changed in ubuntubudgie:
status: Incomplete → Confirmed
importance: Undecided → Wishlist
fossfreedom (fossfreedom) wrote :

ok - now understand - thanks for that. For native english speakers most like myself are not familiar with this capability so cheers for explaining it.

This will need to be raised as an enhancement request upstream https://github.com/budgie-desktop/budgie-desktop - please explain fully (like above) with examples of how to reproduce, Desktop Environments tried, what they do. This is because the key developers of budgie desktop are similarly not familiar in this area.

For the shortcuts you need to recreate the shortcuts again because you also changed the custom keyboard shortcuts after hitting that "reset" button. So please delete all the custom shortcuts at the bottom of the keyboard screen. Then delete the file "keycontrol" in ~/.config/budgie-desktop/

Logout and login again.

Zheng Liu (mizuseki) wrote :

I found the same issue in Ubuntu Budgie 18.04 (official release). Below is what I did:

- Language Support > Added Chinese Simplified, Chinese Traditional, and Japanese.
- Input Method > set to ibus (default)
- Package installed: ibus-pinyin, ibus-mozc
- Region & Language > added the above two input methods
- Rebooted the system but the language/input selector icon doesn't appear in the system tray when I try to switch the input method.
- Adding the "Keyboard Layout" and "Keyboard AutoSwitch" applets doesn't help either.

I recall that this was working properly in a previous version (17.04 or 17.10), so this would likely be a regression.
Also, not sure if I remember this correctly, but in the previous version it was working under the "fcitx" input method. The "fcitx" option is missing in 18.04 for some reason.

Hope this helps.

Zheng Liu (mizuseki) wrote :

Also, this is working fine in the main Ubuntu 18.04 release. So this should be a Budgie-only issue.

Gunnar Hjalmarsson (gunnarhj) wrote :

The integration between IBus and GNOME seems not to be complete on the Budgie desktop. This is a way which works:

* Don't add the input sources via Region & Language, and don't bother
  with adding the keyboard layout indicator.

Instead:

* Open IBus Preferences via the terminal command ibus-setup

* Check the "Show icon on system tray" option

* Switch to the "Input Method" tab and add the input sources you need
  from there

Then you can use the IBus icon in the top panel to switch between all input sources, both XKB keyboard layouts and IBus input methods. From there you also have access to configure respective IBus method.

HTH

Gunnar Hjalmarsson (gunnarhj) wrote :

Awaiting a possible improvement of the integration, I'd suggest that budgie-desktop-environment installs the file:

/usr/share/budgie-desktop/applications/ibus-setup.desktop

with the same contents as

/usr/share/applications/ibus-setup.desktop

except that the line

NotShowIn=GNOME;Unity;

is replaced with

OnlyShowIn=Budgie;

That way IBus Preferences would show up in the menu.

Changed in budgie-desktop-environment (Ubuntu):
importance: Undecided → Wishlist
no longer affects: ubuntubudgie
Changed in budgie-desktop-environment (Ubuntu):
assignee: nobody → fossfreedom (fossfreedom)
status: New → In Progress
Changed in budgie-desktop-environment (Ubuntu Bionic):
importance: Undecided → Wishlist
assignee: nobody → fossfreedom (fossfreedom)
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop-environment - 0.10.0

---------------
budgie-desktop-environment (0.10.0) cosmic; urgency=medium

  * New release
    - Display ibus-setup in the menu to enable configuration
      on ibus (LP: #1755831)
    - Merge GNOME 3.28 Settings .desktop files to ensure menus and
      Settings display translations correctly (LP: #1772238)
    - Use the correct GNOME Nautilus .desktop file for plank; this
     stops duplicate icons when Files (Nautilus) is run
    - Add budgie override for gufw.desktop to enable displaying
      of the gufw menu firewall option
    - Remove file-roller.desktop override since the application
      now provides a .desktop that can be displayed in the menu
    - Merge mpv.desktop and nautilus.desktop overrides with the
      18.04 applications version to ensure translations are displayed

 -- David Mohammed <email address hidden> Wed, 23 May 2018 20:47:18 +0100

Changed in budgie-desktop-environment (Ubuntu Cosmic):
status: In Progress → Fix Released
description: updated
description: updated
description: updated

Hello Toan, or anyone else affected,

Accepted budgie-desktop-environment into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-desktop-environment/0.9.9ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in budgie-desktop-environment (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Zheng Liu (mizuseki) wrote :

I have tested and confirmed that the package budgie-desktop-environment_0.9.9ubuntu1 has solved this issue. The "IBus Preferences" option now shows under the menu, and I can add the input method icon by checking the "Show icon on system tray" option. Once the icon shows up, I can now add new input methods through "IBus Preferences" and have them show in the list of available input methods. Typing in additional input methods is working properly too.

Changing the tag to verification-done-bionic.

tags: added: verification-done-bionic
removed: 18.04-beta ibus verification-needed verification-needed-bionic
tags: added: 18.04-beta ibus
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-desktop-environment - 0.9.9ubuntu1

---------------
budgie-desktop-environment (0.9.9ubuntu1) bionic; urgency=medium

  * Bug-fix release
    - Merge GNOME 3.28 Settings .desktop files to ensure menus and
      Settings display translations correctly (LP: #1772238)
    - Display ibus-setup in the menu to enable configuration
      on ibus (LP: #1755831)
    - Use the correct GNOME Nautilus .desktop file for plank; this
     stops duplicate icons when Files (Nautilus) is run
    - Add budgie override for gufw.desktop to enable displaying
      of the gufw menu firewall option
    - Remove file-roller.desktop override since the application
      now provides a .desktop that can be displayed in the menu
    - Merge nautilus.desktop overrides with the
      18.04 application version to ensure menu options are not
      duplicated
    - Merge GNOME Disks .desktop override to ensure all translations are
      displayed

 -- David Mohammed <email address hidden> Thu, 24 May 2018 19:24:19 +0100

Changed in budgie-desktop-environment (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for budgie-desktop-environment has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers