Screen sharing switch does not work in Budgie 22.04

Bug #1973117 reported by Chandra
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
budgie-control-center (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Medium
fossfreedom

Bug Description

[Impact]

 * Remote Desktop Sharing is a capability that Budgie supports through its GNOME Control Center equivalent called
   Budgie Control Center
 * Through our community forum it has been reported that Remote Desktop Sharing is not working
 * The issue has been tracked back to Ubuntu itself sync'ing gnome-remote-desktop & gnome-settings-daemon very late into the cycle
   which broke how VNC sharing was enabled - it is now enabled via systemd - previously it was enabled via gnome-settings-daemon
   which budgie-control-center used to enable.
 * To support remote desktop sharing we have imported the systemd code from gnome-control-center into our fork and rewritten
   how the enabling occurs. We have done this to ensure the existing interface is not changed rather than trying to
   import the wholescale RDP & VNC graphical changes gnome-control-center made just before the 22.04 release date.

[Test Plan]

 * Without the package update the follow issue occurs:
   1. Open budgie-control-center - choose the Sharing side tab
   2. Slide the switch toggle on the headerbar to enable the other sharing options below
   3. click on the Screensharing -> arrow
   4. This will open a dialog
   5. Attempt to click the switch toggle on the new dialog to enable sharing. This will be disabled which means sharing is disabled
   6. Close budgie-control-center and restart budgie-control-center again
   7. Note that screensharing will have a "no" next to the arrow. The screen sharing toggle will be disabled and does not respond to a click i.e. does not turn on.
   8. Confirm this by trying to remmina (or using your favourite VNC client) to the desktop VNC Name / IP Address. Remmina will not be able to connect to the test machine's screen sharing IP address/VNC name.

 * Enable the proposed repo and then install the updates - the following packages
   needs to be installed

   sudo apt install budgie-control-center budgie-control-center-data

 * Test screensharing:
 1. Open budgie-control-center - choose the Sharing side tab
 2. Slide the switch toggle on the headerbar to enable the other sharing options below
 3. click on the Screensharing -> arrow
 4. This will open a dialog
 5. Click the switch toggle on the new dialog to enable sharing.
 6. Close budgie-control-center and restart budgie-control-center again
 7. Note "Yes" will be shown next the the screensharing -> arrow. Screen sharing toggle will be enabled and turns "on" when clicked.
 8. Confirm sharing is enabled by trying to remmina (or using your favourite VNC client) to the desktop VNC Name / IP Address. i.e.Remmina from another machine connects to screen sharing via VNC successfully. Note Screen-sharing is VNC only - RDP is not supported.
 9. Confirm the other options shown in the dialog work as expected i.e. disconnect first from remmina, change the option and connect.

 * Regression testing
   The testing to ensure no regressions occur in this area.
   1. Connect to the screensharing host with the other sharing options

Expected results include:

New connections must ask for access. When toggled on, request pops up on sharing machine. Sharing works on accepting.

Require a password: When toggled on, password input on sharing machine needs entered on connecting machine to start sharing.

Show password: Toggles display of password input.

Note - networks selection is not an expected option.

File Sharing: Public folder on sharing machine accessible from connecting machine when switch is toggled on.

Require password: Should prompt for a password.

Media Sharing: Expect that the toggle works.

[Where problems could occur]

 * The changes are specifically around sharing handling
   Since this is in a budgie specific package (budgie-control-center)
   this will not impact any other desktop.
 * The changes are in the same code section of budgie-control-center for all other sharing options
 * Thus from a regression view point handling of any sharing capability may be impacted.
 * From a mitigation point of view - in the unlikely event of an issue occuring, Ubuntu Budgie
   also ships with gnome-control-center which can be used to handle sharing.
   Note GCC prior to 22.04 has always been used to sharing.
 * The team has also produced a test PPA package and independently a UB team member and the originator of this issue has confirmed no additional issues https://launchpad.net/~ubuntubudgie-dev/+archive/ubuntu/vnc

[Other Info]

 * N/A

----

The screen sharing switch does not work in Budgie control center and hence no screen sharing is possible. The toggle to switch on screen sharing is disabled.

Ubuntu 22.04 seems to have RDP as default sharing option. The share settings screen looks very different in some videos about standard Ubuntu 22.04, but Budgie’s seems the same as earlier Ubuntu versions.

This issue is confirmed by other users here:
https://discourse.ubuntubudgie.org/t/screen-sharing-in-budgie-outdated-and-not-functional/

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: budgie-control-center 1.0.1-2ubuntu1
ProcVersionSignature: Ubuntu 5.15.0-27.28-generic 5.15.30
Uname: Linux 5.15.0-27-generic x86_64
ApportVersion: 2.20.11-0ubuntu82
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: Budgie:GNOME
Date: Thu May 12 10:04:51 2022
InstallationDate: Installed on 2022-04-23 (18 days ago)
InstallationMedia: Ubuntu-Budgie 22.04 LTS "Jammy Jellyfish" - Release amd64 (20220419)
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: budgie-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Chandra (chandrafn) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in budgie-control-center (Ubuntu):
status: New → Confirmed
description: updated
Changed in budgie-control-center (Ubuntu Jammy):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → fossfreedom (fossfreedom)
Revision history for this message
Chandra (chandrafn) wrote (last edit ):

Tested from dev PPA and screen sharing changes seem to be working fine.

[Test Plan]

 * Without the package update the follow issue occurs:
   1. Open budgie-control-center - choose the Sharing side tab
   2. Slide the switch toggle on the headerbar to enable the other sharing options below
   3. click on the Screensharing -> arrow
   4. This will open a dialog
   5. Attempt to click the switch toggle on the new dialog to enable sharing. This will be disabled which means sharing is disabled
   6. Close budgie-control-center and restart budgie-control-center again
   7. Note that screensharing will have a "no" next to the arrow.

[Test Result]: screen sharing toggle is disabled and does not turn on.

   8. Confirm this by trying to remmina (or using your favourite VNC client) to the desktop VNC Name / IP Address

[Test Result]: Remmina cannot connect to the test machine's screen sharing.

 * Enable the proposed repo and then install the updates - the following packages
   needs to be installed

   sudo apt install budgie-control-center budgie-control-center-data

 * Test screensharing:
 1. Open budgie-control-center - choose the Sharing side tab
 2. Slide the switch toggle on the headerbar to enable the other sharing options below
 3. click on the Screensharing -> arrow
 4. This will open a dialog
 5. Click the switch toggle on the new dialog to enable sharing.
 6. Close budgie-control-center and restart budgie-control-center again
 7. Note "Yes" will be shown next the the screensharing -> arrow.

[Test Result]:
Screen sharing toggle is enabled and turns on when clicked.

 8. Confirm sharing is enabled by trying to remmina (or using your favourite VNC client) to the desktop VNC Name / IP Address
 9. Confirm the other options shown in the dialog work as expected i.e. disconnect first from remmina, change the option and connect.

[Test Result]:
Remmina from another machine connects to screen sharing via VNC successfully.
Remmina does not connect by RDP.

 * Regression testing
   The testing to ensure no regressions occur in this area.
   1. Connect to the screensharing host with the other sharing options

[Test Result]:

Allow connections to control the screen: Works. When toggled on, can control sharing machine via mouse and keyboard on connecting machine. Control not available when toggled off.

New connections must ask for access: Works. When toggled on, request pops up on sharing machine. Sharing works on accepting.

Require a password: Works. When toggled on, password input on sharing machine needs entered on connecting machine to start sharing.

Show password: Works. Toggles display of password input.

Networks: Not available. There was a networks selection option in earlier Ubuntu versions that does not show here.

File Sharing: Works. Public folder on sharing machine accessible from connecting machine when switch is toggled on.

Require password: Works.

Media Sharing: Toggle works.
Could not test actual sharing from other media devices.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-control-center - 1.0.2-1

---------------
budgie-control-center (1.0.2-1) unstable; urgency=medium

  * New upstream release
    - display sound icons when testing the sound output
    - small typo fix in oc language
    - version bump for gsettings schemas i.e. BCC is for GNOME 42 and later
    - Rework fractional scaling support for distros that include the mutter
      patch (LP: #1972007)
    - Support VNC Screen-sharing with GNOME 42 GNOME Remote Desktop
      (LP: #1973117)
  * Adapt GCC ubuntu specific language & region chooser to ensure
    language & locale selection is displayed and able to choose from
    (LP: #1970255)
    ubuntu/Adapts-the-region-capplet-and-the-language-chooser-in-the.patch
  * Packaging Changes
    - Drop existing patch since incorporated in the microrelease
    - d/rules add clean and configure rules to apply ubuntu specific patch

 -- David Mohammed <email address hidden> Thu, 12 May 2022 14:31:10 +0100

Changed in budgie-control-center (Ubuntu):
status: Confirmed → Fix Released
description: updated
description: updated
Changed in budgie-control-center (Ubuntu Jammy):
status: Confirmed → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Chandra, or anyone else affected,

Accepted budgie-control-center into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-control-center/1.0.1-2ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-jammy to verification-done-jammy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-jammy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in budgie-control-center (Ubuntu Jammy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-jammy
Revision history for this message
Chandra (chandrafn) wrote :

Tested from Proposed PPA and screen sharing changes seem to be working fine.

Version tested:
budgie-control-center/jammy-proposed,now 1.0.1-2ubuntu2 amd64

---

[Test Plan]

 * Without the package update the follow issue occurs:
   1. Open budgie-control-center - choose the Sharing side tab
   2. Slide the switch toggle on the headerbar to enable the other sharing options below
   3. click on the Screensharing -> arrow
   4. This will open a dialog
   5. Attempt to click the switch toggle on the new dialog to enable sharing. This will be disabled which means sharing is disabled
   6. Close budgie-control-center and restart budgie-control-center again
   7. Note that screensharing will have a "no" next to the arrow.

[Test Result]: screen sharing toggle is disabled and does not turn on.

   8. Confirm this by trying to remmina (or using your favourite VNC client) to the desktop VNC Name / IP Address

[Test Result]: Remmina cannot connect to the test machine's screen sharing.

 * Enable the proposed repo and then install the updates - the following packages
   needs to be installed

   sudo apt install budgie-control-center budgie-control-center-data

 * Test screensharing:
 1. Open budgie-control-center - choose the Sharing side tab
 2. Slide the switch toggle on the headerbar to enable the other sharing options below
 3. click on the Screensharing -> arrow
 4. This will open a dialog
 5. Click the switch toggle on the new dialog to enable sharing.
 6. Close budgie-control-center and restart budgie-control-center again
 7. Note "Yes" will be shown next the the screensharing -> arrow.

[Test Result]:
Screen sharing toggle is enabled and turns on when clicked.

 8. Confirm sharing is enabled by trying to remmina (or using your favourite VNC client) to the desktop VNC Name / IP Address
 9. Confirm the other options shown in the dialog work as expected i.e. disconnect first from remmina, change the option and connect.

[Test Result]:
Remmina from another machine connects to screen sharing via VNC successfully.
Remmina does not connect by RDP.

 * Regression testing
   The testing to ensure no regressions occur in this area.
   1. Connect to the screensharing host with the other sharing options

[Test Result]:

Allow connections to control the screen: Works. When toggled on, can control sharing machine via mouse and keyboard on connecting machine. Control not available when toggled off.

New connections must ask for access: Works. When toggled on, request pops up on sharing machine. Sharing works on accepting.

Require a password: Works. When toggled on, password input on sharing machine needs entered on connecting machine to start sharing.

Show password: Works. Toggles display of password input.

Networks: Not available. There was a networks selection option in earlier Ubuntu versions that does not show here.

File Sharing: Works. Public folder on sharing machine accessible from connecting machine when switch is toggled on.

Require password: Works.

Media Sharing: Toggle works.
Could not test actual sharing from other media devices.

Chandra (chandrafn)
tags: added: verification-done-jammy
removed: verification-needed-jammy
tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-control-center - 1.0.1-2ubuntu2

---------------
budgie-control-center (1.0.1-2ubuntu2) jammy; urgency=medium

  * Bug-fix
    - Ensure lock-screen does not break budgie-desktop fractional scaling
      support (LP: #1972007)
      Rework-fractional-scaling-to-disable-the-lock-screen.patch
    - Ensure screen-sharing starts VNC through enabling systemd
      (LP: #1973117)
      remote-desktop-service-enable.patch
    - Update previous changelog with the actual patch file name

 -- David Mohammed <email address hidden> Fri, 13 May 2022 10:51:18 +0100

Changed in budgie-control-center (Ubuntu Jammy):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for budgie-control-center has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers