[SRU] Resolve Pocillo theming issues for Ubuntu Budgie

Bug #1811522 reported by fossfreedom on 2019-01-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
budgie-artwork (Ubuntu)
Medium
fossfreedom
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

The budgie-artwork package is an umbrella package for the look-and-feel for Ubuntu Budgie. Included with this source package is a binary package called ubuntu-budgie-themes which has the precompiled GTK+ theme for Ubuntu Budgie called Pocillo.

A number of issues have been raised since the 18.04 release. As part of ongoing 18.04 & 18.10 support the Ubuntu Budgie Team proposes to wrap up fixes as a SRU release for both 18.04 and 18.10. In this SRU we have wrapped up reported issues that have been classified as LOW by the UB dev team. In addition the scope of the change has been assessed to limit the potential of regression. This is to ensure this SRU requests is strictly limited in scope with the risk(s) being easily determinable.

Pocillo consists of 6 variants and whilst the theme changes themselves are small, the nature of GTK+ theming means the diff are basically repeated 6x.

All the issues noted below have already been fixed and uploaded to 19.04. The compiled CSS elements of the 18.04 & 18.10 theme have been generated once (https://github.com/UbuntuBudgie/pocillo-gtk-theme/tree/bionic) and copied to the budgie-artwork packages for 18.04/18.10.

[Impact]

The following Pocillo issues have been resolved for 18.04:

    Raven Styling
    Vertical dock highlighting
    GtkColorChooser border truncation
    GEdit search styling
    Eog zoom truncation
    Ensure Titlebar button are always circular
    Nemo not themed

Most of these issues have been wrapped up in the 18.10 release. The remaining issues from the above that apply to 18.10 are:

    Raven Styling
    GtkColorChooser border truncation
    Nemo not themed

[Test Case - 18.04]

1. Open GEdit and examine the search (CTRL+F) - note the styling of the search box and the buttons are truncated.
2. Using Budgie-Settings add a left dock + icon-tasklist. Open a few applications. Note it is not possible to see which are unopened applications compared to opened applications since there is no highlight mark to show opened windows.
3. Repeat 1 & 2 for each of the remaining Pocillo variants.
4. Install the package ubuntu-budgie-themes from Proposed, logout and login
5. Repeat 1 - 3 and note that the issues have been resolved

[Test Case - 18.10]

1. Open Raven and examine the Apps/Devices buttons - note in Pocillo those buttons are invisible. You can see them appear if you switch to the inbuilt theme using budgie-desktop-settings.
2. Install the package ubuntu-budgie-themes from Proposed, logout and login
3. Repeat 1 for each of the Pocillo variants. The apps/devices buttons are visible and styled.

[Regression Potential]

 * The worst case scenario is that the GTK+ theme changes affect other aspects of the Pocillo theme. This is thought very unlikely due to the CSS changes are mostly named classes that are unique to each of the areas of Budgie and are not repeated elsewhere.

[Other Info]

 None

description: updated
tags: added: patch

Hello fossfreedom, or anyone else affected,

Accepted budgie-artwork into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-artwork/0.9.7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in budgie-artwork (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello fossfreedom, or anyone else affected,

Accepted budgie-artwork into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/budgie-artwork/0.9.6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in budgie-artwork (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
fossfreedom (fossfreedom) wrote :

v0.9.6.1 for bionic has been tested successfully on a clean 18.04.1 ISO install. Test case was completed successfully

tags: added: verification-done-bionic
removed: verification-needed-bionic
Jacob Vlijm (vlijm) wrote :

v0.9.7.1 for cosmic has been tested successfully, installed from proposed. Test case was completed successfully.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-artwork - 0.9.7.1

---------------
budgie-artwork (0.9.7.1) cosmic; urgency=medium

  * Bug fix release - Fix Pocillo theme issues (LP: #1811522)
    Raven Styling
    GtkColorChooser border truncation
    Nemo not themed

 -- David Mohammed <email address hidden> Sat, 12 Jan 2019 11:36:23 +0000

Changed in budgie-artwork (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for budgie-artwork has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package budgie-artwork - 0.9.6.1

---------------
budgie-artwork (0.9.6.1) bionic; urgency=medium

  * Bug fix release - Fix Pocillo theme issues (LP: #1811522)
    Raven Styling
    Vertical dock highlighting
    GtkColorChooser border truncation
    GEdit search styling
    Eog zoom truncation
    Ensure Titlebar button are always circular
    Nemo not themed

 -- David Mohammed <email address hidden> Fri, 11 Jan 2019 13:00:22 +0000

Changed in budgie-artwork (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers