bubblewrap 0.2.1-1ubuntu0.1 source package in Ubuntu

Changelog

bubblewrap (0.2.1-1ubuntu0.1) bionic-security; urgency=medium

  [ Iain Lane ]
  * Don't install setuid on Ubuntu & derivatives since Ubuntu's
    kernel enables unprivileged user namespaces (LP: #1795668, LP: #1709164)
  * debian/tests/basic: We're not setuid - in this case we have to use a new
    user namespace. Not all the GIDs from the parent namespace are mapped
    through, and so testing that `id` is identical inside and out of the
    bubblewrap is not going to work. Let's make sure that the euid and egid
    are the same.

 -- Jeremy Bicha <email address hidden>  Tue, 02 Oct 2018 11:03:48 -0400

Upload details

Uploaded by:
Jeremy Bicha on 2018-11-20
Sponsored by:
Steve Beattie
Uploaded to:
Bionic
Original maintainer:
Ubuntu Developers
Architectures:
linux-any
Section:
admin
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic updates on 2018-11-28 main misc
Bionic security on 2018-11-28 main misc

Downloads

File Size SHA-256 Checksum
bubblewrap_0.2.1.orig.tar.xz 204.0 KiB 54b8c805b0ed5c961f6975589c7343b9c3bf1a8987e1593683c670edeee31fe2
bubblewrap_0.2.1-1ubuntu0.1.debian.tar.xz 7.2 KiB a1cb9ad1d6348e7381d0b94c77ee0910566612348c1853d3b2cc8e675fe587ac
bubblewrap_0.2.1-1ubuntu0.1.dsc 2.5 KiB b9b842278712330a2ffabbecd8b0fce6f56c685499ba7e98bbf1385a1c020f1b

View changes file

Binary packages built by this source

bubblewrap: setuid wrapper for unprivileged chroot and namespace manipulation

 Core execution engine for unprivileged containers that works as a setuid
 binary on kernels without user namespaces.

bubblewrap-dbgsym: debug symbols for bubblewrap